Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Icons do not load on startup

10 May 2010   #1

Windows 7 Professional (64-Bit)
Icons do not load on startup

My girlfriend recently bought a new laptop from DELL (Studio 15) w/an i7 processor/4GB RAM/64bit Windows 7 ultimate.

Anyways, she really doesn't do anything on her computer (definitely doesn't need that kind of computer) and only has these programs installed:

  • Mozilla FireFox (I use)
  • Google Chrome (She uses)
  • Picasa
  • CCleaner
  • TeamViewer
  • Verizon Wireless Internet Program
  • AOL Instant Messenger
  • iTunes
  • FrostWire (I hate it, too)
  • Speccy
  • Internet Explorer (Neither of us use)

Anyways, nearly all of those have icons on the desktop and about 50% of the time, when she turns on her computer, either they're all white or none of them show up, at all. She doesn't have to reboot for them to show again, all she has to do is logout and log back in. Although, that is rather tedious to do nearly every time that she turns on her computer.

Any quick fix?

My System SpecsSystem Spec
10 May 2010   #2

Microsoft Community Contributor Award Recipient


See if this helps you out,

Icon Cache - Rebuild
My System SpecsSystem Spec
10 May 2010   #3
BrettM WinTeam


Check out these two sites. They should be able to answer your questions about missing desktop icons!

Fix Missing Desktop Icons [Windows 7]

Desktop icons are gone, taskbar won't show up [Solved]

I hope these help!

Brett M,
Windows Outreach Team
My System SpecsSystem Spec


 Icons do not load on startup

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Why do desktop icons load at log-on, then refresh one at a time?
When I start up Windows 7, the icons on the desktop are all visible to start with, but then the desktop seems to refresh, and the icons all go blank, then re-appear in a painfully slow manner (one or two at a time). This is a very recent clean install of Windows.
General Discussion
Computer takes about 1.5 minutes to load the desktop + icons
Granted my computer's now 4-5 years old. I was wondering if anyone has an idea on this. I ran chkdsk, Malwarebytes, and Ccleaner. All were clear but the last, which fixed many things, but I still have the issue. I have minimal programs that run on start-up, so I highly doubt it's that. I...
Performance & Maintenance
Systray icons never load after re-install
Hey guys I am having an extremely annoying problem. ALL my systray icons,except sound,network and ms security essentials are gone, a reboot doesnt fix it, neither does a reload of explorer.exe,BUT if i log off,and log back in,all icons are present and accounted for. Anyone have a solution to fix...
Performance & Maintenance
Desktop icons and taskbar take ages to load, sometimes never
Guys theres something wrong. I reinstalled windows xp on my harddrive and theres only 1 partition on it which is the current one. I had been getting boot disk failure etc but now that has gone and basically, it loads up the windows logo, and logs in to the desktop, but it takes ages for the taskbar...
General Discussion
Startup programs sometimes do not load
Hello, I have a problem whit startup programs. When I start Windows 7, sometimes some programs do not load at startup. It doesn’t happen all the time and it is not always the same program that doesn’t load, but it occurs randomly. Anyone has got a solution for this? Thanks in advance for your...
General Discussion
Icons in menus and folders load/display slowly
I'm running a reasonably potent system with Win7 x64, and it seems kind of sluggish at loading & handling icons. For example, after a fresh reboot, if I open the Start menu (or whatever it's called in 7) and click on All Programs, I can hear the hard drive being accessed and the icons sort of fill...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:07.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App