Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Search Service/Indexing - Access Denied?


28 May 2010   #1

Windows 7 Ultimate 64-Bit
 
 
Windows Search Service/Indexing - Access Denied?

Hello,

I have been trying to enable the search feature on my windows 7 64-bit machine but when I attempt to do so, or use indexing, nothing seems to happen. When I try to enable windows search in services I get "Windows could not start the Windows Search service on Local Computer - error 5 access denied."

When I detect problems in search and indexing it tells me windows search service is not running but lists the error as not fixed. When I try to manually add a config folder in the ProgramData - Microsoft - Search - Data folder it erases itself after a few seconds.

This account has full admin control, I don't get it. I even tried to do this through the hidden admin account.

This laptop is only a month old but I can't turn the search feature on. I think maybe if I modify it to not include the external in indexing it would not mess up, but I can't even touch the modify button without enabling windows search, which is currently impossible. Any help?

My System SpecsSystem Spec
.

28 May 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Try reregistering the windows installer service:

You want to unregister and then reregister.

1) Start> Run

2) Type in msiexec /unreg

3) Press enter

4) Start> Run

5) Type in msiexec /regserver

6) Press enter

Hopefully that will fix it, if not let us know. A Guy
My System SpecsSystem Spec
29 May 2010   #3

Windows 7 Ultimate 64-Bit
 
 

Naw, I appreciate your suggestion but that didn't work. I have also tried this Index - Windows Search Service - Vista Forums
My System SpecsSystem Spec
.


29 May 2010   #4

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

This could be due to the service having changed itself from the required account (system, network, local) to a different user account. The windows search service should be running under the "Local System Account", check that it is so.
My System SpecsSystem Spec
29 May 2010   #5

Windows 7 Ultimate 64-Bit
 
 

How would I go about checking this or correcting it? If you don't mind me asking

In services under log on it says Local System Account
My System SpecsSystem Spec
29 May 2010   #6

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Click on Start button, then type "Services.msc" without quotes in the Run box or Search box. Locate Windows Search service, see what it says in the right-most column labelled "Log On As". It should read "Local System".
My System SpecsSystem Spec
31 May 2010   #7

Windows 7 Ultimate 64-Bit
 
 

It did. Still no resolution though.
My System SpecsSystem Spec
04 Jun 2010   #8

Windows 7 Ultimate 64-Bit
 
 

this error was in my error logs like 6000 times: The Windows Search Service has failed to remove the old search index. Internal error <0,0x80070005>.

and in administrative events i have it saying
The Windows Search service terminated with the following error:
Access is denied.
and
The Windows Search service terminated unexpectedly. It has done this 198 time(s).

Also found this:
The Windows Search Service is starting up and attempting to remove the old search index {Reason: Full Index Reset}.
My System SpecsSystem Spec
14 Aug 2010   #9

WinXP Pro (x86) / Win7 Pro (x64)
 
 

I had out of the blue this error too. Like you my even log got spammed so massively I keep overclocking the one error message that was actually offering a clue what was wrong.
ACCESS DENIED
When I read that I had a hunch. I checked my "ProgramData" folder and then all down
"Microsoft", "Search"
I can't retell which folders excatly but some where missing permissions.
When I clicked on folder properties and then the security tab the only one with access was my user account.
It should list actually SYSTEM and Administrators at least or windows can't work with these folders.
What I did was first was to delete the whole search folder.
After that I open properties of the program data folder, security tab than clicked on advanced. Clicked on change permissions and then checked the box of "include inheritable permissions from this objects parent". This restored all the permissions. I repeated this for the "microsoft" folder too.
After that windows search recreated the search folder with correct permissions and resumed it work flawless. Of course the whole index has to be rebuild.
My System SpecsSystem Spec
10 Apr 2014   #10

Win 7 64 bit
 
 

Dragoon is right on solving this befuddling problem. Thanks for the great idea-solution.
My System SpecsSystem Spec
Reply

 Windows Search Service/Indexing - Access Denied?




Thread Tools



Similar help and support threads for2: Windows Search Service/Indexing - Access Denied?
Thread Forum
Solved Windows Firewall service will not start, Error Code 5: Access Denied System Security
Solved Windows Search indexing USB sticks Hardware & Devices
Windows Indexing service won't start BSOD Help and Support
Indexing doesn't work. Windows search service stopped General Discussion
Windows Indexing Service not working properly Performance & Maintenance
access denied to a service Performance & Maintenance
Solved: Force Windows Search Indexing Gadgets

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33