Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 isn't working right AT ALL

22 Jun 2010   #31
Microsoft MVP

Win 7 Ultimate x64

Where are you getting teh video and chipset drivers from? With having both a Nvidia chipset and video cards I wouldn't get them from anywhere other than Nvidia (and definitely not through Windows Update),



My System SpecsSystem Spec
22 Jun 2010   #32
Colonel Travis

Black Label 7 x64

Quote   Quote: Originally Posted by DeaconFrost View Post
I can't think of one time since XP's release that System Restore has actually worked or solved an issue for me.

Not one time?
My System SpecsSystem Spec
22 Jun 2010   #33

Windows 7 Ultimate 32 bit

Quote   Quote: Originally Posted by DeaconFrost View Post
I can't think of one time since XP's release that System Restore has actually worked or solved an issue for me. Rather that, problems usually fall into two groups. Either a relatively quick fix, that leaves the issue completely resolved (rather than a roll back that could re-occur), or a simple repair install fixes the problem, leaving the computer at a normal operating mode. Reinstallation, for me, is never a troubleshooting tool, unless I have no faith in the OS's stability or security anymore, such as one so badly infected with malware that even after total removel, random issues still occur. If a driver or app is the issue, you have driver rollbacks or safe mode for removal, followed by something like Driver Cleaner or CCleaner. Windows 7 even has a great system image utility built-in that would do the same rough job as System Restore (only more complete). If anyone is running WHS at home, you have even better options still.
I can only think of two times, since the release of XP, that system restore has not worked for me.
My System SpecsSystem Spec

23 Jun 2010   #34

windows 8.1 Pro x64

Quote   Quote: Originally Posted by DeaconFrost View Post
I'll break our tradtition and agree with you on this one. Although running it on a system with 2 GB cancels out one of it's biggest benefits, Windows 7 x64 should run just fine with only 2 GB of system memory. You will have slightly less headroom for apps, given the fact that x64 OSes use a little more memory, but that doesn't mean you'll have issues with stability. I also had a system running on 2 GB while waiting for a memory upgrade, and it ran just fine.
also agree, when I was testing the RC build my laptop only had 1 gig for a while before I upgraded it.

I checked the op's specs and I fail to see why he had so many graphics card issues, his card is a 7900GT, my test machine has a 7600GT and works out of the box with the windows drivers as well as nvidia drivers.
My System SpecsSystem Spec
23 Jun 2010   #35

Windows 7 Ultimate x64 SP1

Quote   Quote: Originally Posted by Colonel Travis View Post
Not one time?
Honestly, not one. It had many chances to try though, thanks to family and friends who don't like a working, running system apparently.

The fix, for me, has always been just as easy and always more effective to tackle to issue at hand directly, rather than cover it up. Like I said above, there are always other ways. Driver's can be rolled back or removed. Apps can be removed in safe mode, or forceable removed. Malware can be removed, thanks to some nice, free tools. If the system isn't booting, a repair install does the trick. It's honestly to the point I haven't even tried a system restore in the last 6 months or so, because the time I wasting trying system restore, can be better spent fixing the actual problem.
My System SpecsSystem Spec
23 Jun 2010   #36


A repair install cannot be done if the System isn't booting.

Repair Install

Startup Repair
My System SpecsSystem Spec
24 Jun 2010   #37

Windows 7 Ultimate x64 SP1

Quote   Quote: Originally Posted by gregrocker View Post
A repair install cannot be done if the System isn't booting.
You're combining two separate issues. If the system doesn't boot, you can run a startup repair, which happens to work very well. If the system is booting, but is experiencing odd issues, such as one might after a malware infestation, you can repair it. Windows 7 handles these differently than previous OSes, as in they are two separate processes, but either one can be used.
My System SpecsSystem Spec
26 Jun 2010   #38

Windows 7 64 bit

stormy - I let the Windows Update install the driver for the video card the first time, and when it fragged the system (it was obviously the update since that was the first thing I did after the install) I haven't touched it since. I've been getting drivers straight from Nvidia, or from 3dguru (I think) who apparently gets nvidia drivers before they post to Nvidia's site. My system just doesn't like those later drivers I guess...

And, back to sys restore, I can think of ONE time it worked, when I installed some video drivers and the video was fragged after the reboot. I couldn't roll back the drivers manually, so I went to SR and it did roll back the drivers, so yeah it worked. Didn't fix the fragged video though, so had to reinstall anyway...
My System SpecsSystem Spec
26 Jun 2010   #39


It can even SysRestore when the OS won't boot, using the Repair CD or DVD Repair console. SysRestore is built into Startup Repair, but can also be run separately from the Recovery Tools list.
My System SpecsSystem Spec
24 Mar 2011   #40

Windows 7 Professional 64 bit

I had a heap of problems too. I hired a good tech guy. Some of things he did was disable UAC and DEP, then remove Roboform off the 64 bit version of IE 8, and set me up with the 32 bit version with same. He worked at lightning speed and had all my blue screens, freezups and crashes cured within an hour, including installing the correct drivers for my printers etc., that didn't work. To say have you tried reinstalling windows is a really dumb place to start I'm sorry to say. That would be as foolish as ripping out your engine because your signal light doesn't work.
My System SpecsSystem Spec

 Win 7 isn't working right AT ALL

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Sound on Laptop and Desktop Randomly Stops Working and Working
So recently the sound on my desktop and my laptop has stopped working. For seemingly no reason. I really don't understand it. I first noticed it with my desktop. The sound just randomly stopped working. But not...entirely. It's really strange and complicated what's been happening, so bare with...
Sound & Audio
mother boad DZ75ML-45k: Streo is working and 5.1 one is not working
Hi Friends, I bought Zebronics cabinet and the mother boad is DZ75ML-45k. I've installed the motherboard CD. In Sound, Streo is working and 5.1 one is not working. In 5.1, front L ,R is working. rear L&R, Center and subwoofer is not working. Kindly find below the screen shot. Thanks...
Sound & Audio
My mouse Usb port stops working. but starts working again after a day.
Hello! I'm using my laptop in a desktop mode. but some days when i start up the computer the mouse is on (Sees the red optical light.) But the cursor dont move when i move the mouse. when i drag the cable out and in again the ligh wont turn on. i change usb port and it works. 1-3 days later the...
General Discussion
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Windows 7 not updating, Indexing not working, search not working, FYI
I had been working an issue where the search function was not working correctly, I then noticed that Indexing was not working and I could not update windows. I wanted to post this in case someone had similar issues, it took me a while to figure this one out... The problem likely started when I...
Windows Updates & Activation
HDMI Sound randomly not working - test in settings gets it working?
I have started having an issue over the past week (config/drivers/etc not changed in months) where sound will randomly not be output by HDMI. System config/specs... Win7 SP1 all patches, nearly a stock install... only running WMC and XBMC. Only 3rd part stuff installed are SpeedFan an ATI...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:58.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App