Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: svchoste.exe problems

23 Jun 2010   #1
shawaj

7 64bit
 
 
svchoste.exe problems

Hi,

I am having problems with svchost.exe using up loads of cpu - approx 50% on a dual core 3.4ghz.

I have been trying to sort this for the last week using google etc but no luck so trying here now!

I am running win7 x64.

The services running under the 2 offending svchost.exe processes are:

Audiosrv
Dhcp
eventlog
lmhosts
wscsvc

BFE
DPS
MpsSvc

Could anyone help me out?

Thanks in advance


My System SpecsSystem Spec
.
23 Jun 2010   #2
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

You may want to download and run Malwarebytes (free download) to see if you have any Malware issues. Malwarebytes
My System SpecsSystem Spec
23 Jun 2010   #3
shawaj

7 64bit
 
 

ok just running that now...will update if that fixes it
My System SpecsSystem Spec
.

23 Jun 2010   #4
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

It won't fix the issue for you but will identify actual Malware on your PC that may be causing the issue, action to remove the Malware needs to be undertaken by you, it just points to where the offender(s) are.
My System SpecsSystem Spec
23 Jun 2010   #5
shawaj

7 64bit
 
 

no malware found...
My System SpecsSystem Spec
23 Jun 2010   #6
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

Well that is good news, next question is are your drivers and updates for Windows up to date?
My System SpecsSystem Spec
23 Jun 2010   #7
shawaj

7 64bit
 
 

i just installed some updates, and after they installed it worked fine, i then restarted again to see if it was a coincidence...and sure enough it happened again.

as far as i know my drivers are up to date, although i think this could be a problem with a creative sound card i tried to install.

i have now uninstalled it and got rid of all the software, but it is still happening to maybe not.
My System SpecsSystem Spec
23 Jun 2010   #8
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

Monitor it for a little bit, if it returns I used the following on a friends PC due to the same issue to identify what process using svchost was actually eating up the resource. svchost viewer It takes a few seconds to download and install and several minutes to run, it identifies everything using svchost and how much resource it is using and should help you pinpoint the offender.

Almost forgot to add that you should not allow the automatic updates from Creative run with Windows 7 this has been an ongoing issue and you should check for updates via their website.
My System SpecsSystem Spec
23 Jun 2010   #9
shawaj

7 64bit
 
 

ok i am running that now...

there also seems to be quite a high "hardware interrupts@ cpu usage.
My System SpecsSystem Spec
23 Jun 2010   #10
shawaj

7 64bit
 
 

i had a look at the svchoste viewer thing, it only shows amount of memory being used, not cpu, so not quite sure how to identify which process is eating up the cpu?
My System SpecsSystem Spec
Reply

 svchoste.exe problems




Thread Tools




Similar help and support threads
Thread Forum
Many problems with video errors and somehow RAM problems
Okay so for a while now i have been having many problems. First off i had a PC with the video card i am using right now(Nvidia GTX 295), and it has been "losing signal" and just plain old crashing. So i bought a PC off my uncle. Its got reletivly good hardware, but i am still getting the same...
General Discussion
USB Problems, Errors and port problems!
I have a Dell Inspiron 1545 laptop, not to long ago I had to replace my hard drive. After that I reinstalled windows 7. Before this the usb devices would charge just not be recognized. Now only ONE port does everything (charge, sync, etc.) the other two just stopped working. I have no clue if its a...
Hardware & Devices
Can't start up my computer. (Driver problems, BSOD, other problems)
Hi I hope I'm placing this in the right section, if not, then could someone tell me where to put it and I'll post it again. I've got a Samsung RV510 laptop with Windows 7 HP 64 bit. About 2 weeks ago, I was watching a Youtube video, had Spotify and Facebook open too, and my computer...
BSOD Help and Support
extract problems, random BSOD errors all those problems
hi guys i dunno why i have many problems with win7 since installation and so far btw i wrote many topics before about my installation and eventually i didn't found any solution so i took my pc to computer shop and they solve the problem after that i installed win7 without any problems...
BSOD Help and Support
Windows Index Problems a.k.a Windows Assesment Problems
Hi, I have had Windows 7 for a while now and have continually tried to run windows assesment tool for a while now, but each time I run it, it always ends up having a problem when it starts "Tuning Windows Media Decoding" and ends up closing. This is not terribly important but I was just wondering...
Performance & Maintenance
Problems leading to problems...
Hello, I am new to the forum, and I am hoping someone can help me out. I am attempting to install Win 7RC 64 bit on my system and seem to run into another problem as soon as I solve one. I am now at a problem that has me at a loss. Bear with me as I outline what I have done so far. I had...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App