Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Has anyone used the new ATI 10.8 drivers ?


27 Aug 2010   #1

Windows 7 Home Premium 64bit sp1
 
 
Has anyone used the new ATI 10.8 drivers ?

I wondering if anyone used the new ATI driver because now i am leary of using a newer driver seems like ATI updates drivers to often with more and more less stability recently when i updated to 10. 7 v i was having bsod on my left4dead2 found out i had a corrupted file and was fixed

Now i play left4dead2 the game not all the time but randomly with just close out disappear i am thinking it is a driver issue can someone tell me if this driver is stable at all cause it is getting ridiculous to update this driver when before i had no issues

I f this continues im going to go back to the 10.5 cause i just dont see the stability

Thanks for any pros and cons on this matter im sure someone has a good idea of what this new driver is about

My System SpecsSystem Spec
.

27 Aug 2010   #2

7 Ultimate x64
 
 

I'm using 10.8. So far they're great. Most importantly, they do no harm; I can't say the same for 10.7. While I understand some old titles still have issues, all my old games run fine.
My System SpecsSystem Spec
27 Aug 2010   #3

 

Quote   Quote: Originally Posted by Fumz View Post
I'm using 10.8. So far they're great. Most importantly, they do no harm; I can't say the same for 10.7. While I understand some old titles still have issues, all my old games run fine.
unfortunatelyit does seem to cause problems in some games, the problem seems to centred around the mouse moveing.
My System SpecsSystem Spec
.


27 Aug 2010   #4

Windows 7 Home Premium
 
 

I'm using them but I don't game. When I installed the os I just used the factory driver it provided bit when I'd lock my comp and come back to it later I'd have a black screen and would have to restart. So I decided I probably wasn't getting the best performance from my bid card and went ahead and installed the latest drivers and so far so good. But the test will be when I get home this evening, hopefully no black screen.
My System SpecsSystem Spec
27 Aug 2010   #5

Windows 7 Home Premium 64bit sp1
 
 

I had a mouse issue with the 10.7 i updated to 10.8 now but when i was playing left for dead the mouse would lag like i needed batteries and i ended up swapping them out it seemed to work better but did it again the next day

Left4dead 2 is not that old of a title and it loaged occassionaly with the mouse
My System SpecsSystem Spec
27 Aug 2010   #6

Windows 7 ultimate
 
 

I was about to install it as I thought it couldn't be as worst as 10.7 I'm actually only playing SC2 and Mafia 2. Should I install the driver, though?
My System SpecsSystem Spec
28 Aug 2010   #7

Windows 7 Home Premium
 
 

Well, got home a little while ago, woke my rig from sleep mode and all is well!
My System SpecsSystem Spec
28 Aug 2010   #8

Windows 7 Enterprise
 
 

Just update from 10.7 to 10.8.

Truthfully, I haven't seen any difference whatsoever.
My System SpecsSystem Spec
Reply

 Has anyone used the new ATI 10.8 drivers ?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33