Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Catalyst wont load.

28 Aug 2010   #1

 
Catalyst wont load.

Hello (waves)

Just updated recently to a new system and finally brought windows 7 Home premium but for some reason the graphics card won't register properly. I have tried 3 different versions of Catalyst (including the suggestions in previous posts on this board AND the original GC driver disc, which crashed the system).
Even stranger is the fact that CCC.exe is running in my processes yet after initial boot up, I get a message saying that Catalyst will not start properly and to install the right software for the hardware.
My card ran fine on XP, but not with Windows 7.

System;
HIS ATI HD 5750 1GB IceQ
Athlon II X2 240 @ 2.8ghz
Cheap motherboard (American Megatrends? that's what's displayed on initial screen)


My System SpecsSystem Spec
.

28 Aug 2010   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by dAnnybOy66 View Post
Hello (waves)

Just updated recently to a new system and finally brought windows 7 Home premium but for some reason the graphics card won't register properly. I have tried 3 different versions of Catalyst (including the suggestions in previous posts on this board AND the original GC driver disc, which crashed the system).
Even stranger is the fact that CCC.exe is running in my processes yet after initial boot up, I get a message saying that Catalyst will not start properly and to install the right software for the hardware.
My card ran fine on XP, but not with Windows 7.

System;
HIS ATI HD 5750 1GB IceQ
Athlon II X2 240 @ 2.8ghz
Cheap motherboard (American Megatrends? that's what's displayed on initial screen)

Different driver of win 7 than XP. you need to remove the current driver completely and download the correct one and install it
When upgrading your graphic driver you MUST remove all traces of the current driver. In order to do that we recommend using Guru3D - Driver Sweeper

When it is removed then download and install the fresh copy.
My System SpecsSystem Spec
28 Aug 2010   #3

 

Hmm, ok I do realise that. Im not a complete noob. I did get the latest vista driver from the AMD site, plus 10.4 and 10.7. as recommended by a previos poster on this forum that had a similar problem
I'll try your recommendation and see what happens.
My System SpecsSystem Spec
.


28 Aug 2010   #4

 

Oops. Got it going. now windows update is trying to throw me an ATI update. So fingers crossed.
My System SpecsSystem Spec
28 Aug 2010   #5

 

OK, so I ran the sweep and ran windows update and wouldn't you know it?, it included the ATI 5700 series driver!
Thanks Zigzag! running the sweeper screwed up the settings enough for it to fix itself! lol
My System SpecsSystem Spec
Reply

 Catalyst wont load.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33