Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI RADEON X1300 PRO Problem

15 Sep 2010   #1

Windows 7 Home Premium (64 bit)
ATI RADEON X1300 PRO Problem

I wasn't sure where to put this since it's specific to this exact video card, so I started it's own thread. If need be, feel free to move it where necessary.

I've been using the ATI RADEON X1300 PRO card on & off for a while now and even in my new system I am encountering the same intermittent problem. What's happening is that when you reboot or power up the PC, the screen will appear to be scrambled. To best describe this, think of turning your vertical and horizontal controls all the way in one direction on your TV. Unwatchable. However, since you cannot see the screen once Windows loads, you have no choice but to force a shutdown by pressing & holding the power button on the PC. Start up again, and all is well. I have checked for new drivers and installed where applicable. I'm thinking a hardware problem with the card itself perhaps? Any thoughts?

My System SpecsSystem Spec
15 Sep 2010   #2

Windows 7 ultimate 64 bit / XP Home sp3

Welcome to Seven Forums.
My thinking is since you experience this problem with the card in different systems it's probably the card itself going bad.
Do you have a different card you can try and see if you still have this issue?
If you don't it would pretty much narrow it down to the card. Fabe
My System SpecsSystem Spec

 ATI RADEON X1300 PRO Problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Using integrated graphics with ATI Radeon X1300/X1550 Series
I have just very recently as today started using a new PC with Windows 7, Dell Optiplex 745/755, 8gb, 160gb hdd. Dual monitors is important to me so i got a ATI Radeon card which fitted in and works. My problem being is that on my other PC, Optiplex 520 running XP, i had a Nvidia Quadro 280 PCI...
Graphic Cards
Mobility Radeon X1300 not working on Windows 7
Hi all, I have upgraded to Windows 7 Ultimate 32 bit, I am having problems with my Dell Inspiron E1505 / 6400. The Mobility Radeon X1300 can't be detected at all. I cannot run games such as World of Warcraft, or Mass Effect, unless the drivers work. I have installed Catalyst 8.12 drivers...
ATI Radeon X1300 series
Hi... I installed windows 7 on my Intel 865G with built in VGA & sound card. All works fine except VGA. I used ATI Radeon x1300 series 3d card abd after installing that i am facing distortion in my sound card. can anu one tell me that what i must do to solve this
Radeon X1300 Pro?
Alright, well I've been on a budget and I just recently had some hardwre failures on my previously 7-compatible PC, so I decided to buy some newer (but cheaper) parts off eBay to rebuild, I went with a socket 775 board and a Dual-core pentium (seeing as my old system was an old Athlon 64), so...
Graphic Cards
Radeon X1300 issue
After reviewing the forum, I see several people having trouble with getting the ATI Radeon X1300 graphics card to work with Windows 7. None of the solutions worked for me (so far)... I've tried several iterations of Catalyst, including the most recent version, but none of those would work on my...
Graphic Cards
Windows 7 & ATI Radeon X1300
I have recently installed Windows 7 RC and I successfully install the WDM Integrated Driver for Radeon X1300 but when i reboot my computer windows decides to rollback to its original PCI standard PCI-to-PCI bridge. Now I am left with two PCI standard PCI-to-PCI bridge drivers installed and one has...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:31.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App