Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 4 Monitor Setup - Not Working - Help Plz


26 Sep 2010   #1
the

Win 7 64 bit
 
 
4 Monitor Setup - Not Working - Fixed !

Hello Everyone,

After long deliberation I went ahead and bought new PC. The purpose is run 4 monitors with two grahics card, however so far I've no luck. I udpated the drivers, searched on Google and searched here.

Here is my configuration:
Intel i7 – 950
Gigabye X58A-UD3R
2 x Gigabyte HD 5570
Win 7 64 Bit

The two card are connected via bridge and under "Catalyst Contol Center" CrossFirex is enabled.

Right now only 2 monitor works and they both conneted to same graphics card. If I swap the cables then other 2 monitor works, which tell me that one card is not working at all. However both cards are detected under Device manager.

Any help is highly appreciated.

Regards

My System SpecsSystem Spec
.

26 Sep 2010   #2

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

This might not help but your psu is a bit weak.
My System SpecsSystem Spec
26 Sep 2010   #3

Windows 7 64bit
 
 

I am under the impression that 4 monitors will not work under crossfire. What are you trying to achieve? Do you want a single desktop to span 4 monitors or do you want to play games?
My System SpecsSystem Spec
.


26 Sep 2010   #4

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

Have you tried 3 alone?
My System SpecsSystem Spec
26 Sep 2010   #5
the

Win 7 64 bit
 
 

Thanks for taking time to reply everyone. I am not using this PC to play games. All I want is display stock market charts on all 4 screens.

No, I've not tried 3 monitors. I am using DVI and VGA connections only, haven't tried HDMI connection yet.

Please let me know if you have any suggestions
My System SpecsSystem Spec
26 Sep 2010   #6

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

Do you have the correct drivers installed for crossfire. I have been reading the hotfix 10.9a driver fixes most issues for crossfire.

Motherboard/ Integrated Video Drivers for Windows 7 64-Bit edition

check you have all drivers installed
My System SpecsSystem Spec
26 Sep 2010   #7
the

Win 7 64 bit
 
 

I've already updated drivers from that link. It seems that 1 card is not working even though it is detected in Device Manager
My System SpecsSystem Spec
26 Sep 2010   #8

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

Quote   Quote: Originally Posted by the View Post
I've already updated drivers from that link. It seems that 1 card is not working even though it is detected in Device Manager
what about your bios?
My System SpecsSystem Spec
26 Sep 2010   #9
the

Win 7 64 bit
 
 

Hi Prof,

I am not sure exaclty what you are referring to in BIOS. Can you please elaborate?
My System SpecsSystem Spec
26 Sep 2010   #10

Windows 8.1 Professional x64
 
 

Have you tried it with the crossfire bridge off? I don't use ATI, but with Nvidia you can't use the second card for video output if the SLI bridge is connected, as it disables the outputs.
My System SpecsSystem Spec
Reply

 4 Monitor Setup - Not Working - Help Plz




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:21 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33