Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Radeon 5970 prevents the computer from booting from the first time

17 Dec 2010   #1

Windows 7 Ultimate x64
Radeon 5970 prevents the computer from booting from the first time

My new Radeon 5970 won't allow the computer to boot from the first time. I have to keep the power button down until the computer powers down and then press it again for it to boot fine. I can hear the fans, the CPU and the HDD working fine, but for some reason the PC won't boot from the first time.

I am using Catalyst 10.12, Windows 7 x64.

I have tried everything, including a clean Windows install on my other partition. I remember at first things weren't like that and it did boot up, but now it just won't do it from the first time.

Some times, if I reboot it like 10 minutes after I have shut it down it may start fine, but if it's longer than that, no chance.

Help me, please.

My System SpecsSystem Spec
17 Dec 2010   #2

Windows 10 Home Premium 64bit sp1

I know what you mean it lags the boot process the 6870 does the same thing it lags me as before the hd5770 didnt do that
My System SpecsSystem Spec
17 Dec 2010   #3

Windows 7 Home Premium (64-bit) SP1 RTM

The DX58SO motherboard had an issue which was fixed in BIOS 5390 June 14th 2010, where certain graphics cards can cause the system to fail to boot. This sound like your issue.

Latest BIOS should be:
(always check incase i've linked the wrong one)

BIOS Version 5506 - SOX5810J.86A.5506.2010.1109.0004 November 9th 2010

If you're not familiar with updating the motherboard BIOS, read up on the procedure. Take a note of any setting that need to be re-applied before you update. As always, be carefull, an incorrect update can break your motherboard.
My System SpecsSystem Spec

17 Dec 2010   #4

Windows 7 Ultimate x64

Yes, I am using the latest BIOS and chipset drivers.

I have tried different drivers, a fresh Windows installation, BIOS update, and the only thing I haven't tried actually is update of the vBios itself. Do you know where I can find the latest vBios for my VisionTek card ? Google is not very helpful, nor is VisionTek's official site.
My System SpecsSystem Spec
17 Dec 2010   #5


If it occurs outside of Windows - it's not a driver issue.

Have you tried balancing the PSU rails? (So that the CPU and Card aren't both on v1) etc

It sounds like you are overloading your PSU
My System SpecsSystem Spec
18 Dec 2010   #6

Windows 7 Ultimate x64

My PSU is 750 W, the card, according to its specs requires only 650 W. I changed my PSU especially for that purpose.

What does "balancing the PSU rails" mean ? I hear it for the first time. Also, what is V1 ?

Maybe I should mention that the problem wasn't so heavy at first and happened only occasionally and now it happens every time.

I have a fan on my hard disk which plugs into the PSU directly, maybe it is part of the problem ?

Edit - I tried Google, but I am totally not sure what I even need to read in order to do that properly. Can you give me a link, please ?

My PSU is Chieftec A135 750W.

Edit 2 - I checked this post over there and it mentions the card needs 50 A, but I am not sure if the PSU can provide that. How can I check ?

Edit 3 - Here are my full hardware specs again.

Windows 7 Ultimate
Core i7 2.68
DX58SO with latest BIOS
Chieftec A135 750W.
My System SpecsSystem Spec
18 Dec 2010   #7

Windows 7 Ultimate SP1 (64-bit)

Hi, Dellius.. here are the specs for your PSU

It reads that it delivers only 18A on the +12v rail, so i guess it's the PSU not being able to deliver enough power.

For a High End PC, you need a decent PSU, here's an example of what you could buy

It delivers 70A on the 12v Rail... and has 850w, more than you need but it will be perfect for your build
My System SpecsSystem Spec
19 Dec 2010   #8

Windows 7 Ultimate x64

OK this helps, but is it true the card needs 50A ? Where can I confirm this ? The official manufacturer's site is not much help, nor is the product manual.

Edit - nvm, I am just going to call the card manufacturer's official support line on Monday.
Edit 2 - holy maholy, this PSU costs just a little more than my present PSU.
My System SpecsSystem Spec
19 Dec 2010   #9

Windows 7 Ultimate SP1 (64-bit)

Taken from Guru3D:

Recommended Power Supply

So here's my power supply recommendation:

Radeon HD 5970 (dual GPUs)

  • The card requires you to have a 600 Watt power supply unit at minimum if you use it in a fairly high-end system. We assume you'll overclock your processor and that draws a lot of extra power. That power supply needs to have (in total accumulated) at least 50 Amps available on the +12 volts rails

Radeon HD 5970 CrossfireX (quad GPUs)

  • A second card requires you to add another 294 Watts. Be on the safe side please, have some spare Wattage as here we are sure you are overclocking your processor as well. You need a Kilowatt Watt power supply unit if you use it in a high-end system. That power supply needs to have (in total accumulated) at least 70 Amps available on the +12 volts rails.

There are many good PSUs out there, please do have a look at our many PSU reviews as we have a lot of of recommended PSUs for you to check out and read up on.

I guess that solves your wondering....ment! hehe..

So i would definitely recommend a good PSU for that 5970.
My System SpecsSystem Spec
21 Dec 2010   #10

Windows 7 Ultimate x64

OK sorry for the silence the past two days, I was having my PSU changed by the wise guys who recommended my last one.

Anyway, I got them to install the CORSAIR CMPSU-850TX 850W ATX12V 2.2 / EPS12V 2.91 SLI Ready CrossFire Ready Active PFC Power Supply and now it boots just fine.

Thank you guys.
My System SpecsSystem Spec

 Radeon 5970 prevents the computer from booting from the first time

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Should i sell my Dual Ati Radeon 5970's to get 1 Ati Radeon 6990 4gb?
ok, well here's the problem, ive been trying to max out battlefield 3 at ultra high setting with my comp, (GPU: Dual Ati Radeon 5970's, CPU: Intel i7 920 (overclocked to 3.8ghz), PSU 1200W, OP window 7, Ram: 6gb (1333mhz)) but i im getting extreme lagg, my FPS will randomly drop from 60-70 FPS to...
Graphic Cards
ATI Radeon 5970 Dedicated Memory Issue
I've been having problems with my video card's dedicated memory. It's been taking up 2g of my memory sometimes and sometimes it doesn't. When it takes the 2g i've noticed a slow down when running high end games, and it runs slower while multi-tasking. Some said this was normal, but I don't want...
Graphic Cards
XFX Radeon HD 5970 BE LIMITED 4 GB
My car is not worth this much: - XFX HD-597X-ENFN Radeon HD 5970 BLACK 4GB 512 (256 x 2)-bit DDR5 PCI Express 2.1 x16 CrossFireX Support Eyefinity 6 Edition Video Card
Graphic Cards
ATI Radeon 5970 vs SLI GTX 480 (Fermi)
As promised from a previous post I'd start posting reviews as my friend and I put our cards to the test. My Build: OS Windows 7 Home Premium 64bit CPU AMD Phenom II X6 1090T Black Edition Thuban 3.2GHz Motherboard MSI NF980-G65 AM3 NVIDIA nForce...
Graphic Cards
Dual ATI Radeon 5870 vs ATI Radeon 5970
I NEED HELP DECIDING! ( again :rolleyes:) which one should i get for my new computer, i have effeicient power supply and processor for both, a Dual 1 GB GDDR5 ATI Radeon HD 5870, or a single 2GB GDDR5 ATI Readon HD 5970? help me decide!
Graphic Cards
Radeon HD 5970 detailed in advance
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:48.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App