Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound through HDMI?

17 Dec 2010   #1
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 
No sound through HDMI?

Ok I don't have any sound coming through my HDMI

I have the SPDIF hooked up from the mobo to one of my two graphics cards.

I have 2 Asus Nvidia 9800GT

The HDMI is going to a 46" Samsung 750

Technically I have the HDMI and SPDIF set up through the card that is in PCIx16 #2

Does it have to be hooked up through PCI #1?

Suggestions on how to get this to work?

Thanks.


My System SpecsSystem Spec
.
17 Dec 2010   #2
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

HDMI has its own sound on most if not all video cards.
That is what I have read at least.
SPDIF would go direct to the TV wouldn't it?
TV and moboard manual might or should tell you how to set it up.

HDMI on my Asus you run it straight to TV or monitor with speakers.
I haven't tried it but my video card instructions say to do it that way.
It has its own Nvidia sound card built in.

Hope that helps and sorry if it doesn't.
Mike
My System SpecsSystem Spec
17 Dec 2010   #3
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

The SPDIF is internal and goes from mobo to graphics card per nvidia SPDIF instructions. (there is a special SPDIF port on mobo)

The only thing goin from computer to tv is HDMI (which does both video and sound)

Tv has built in speakers.
My System SpecsSystem Spec
.

17 Dec 2010   #4
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

I switched everything to PCI #1 and still no dice.

The SPDIF port on the other card was different from the first card I tried even though they are the same card which is weird.

Do I have to enable sound through HDMI somewhere in win7?
My System SpecsSystem Spec
17 Dec 2010   #5
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

I should note that under sound in the control panel, there is no HDMI icon?

Just Digital Output and Speakers?

Why isn't it showing HDMI?

And mods please move this to sound. Thanks.
My System SpecsSystem Spec
17 Dec 2010   #6
Sardonicus

Windows 7 Home Premium 64 bit
 
 

When you right click on the volume icon, and select playback device, do you see the HDMI device?
If so, you need to select it.
My System SpecsSystem Spec
17 Dec 2010   #7
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Hopalong X View Post
SPDIF would go direct to the TV wouldn't it?
Not on the Nvidia 8xxx and up (8xxx, 9xxx, most of the GT/GTS/GTX 2xx) series cards that, for those you have to do the following,

Guide: 8800GT/9800GT/9800GTX Sound over HDMI (Now including Creative cards) - Overclock.net - Overclocking.net

A few of the low end G and GT 2xx cards do have a built in sound card like the 4xx seties and up (there was even a rare OEM version of the 7600 called the 7650 GT that had built in audio and a HDMI port).

Quote:
The SPDIF is internal and goes from mobo to graphics card per nvidia SPDIF instructions.
Seeing as you have a TB card listed for sound you have the onboard audio enabled and the drivers for it installed if you are connecting to the motherboard header?
My System SpecsSystem Spec
17 Dec 2010   #8
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

No that's what I was referring to. HDMI isn't showing up at all in playback devices?
My System SpecsSystem Spec
17 Dec 2010   #9
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Did you connect the SPDIF cable to the motherboard header or the one on the sound card?

If the motherboard, is the onboard audio enabled and the driver for it installed?
My System SpecsSystem Spec
17 Dec 2010   #10
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Did you connect the SPDIF cable to the motherboard header or the one on the sound card?

If the motherboard, is the onboard audio enabled and the driver for it installed?
I'm using mobo SPDIF

I guess I don't know if the inboard audio is enabled and the drivers are installed? How can i tell?

For some reason I remember having to disable the onboard to make my turtle beach card work, but I could be wrong.
My System SpecsSystem Spec
Reply

 No sound through HDMI?




Thread Tools




Similar help and support threads
Thread Forum
No sound through HDMI
A few days ago, I plugged a HDMI cable into my new laptop and watched a few videos on my HDTV. No problems whatsoever. Since then though, every time I plug in the HDMI cable, the video comes through just fine, but there's no sound. I've found several threads with similar problems, both here and on...
Sound & Audio
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all....
Sound & Audio
NO SOUND TROUGH HDMI ON ACER AX3400-U3032 and No HDMI Icon in sound se
Had to replace motherboard from authorized acer parts dealer now I get no sound through HDMI port. I did through the original board until it got fried by electrical surge. Can any one help or send me a picture of the inside the same model to make sure all jumpers on the motherboard are in the...
Sound & Audio
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
no sound through tv via hdmi, sound plays through laptop speakers (idt
Yesterday I installed a new external hard drive - following the installation - my sound no longer played through my television (video is fine, HDMI connection) and sound now comes ONLY through the laptop speakers. The option for HDMI Audio doesn't appear in the 'sound' menus. I have 'checked'...
Sound & Audio
No sound via audio jacks, but sound via hdmi.
I recently done a new build, not with the same specs I have on here; i5 2500k p8z77-m pro sapphire radeon 6870 I cannot get any sound through the front+back headphone jacks, realtek doesnt detect any audio devices, however i can mess around with the settings to get windows to say i have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App