Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Nvidia Website Bug! Attention.


18 Dec 2010   #1
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 
Nvidia Website Bug! Attention.

Hello, Forum!

I'm posting this today because i found a little bug in Nvidia's Website

Let me upload a Pic for you guys to understand a little bit better what i'm talking about, this bug only affects users who try to download Nvidia's GeForce 8 Series drivers, not even GeForce 8M Series (Mobile), only GeForce 8 Series, the bug is that you can't select Win7 as an OS for your Download, i know this may be a stupid bug but there are a lot of users out there who doesn't know that and they could be confused!




Solution: Download another GeForce Series Driver, I.E.: Nvidia 9 Series Drivers

DO NOT download GeForce 500 Series Drivers because they're only compatible with GTX 580/570 and DO NOT download GeForce 400 Series (GTX 460SE) because it's the same driver that GTX 580/570 uses, download any other one.

Here's a Direct Link to 260.99 WHQL Drivers:

64-bit: NVIDIA DRIVERS 260.99 WHQL
32-bit: NVIDIA DRIVERS 260.99 WHQL

Check under Supported Products to see if your card is supported, if not, then you must look for another driver in the "Nvidia Driver" section.

Cheers, Forum!
Punkster.


My System SpecsSystem Spec
18 Dec 2010   #2
Everlong

Windows 8.1 Professional x64
 
 

Hmm?

-nvdriver.png

How many times as this happened. If it's just the once then it was probably just a bug in loading the webpage.

Edit: Helps if I upload the right screenshot.


My System SpecsSystem Spec
18 Dec 2010   #3
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

wow, which browser are you using, Everlong? cause this bug has been in Firefox for at least 2 ~ 3 weeks.. i've tried refreshing the website, closing the browser, restarting the PC! nothing, i guess it only affects some users, who knows...
My System SpecsSystem Spec
18 Dec 2010   #4
arkhi

Windows 2000 5.0 Build 2195
 
 

Tried on IE9/Win7, FF 3.x(something) and IE6 on WinXP Sandbox (just to be sure it's not a browser or User Agent issue) and I can select Win7 on all of them.
My System SpecsSystem Spec
18 Dec 2010   #5
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Does not happen for me either ,I see 7 32 & 64bit drivers


Attached Thumbnails
-untitled.png  
My System SpecsSystem Spec
18 Dec 2010   #6
Airbot

Windows 7 Ultimate x64 SP1
 
 

No problem with it here either. Using Firefox 4 Beta 7.

Same on the geforce.com site as well. All good.

GeForce.com - Get the Most Out of Your GPU
My System SpecsSystem Spec
18 Dec 2010   #7
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Now, this is weird, i can't select Windows 7 OS with GeForce 8 Series Drivers, i can with any other driver with no issues, haha, this is weird.. let me see if i can upload a video, i don't want to make a fool out of myself here

I've tried all options and they show Win7 OS to download the driver, only with 8 Series shows the bug, i don't think this is related in any way to the fact that i have a 8 Series Video Card, that'd be a diabolic possesion of my Desktop hehe

EDIT: Airbot, with the link you provided, i have no problems to select Win7 OS and GeForce 8 Series. weird thing, is weird
My System SpecsSystem Spec
18 Dec 2010   #8
Airbot

Windows 7 Ultimate x64 SP1
 
 

Try a different browser. Or it could be something you're using in FF is screwing it up.
My System SpecsSystem Spec
18 Dec 2010   #9
Punkster

Windows 7 Ultimate SP1 (64-bit)
 
 

Problem Solved!

I guess it has to do with the fact that i'm using a Spanish Version of Firefox in a Spanish Version of Windows 7 and that i was trying to access Nvidia's Global English site! Look what happened when i accessed Nvidia's "Latin America" site!




EDIT: here i added a pic to show what happens if i try to access nvidia's global english site! see? no Windows 7/Vista OS selectable for download



Again, this is an unusual Bug! but the problem is solved by now

Cheers, Forum.
Punkster!
My System SpecsSystem Spec
Reply

 Nvidia Website Bug! Attention.




Thread Tools



Similar help and support threads for2: Nvidia Website Bug! Attention.
Thread Forum
ATTENTION Crucial M4 SSD owners News
ATTENTION - Your smartphone is now a tricorder Chillout Room
Attention Photoshop Geeks!! Chillout Room
Battlefield 3 Will Get Extra PC Attention Gaming
Icon attention in the Taskbar. Customization
ATTENTION Internet problems Network & Sharing
Attention Canadians: Chillout Room

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:17 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App