Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Mobile Catalyst Not-Installing

21 Jun 2009   #11
OEM

OS3.5
 
 

Quote   Quote: Originally Posted by Cam Soper View Post
Mobility Modder doesn't support the Mobility Radeon HD 4570.

Strangely, Dell's own x64 Vista drivers don't install either. WTF?

Guess I'll just use the drivers built into Windows 7 for now. Sadly, these don't work with my wife's favorite game, Neverwinter Nights, but everything else seems to run fine.
When you say, "use the drivers built into Windows 7", have you ran windows update to see if there are better video drivers (if any are available)?

Windows update did have better drivers for my card than what came with Seven.

Keep eye out on modder site, maybe soon the'll have something for ya.
Good Luck


My System SpecsSystem Spec
.
21 Jun 2009   #12
TenGen

Win7 64-BIT RC
 
 

Thats exactly what I just did OEM, it seemed to work.

I found my device ID and manually put it into the .inf on the regular 9.6 catalyst drivers (not the mobility drivers). I first tried to do it on the drivers named '9-6_beta_win7_64_dd_CC' but when I tried to install them, they said 'These drivers are incompatible for this version of windows' or something.

So I went to the other set of drivers I downloaded named '9-6_vista64_win7_64_dd_ccc_wdm_enu', which had two versions named 'C7_81756' and 'CH_81756'. I modified both, but the one labeled C7 had the same windows incompatibility error. BUT for some reason, the CH one ran like a charm.

The line I put in was :
"ATI Mobility Radeon HD 4570" = ati2mtag_M76, PCI\VEN_1002&DEV_9553&REV_00

Those Dev/Rev were gotten from the device manager. I just used the at2mtag_M76 since it was the one used by the previous device (mobile radeon hd 3870). It seems to work so idk if it really is the right version or not.

SO drivers installed fine finally, but CCC Still won't install. I click setup, then custom, then it does its Analyze stuff and lists to install : CIM/HDMI Audio/MSEE Encoder or w/e. Doesn't list CCC/Hydravision/Anything else.
My System SpecsSystem Spec
21 Jun 2009   #13
OEM

OS3.5
 
 

Quote   Quote: Originally Posted by TenGen View Post
Thats exactly what I just did OEM, it seemed to work.

I found my device ID and manually put it into the .inf on the regular 9.6 catalyst drivers (not the mobility drivers). I first tried to do it on the drivers named '9-6_beta_win7_64_dd_CC' but when I tried to install them, they said 'These drivers are incompatible for this version of windows' or something.

So I went to the other set of drivers I downloaded named '9-6_vista64_win7_64_dd_ccc_wdm_enu', which had two versions named 'C7_81756' and 'CH_81756'. I modified both, but the one labeled C7 had the same windows incompatibility error. BUT for some reason, the CH one ran like a charm.

The line I put in was :
"ATI Mobility Radeon HD 4570" = ati2mtag_M76, PCI\VEN_1002&DEV_9553&REV_00

Those Dev/Rev were gotten from the device manager. I just used the at2mtag_M76 since it was the one used by the previous device (mobile radeon hd 3870). It seems to work so idk if it really is the right version or not.

SO drivers installed fine finally, but CCC Still won't install. I click setup, then custom, then it does its Analyze stuff and lists to install : CIM/HDMI Audio/MSEE Encoder or w/e. Doesn't list CCC/Hydravision/Anything else.
Thats Cool, good work.

At least you got the drivers, thats the main thing imo.
Maybe Cam Soper will come back at see that you got the drivers, cause he has the same card I beleive. Can you post a screen shot for others to see what you modified & how? It might help those who have a similar or same setup.

---

I tried to install using the modder app, but it was a no go. Followed instructions to the tee, and it seemed to install ok, but when it completed, got an error stating a problem with the ati driver. So system restore from the install disk and restored to previous point and so back to where I was. Its not a problem on this lappy, don't use it for games or video editing, really just for regular use like web.
My System SpecsSystem Spec
.

22 Jun 2009   #14
TenGen

Win7 64-BIT RC
 
 

Sure, here are the screens.

The basic problem is Dell's drivers are 'proprietary' and do not support Windows 7. And dell makes ATI not offer driver support, so the devID's are not listed as compatible. Mobility modder basically just does what I did, put in the dev ID's into the .inf's. What I'm not sure of, does mobility modder also change the msi's somehow to make them compatible? Yeah, drivers now install fine and I can select proper resolutions finally. But when I connect to my TV, it still looks bad, needs some changes in the catalyst suite. Which won't install no matter what I do.


Attached Thumbnails
ATI Mobile Catalyst Not-Installing-1.jpg   ATI Mobile Catalyst Not-Installing-2.jpg   ATI Mobile Catalyst Not-Installing-3.jpg  
My System SpecsSystem Spec
24 Jun 2009   #15
IMatang

Windows 7 Ultimate Build 7100 (x64)
 
 

Just an FYI...

I've been lurking on these forums looking for answers to this problem and figured I'd come out of hiding. I have pretty much the same setup (Dell Studio 1555) and I, like TenGen, have been having the hardest time getting the ati drivers and the Catalyst Control Center to work.

I'll try this tonight but if anyone can get the CCC working, they'd be my hero because my external 1920x1080 monitor (BenQ e2400HD) looks like crap when connected through HDMI (1920x1080 leaves black bars on top and bottom and all resolutions have really blurry text).

I hope this driver and CCC settings can fix this!
My System SpecsSystem Spec
25 May 2011   #16
winh8r

windows 7 ultimate 32bit
 
 

Hi, just refreshing this old thread. Jaydee73 made the day giving solution to the problem in which I ran into just now when bought dell 1470 with HD 4300 and win7 32bit.
By the way now these mobility modder supports 4570 as well. What a stupid policy by Dell, and strange the solution/problem is not so common on the internet!

I'm not there at that laptop to do this but I assume it will work!
My System SpecsSystem Spec
Reply

 ATI Mobile Catalyst Not-Installing




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Is AMD Catalyst installing the wrong drivers?
My PC is OEM: My motherboard is AsusTek P7P55D-E LX Rev 1.xx with Intel Core i5 760. My thinking up to now was to use the AMD Catalyst center for its driver updates but am wondering if this is something else
Graphic Cards
Catalyst Driver V12.4 not installing
All, According to the Catalyst Control Center, Catalyst Version 11.12 is installed on my Win7 x64 box. I downloaded the version 12.4 executable from ATI, uninstalled version 11.12, rebooted, installed version 12.4, rebooted, and guess what? According to the Catalyst Control Center, Catalyst...
Drivers
Catalyst driver for HD4330 mobile - can't install, only WDDM
Hi, I have a problem on a Dell laptop where by default windows installs a wddm driver for the discrete graphics. there is catalyst driver package with ccc (catalyst control center) available to download from AMD/dell but whatever version I tried to use, I cannot install the actual driver and the...
Graphic Cards
ATI CATALYST after installing Windows 7
Yesterday I installed Windows 7 on my Acer Aspire before installing it said I should uninstall ATI Catalyst install manager and control center it would be easy to reinstall after installation....however now i cannot find how to reinstall it.....can anyone help me?:confused:
Software
ATI Catalyst Control Centre not installing with 7
Hey guys New guy here. I am in HELL! I installed Windows 7 on My Vaio laptop a few days ago. The machine had factory installed Vista. Its a Due core 2.4 with ATI Radeon HD 3400, 4 GHZ ram The install went fine and it asked for the nuking of the ATI software to facilitate install. I did that...
Graphic Cards
Catalyst Control Center Not Installing
I have just installed a clean copy of Windows 7 32-bit. I have a Radeon x850 hooked up to a 50" monitor. During installation it reverts to standard dvi/vga. So I hooked up a small (19") Computer monitor lol. And now CCC will install and everything will be complete. But CCC won't be in the...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App