Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System won't detect radeon 5570, says standard vga graphics adapter


10 Jan 2011   #1

Windows 7 Home Premium 64bit
 
 
System won't detect radeon 5570, says standard vga graphics adapter

Hi, my system will not detect my video card, everytime i try uninstalling the standard vga graphics adapter and sweeping drivers, it just reinstalls itself, it wont allow me to install radeon drivers and is interfering, please help

My System SpecsSystem Spec
.

10 Jan 2011   #2
BWK

 

Is this a new or used video card? Also have you tried doing this via safemode? Try uninstalling everything in safemode and reinstall, with reboot, and see if it detects your new hardware.
My System SpecsSystem Spec
10 Jan 2011   #3

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by BWK View Post
Is this a new or used video card? Also have you tried doing this via safemode? Try uninstalling everything in safemode and reinstall, with reboot, and see if it detects your new hardware.
Its the video card i originally had, i tried replacing it with a different one but i didnt like the other one so i put this one back, i already tried what you said but i can try again
My System SpecsSystem Spec
.


10 Jan 2011   #4

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Joules View Post
In bios you may have a setting that allows you to turn off VGA mode and switch to agp or pci express maybe that could be a possibility....
Bios gives me two options, pci and onboard, it is currently on pci, it just wont detect the card
My System SpecsSystem Spec
10 Jan 2011   #5
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
my system will not detect my video card, everytime i try uninstalling the standard vga graphics adapter and sweeping drivers,
The usual cause of what you are going through is from using a driver cleaner program. I don't know if it is something that people miss or just the program being a little overzealous at times, but it can and does happen that it removes more than it should. Unfortunately unless someone else knows of another way, the only way I know of to get things back to normal is a re-install of Windows A repair install may fix it,

Repair Install

Whichever you try make sure to backup anything you want saved; clean install goes without saying, a repair install just in case.

Running System Restore is also a possibility assuming you have a restore point from before you started running the driver cleaning program, and it doesn't go too far back; a few days would be OK, but if it is weeks I would just go with the repair or full re-install of Windows.
My System SpecsSystem Spec
10 Jan 2011   #6

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Quote:
my system will not detect my video card, everytime i try uninstalling the standard vga graphics adapter and sweeping drivers,
The usual cause of what you are going through is from using a driver cleaner program. I don't know if it is something that people miss or just the program being a little overzealous at times, but it can and does happen that it removes more than it should. Unfortunately unless someone else knows of another way, the only way I know of to get things back to normal is a re-install of Windows A repair install may fix it,

Repair Install

Whichever you try make sure to backup anything you want saved; clean install goes without saying, a repair install just in case.

Running System Restore is also a possibility assuming you have a restore point from before you started running the driver cleaning program, and it doesn't go too far back; a few days would be OK, but if it is weeks I would just go with the repair or full re-install of Windows.
Restore points would not load, something was interfering with them, either way i wish i knew about repair installs before i factory reset my computer, at least i copied all my files to a portable drive first.
My System SpecsSystem Spec
10 Jan 2011   #7
Microsoft MVP

Win 7 Ultimate x64
 
 

Card detected and the driver install since the reset?
My System SpecsSystem Spec
10 Jan 2011   #8

Windows 7 Home Premium 64bit
 
 

No... this is just awful
My System SpecsSystem Spec
10 Jan 2011   #9

Windows 7 Home Premium 64bit
 
 

Im going to try the repair install now
My System SpecsSystem Spec
10 Jan 2011   #10

Windows 7 Home Premium 64bit
 
 

Repair install didnt work, i guess ill have to return the computer
My System SpecsSystem Spec
Reply

 System won't detect radeon 5570, says standard vga graphics adapter




Thread Tools



Similar help and support threads for2: System won't detect radeon 5570, says standard vga graphics adapter
Thread Forum
AMD Radeon HD 6470m showing as Standard VGA graphics adapter??? Graphic Cards
Standard VGA graphics adapter Graphic Cards
HELP!!! standard vga graphics adapter Tried everything Graphic Cards
Solved Need advice for new computers graphics card XFX Radeon HD 5570 Graphic Cards
Says I have standard VGA adapter instead of AMD Radeon HD6650M Graphic Cards
Solved Standard VGA Graphics Adapter Graphic Cards
Standard VGA Graphics Adapter? Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:06 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33