Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Crossfire HD5870s and Crysis Warhead - Huge FPS Drops?


21 Jan 2011   #1

Windows 7 Premium 64 bit
 
 
Crossfire HD5870s and Crysis Warhead - Huge FPS Drops?

Hi,
I've recently changed my set up as per the specs below and since trying Crysis Warhead I get very noticeable drops in frame rates whether I high or low the settings. One minute the games ok and playable but then, even with no combat going on, it just drops to a slide show! The other issue I seem to have is Alien vs Predator in DX11 mode sometimes just freezes randomnly during play.

I have tested the card with Bad Company 2 at max settings with DX11 and it runs very smoothly with no problems. Same for Metro 2033 at fairly high settings. I don't understand why the huge drops with WH or the freezes with AVP? I'm fairly certain its not the PSU as BC2 at least should have problems?

Specs
Asus AM3 Crosshair IV Motherboard
AMD Phenom II X4 965 BE O'clocked to 3.8Ghz stable as per Prime 95
1 x XFX HD5870 1GB O'clocked from 800/1200 to 875/1225
1 x powercolour PCS+ HD 5870 factory clocked to 875/1225
3 HDDs
6GB Kingston Hyperx RAM 1600OC
Corsair TX750W PSU

ATI Catalyst is most recent version. Downloaded the package from the AMD site including Drivers, profiles etc.

Any help would be appreciated as I thought, with 2 HD5870 Crossfired, there should be a big gain. If there's something I'm missing in terms of setting up ATI Catalyst please let me know?? Crossfire is def ticked though.

Thanks in advance from a confused PC noob!!

My System SpecsSystem Spec
.

21 Jan 2011   #2

Windows 7 Pro x64 SP1
 
 

Nahh, that PSU should handle that system just fine.

I'm guessing you installed the latest CAPs as well... Am I right?

EDIT: As well as the latest BIOS?
My System SpecsSystem Spec
22 Jan 2011   #3

Windows 7 Premium 64 bit
 
 

Hi,
Thanks for the reply. I've installed the latest catalyst drivers and added in the newest profiles which I found last night. Crysis WH now runs between 29fps to 60fps with crossfire enabled.

How do you install the latest BIOS?

Another quick query - The second card doesn't seem to register much usage, hardly any temp increase but there is an approx 20fps increase in Warhead. Is this right? I expected the temps to increase on both cards and for no. 2 to show heavier traffic?
My System SpecsSystem Spec
.


22 Jan 2011   #4

Windows 7 Home Premium 64bit sp1
 
 

Have you ever gone into the bios and look at the pci -e settings

some board you have to enable crossfire manually vs one card.

I think you have a option to enable crossfire in the bios and gpu settings

I found that option on my board but it is a hybrid crossfire so it doesnt work with what im running
My System SpecsSystem Spec
Reply

 Crossfire HD5870s and Crysis Warhead - Huge FPS Drops?




Thread Tools



Similar help and support threads for2: Crossfire HD5870s and Crysis Warhead - Huge FPS Drops?
Thread Forum
Crysis Warhead - Frozen Paradise...Um, What? Gaming
Crysis Warhead freezes Gaming
Crysis Warhead Crashes (Son's new build) BSOD Help and Support
Solution for Prototype and Crysis:Warhead on x86 Gaming
Crysis Warhead Choppy Gameplay...Why? Gaming
Crysis Warhead in 1680x1050? Gaming
Crysis Warhead crashes in dx9 Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:10 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33