Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installed new PSU and GFX and still doesnt work


07 Feb 2011   #1

Windows 7 Ultimate 64Bit
 
 
Installed new PSU and GFX and still doesnt work

Ok so pretty much
I bought a Gigabyte 4890 and it didnt boot
so then i installed at 650W Awyun PSU with 48A so that is PLENTY of power for it

But the problem is
I hit the power button everything loads, then it gets to "Starting Windows"
And it just stays there but i hear the sounds of windows loading up through the speakers.

Cheers for any help
i3rock

My System SpecsSystem Spec
.

07 Feb 2011   #2

Windows 7 Ultimate 64Bit
 
 

Oh and i can boot fine into safe mode which is what im running atm
My System SpecsSystem Spec
07 Feb 2011   #3

Windows 7 x64 Ultimate
 
 

Sounds like at this point you just need to get the latest drivers for your video card off the net and install those in safe mode
My System SpecsSystem Spec
.


07 Feb 2011   #4

Windows 7 Ultimate 64Bit
 
 

I just get a "failed to load detection driver" which i assume means i cant install it in safe mode
So any other ideas lol?
My System SpecsSystem Spec
07 Feb 2011   #5

Windows 7 x64 Ultimate
 
 

You get that from the video card driver installer?

[edit] Looks like the net is FULL of people having that error Probably start slogging though a google search of that error string to start... something to do with having installed then uninstalled the driver previously or something.[/edit]
My System SpecsSystem Spec
07 Feb 2011   #6

Windows 7 Ultimate 64Bit
 
 

Well what im trying now is i just put my HIS 3850 back in and installing the latest driver with that
so that just shows it isnt a hard-driver error right?
And hopefully if this works and my 4890 runs other people can be helped
My System SpecsSystem Spec
07 Feb 2011   #7

Windows 7 x64 Ultimate
 
 

Yeah
My System SpecsSystem Spec
07 Feb 2011   #8

Windows 8.1 Pro
 
 

Do not install video card drivers in safe mode. If you can't boot into Windows, remove and replace the card, boot into Windows and attempt to load the drivers.

Let us know what happens.

Also, I have to ask, did you connect the power connector to the card?
My System SpecsSystem Spec
07 Feb 2011   #9

Windows 7 Ultimate 64Bit
 
 

Ok i installed the latest driver by using the 3870 in normal windows then i put the 4890 back and tried to load windows but the same thing happened
It got up to the "Starting Windows" froze once the orbs came together
but still heard the booting sounds finish
And yes i do have both the 6pin PCI-e cables connected
My System SpecsSystem Spec
07 Feb 2011   #10

Windows 8.1 Pro
 
 

Are you sure the card is good?

Also, could you post your system specs?

Thanks
My System SpecsSystem Spec
Reply

 Installed new PSU and GFX and still doesnt work




Thread Tools



Similar help and support threads for2: Installed new PSU and GFX and still doesnt work
Thread Forum
Windows7: .NET ActiveX doesnt work when installed from cab file Browsers & Mail
Microphone doesnt work? Sound & Audio
My microphone doesnt work Sound & Audio
Mic doesnt work Sound & Audio
SupremeFX II Win 7 !Doesnt Work! Drivers
homegroup doesnt work Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:55 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33