Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Auto-detect monitors


15 Feb 2011   #1

Windows 7 Ultimate x64
 
 
Auto-detect monitors

Hi,

I bought Monitor LED Philips 222EL2SB 21.5 inch 5 ms wide black, and i've connected it to the pc via DVI, 1 problem is that it will not detect my monitor via DVI. Luckily i have an addaptor from DVI to hdmi and this seems to work. The second problem is that whenever i plug anything in the computer my screen start flickering black. I've noticed that when this happens my windows starts looking for additional monitors and finds 3: my actual screen,and 2 Generic non-pnp monitor.



If i press detect it will go back to 1 screen like i actually have,so it's rly annoying, especially when i have to unplug something from the pc and plug it back in whenever i want to start the computer. What can be the problem ? :/ ( just got home and my hands are rly cold, so sorry for bad english )


My System SpecsSystem Spec
.

15 Feb 2011   #2

Windows 7 Ultimate x64
 
 

Try updating all drivers. For monitor drivers, usually windows update in windows 7 is pretty good about finding them. After that is complete, I would also try to update your video drivers. If you're having an issue everytime you're plugging in something to your computer, it could be a problem with the chipset drivers on your motherboard, which would control the usb ports.

Bill
My System SpecsSystem Spec
15 Feb 2011   #3

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

The locating of three monitors when only one actually exist could also be a video driver issue (though not that likely it is possible) you could try updating (or rolling back if that applies) not a huge chance of it fixing it, but it certainly can't hurt anything either.
My System SpecsSystem Spec
.


18 Feb 2011   #4

Windows 7 Ultimate x64
 
 

Ok, so i've reinstalled the video drivers and the flickering of the screen (in vga and dvi) and the often no video input on the dvi connection still happens... So i've hooked up my old LCD on, with his VGA connection, and it doesn't flicker at all. So the monitor itself could be broken. Is that posssible ?

+ the LED Philips 222EL2SB 21.5 inch 5 ms wide black,on the DVI connection, doesn't even want to show the bios image + the loading of it, until it reaches the windows user password window (log-in screen). While on the same monitor,on VGA, it shows the image right from the beginning with the motherboard image and the bios loading etc.
My System SpecsSystem Spec
18 Feb 2011   #5
Microsoft MVP

Win 7 Ultimate x64
 
 

From what you have said you only have the one monitor connected. If so let's start with cleaning out the old one(s) from Device Manager. Follow this,

Device Manager : Hidden Devices

to set Device Manager to show hidden and ghost devices. Once set expand Monitors and uninstall all that are greyed out; uninstall only, don't remove the driver if asked.

Once all of them are removed if you haven't yet install the driver for your new monitor,

222EL2SB/10 Philips LED monitor with SmartTouch 222EL2SB 21.5'' (54.6 cm) E-line 21.5" w Display - Philips Support
My System SpecsSystem Spec
18 Feb 2011   #6

Windows 7 Ultimate x64
 
 

Can i unistal the generic non pnp monitor that are not grayed out ? Or at least disable it ? so it can't find it ?

They grayed out at one point... and i got rid of all generic non pnp monitors, and the flicker randomly happens when i alt+tab a game( note: not always, just once at 2-4 tries)

And i have installed the monitor from the beginning

Any other suggestions ?


LE: So i've hooked up another video card (GeForce GTS 450) that has 2 DVI and 1 HDMI slot, one of the DVI slots doesn't send any video signal to the monitor while the second one that's between the HDMI and DVI (if it matters the position) works just fine, when i start the computer i have signal right from the beginning,i see the bios loading and stuff, and in Windows i have no problems with flickering of the image, and of course no second monitors get detected.

This still raises some questions:

1) My video card that i had originally(a gigabyte GTX 260 OC) on the computer has 2 slots for the power cable while this one(the GeForce GTS 450) has just 1, so this could indicate that it doesn't eat as much power as the original one. So i also suspect the Power Supply
2) Why doesn't one of the DVI of the second video card (GeForce GTS 450) work ?
My System SpecsSystem Spec
Reply

 Auto-detect monitors




Thread Tools



Similar help and support threads for2: Auto-detect monitors
Thread Forum
auto detect headset plugin Sound & Audio
USB 3.0 Hard Drive won't auto-detect Hardware & Devices
No auto-detect output for Realteck on Windows 7 device Sound & Audio
Auto detect fails cold boot only Installation & Setup
Auto-Detect issue Hardware & Devices
Can Realtek auto detect and switch to which mode I'm playing on? Sound & Audio
Windows 7 cannot auto-detect audio I/O Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:43 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33