Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: hdmi audio nvidia g100 problem.. HELP

24 Feb 2011   #1
sogone209

Windows 7 Professional x64 (6.1.7600)
 
 
hdmi audio nvidia g100 problem.. HELP

ok my computer is acer aspire x1700 and it comes iwth a discrete nvidia geforce g100 video card with HDMI output,when i hook it up tomy tv theres no audio. but if i use the motherboard hdmi it has audio, how do i get my NVIDIA TO PLAY AUDIO. plz help i have the latest drivers


My System SpecsSystem Spec
.

24 Feb 2011   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Make sure that SPDIF is set as the default audio device first in the Windows playback properties. If that doesn't get sound then,

Acer Support: Frequently Asked Questions list for No HDMI audio can be caused by SPDIF cable reversed

Open up the case and find the cable mentioned there, then follow the instructions to switch the connectors around.
My System SpecsSystem Spec
24 Feb 2011   #3
sogone209

Windows 7 Professional x64 (6.1.7600)
 
 

i dont see spdif in the sound or realtek audio panel. it says realtek audio optical when i plug in the hdmi to the g100 graphics card. but when i but the hdmi from the motherboard using the motherboard internal video it says the aduio is using nvidia hdmi for sound. but it never says that for my g100 card. i have realtek and 266.58 drivers the newest ones. and i know it has spdif for sound it says on the specs of that video card on nivdia website
My System SpecsSystem Spec
.


24 Feb 2011   #4
sogone209

Windows 7 Professional x64 (6.1.7600)
 
 

im just trying to get video and SOUND from the hdmi cable connected to my g100 card, cause thats how it works when i plug it into the MOTHERBOARD HDMI AND USE THE MOTHERBOARD VIDEO CARD instead of the G100 card attached to the pci slot.
My System SpecsSystem Spec
24 Feb 2011   #5
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

That video card does not have any built in audio. To get audio over HDMI from it it has to have a SPDIF cable from it to the SPDIF header on the motherboard (or sound card if one is used instead). As a result it uses whatever driver is installed for the onboard audio which when you say,

Quote:
it says realtek audio optical when i plug in the hdmi to the g100 graphics card.
then it is switching to the correct setting (SPDIF is digital).

Seeing as Acer conveniently provided instructions on what to check inside the computer when the HDMI audio doesn't work, follow that link I posted and check the cable and connectors, and reverse it as shown.
My System SpecsSystem Spec
24 Feb 2011   #6
sogone209

Windows 7 Professional x64 (6.1.7600)
 
 

the spdif and ground is exactly like the picture. but i dont want to use 2 cables for video and sound. doesnt sound travel threw hdmi cords? THE CONNECTERS ARE FINE. and audio is enabled on my nvidia control panel its 1600x1800 1080p (audio enabled) but dont hear soundthrew tv? LIKE THE OTHER HDMI PORT ON MY COMPUTER MOTHERBOARD on the realtek audio digital it shows sound on the sound meter going up and down like theres sound but no sound to the tv via threw the hdmi from the g100.
My System SpecsSystem Spec
24 Feb 2011   #7
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
the spdif and ground is exactly like the picture.
Then disconnect them and switch them around. Just because it matches the picture doesn't mean it isn't connected backwards on the video card.
My System SpecsSystem Spec
24 Feb 2011   #8
sogone209

Windows 7 Professional x64 (6.1.7600)
 
 

ok i switched them twice, so are you for sure saying that i can get AUDIO from my nvidia geforce g100 video card via HDMI cord? i dont gotta use 2 cords? hdmi for video and then a audio cord for sound?cause i just wanna use the hdmi for video and sound, so it should work switching those wires around? i tried twice maybe the connection at the top of the card is loose and not connecting. ill see
My System SpecsSystem Spec
Reply

 hdmi audio nvidia g100 problem.. HELP




Thread Tools





Similar help and support threads
Thread Forum
Nvidia GeForce GT 610 HDMI Audio Issue
Ok so this is driving me mad. I'm trying to get the audio to work on my GeForce card to my TV via HDMI (This is the only monitor that I own). I am currently at a loss. I have already contacted Nvidia Tech Suport (Transcript) with no luck. I also did both a general google search with no luck as well...
Sound & Audio
Nvidia HDMI audio issues.
Just upgrading an old system to Windows 7 with a 9500 GT card and started having issues with a 'Static' clicking sound on Philips HDTV. Have tried to see if I can uninstall the driver but seems to always reinstall itself on boot up. Other things I have tried is disable HDMI audio settings within...
Sound & Audio
NVIDIA HDMI audio not working Win 7. Worked on Ubuntu
Athlon 64 3400+ Geforce gt210 PCIE 2gb RAM I had Ubuntu 12.04 installed on this machine as an XBMC HTPC using the HDMI video and audio with the Geforce 210 until yesterday. I had a Win 7 license to use so I planned to rebuild the machine to do the same tasks with Win 7 then I could use Hulu...
Sound & Audio
HDMI Audio Out, Realtek + Nvidia
Hi Guys, I really need some help with this one. I purchased a new PC, with a Gigabyte GA-H61MA-D2V motherboard that has on board realtek audio, I also purchased a nvidia geforce GT630 graphics card which has a built in audio processor and hdmi connection which is going to my LG 42PL6010 tv. ...
Sound & Audio
No sound from HDMI device Nvidia and Realtek HD Audio
Hi, I have installed windows 7 Ultimate 64bit and have now found I get no sound through the HDMI device. I had a simlar issue in Vista and found I had to use an older Nvidia Driver 175.97 for Geforce 7650 GS inorder to get this working with "Speaker" as default device...However in Windows 7 even...
Sound & Audio
Nvidia Geforce GTX 260 HDMI Out With Audio?
So, I got a Geforce GTX 260 with HDMI Out Via a DMI Adapter. But, in order to have sound on that HDMI output, I need to connect the card to an S/PDIF output on my motherboard. My motherboard is an Asus GA-EP45-UD3L, and I do have an S/PDIF output on it. However, I do not have the cable needed...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App