Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XFX Geforce 6200 - no drivers working on Win7-64

25 Feb 2011   #1
Lotus289

Windows 7 Home Premium 64-Bit
 
 
XFX Geforce 6200 - no drivers working on Win7-64

I just upgraded to Windows 7 Home Premium 64-bit and cannot get my graphics card drivers to load properly. I'm getting the same "Code 43" error everyone else I've read about seems to be getting. I've also tried every fix I've read about but to no avail.

Is there any final solution for this. The Windows 7 Compatibility website shows that my graphics card is fully compatible, but I cannot get the full power out of it. I think it's just running in standard VGA Mode.

System Specs:
Board - ASRock 4CoreDual-Sata2 R2.0
Chip - Intel Dual Core 2.50Ghz
Graphics Card - XFX Nvidia Geforce 6200 512Mb 64-Bit
RAM - 2Gb DDR2 PC2 5300

I've checked ASRocks website for drivers but there's none available. I've run multiple driver versions direct from Nvidia but none work. I've used the "stock" driver that Windows 7 uses if I "delete" the card from the system and re-enable it and that doesn't work either.

This setup worked perfectly on WinXP 32-Bit when I had it. But since I upgraded to Win7 64-Bit I can't get the graphics card to work for the life of me. Can someone please point me in the right direction to correct this?


My System SpecsSystem Spec
.
26 Feb 2011   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Seeing as the motherboard bard both, is the video card AGP or PCI-E?
My System SpecsSystem Spec
26 Feb 2011   #3
Lotus289

Windows 7 Home Premium 64-Bit
 
 

Video card is AGP.
My System SpecsSystem Spec
.

26 Feb 2011   #4
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

May find that the built in Windows AGP driver isn't fully compatible with the AGP controller on the motherboard. Go here,

VIA Drivers Download - VIA Technologies, Inc.

and grab the Vista Hyperion Pro (4in1) driver (work your way through the dropdowns), install it and then try the video driver again.
My System SpecsSystem Spec
26 Feb 2011   #5
Lotus289

Windows 7 Home Premium 64-Bit
 
 

That didn't work. The installer said it couldn't find the appropriate hardware to continue the install. (or something to that effect.)

I'm wondering if my Motherboard / Video Card combo isn't compatible with Windows 7. I going to try another video card in a little bit and see what it does. I'm also thinking my video card is just too old to be able to run Win7. I'll find out shortly though.
My System SpecsSystem Spec
26 Feb 2011   #6
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

A little of both actually. The chipset hasn't seen an update since shortly after Vista came out, so if the Vista drivers won't work then it has to rely on whatever support maybe built into Windows 7. It also doesn't help that the video card is AGP as it requires a working AGP driver (part of the chipset) for its driver to install and work properly. Probably find that if it was the PCI-E version of the 6200, you wouldn't be having the problems with it.

Also considering the cards age and that it is AGP I wouldn't go for any of the newer Nvidia drivers for it, as they are all more geared towards the current generation or two of cards. Instead go for one of the older ones from the 197.xx or 196.xx series of drivers,

NVIDIA Driver Downloads - Advanced Search

Just locate your card from the dropdowns, select the OS and hit Select.
My System SpecsSystem Spec
26 Feb 2011   #7
bobkn

Windows 7 Pro X64 SP1
 
 

Quote   Quote: Originally Posted by Lotus289 View Post
That didn't work. The installer said it couldn't find the appropriate hardware to continue the install. (or something to that effect.)

I'm wondering if my Motherboard / Video Card combo isn't compatible with Windows 7. I going to try another video card in a little bit and see what it does. I'm also thinking my video card is just too old to be able to run Win7. I'll find out shortly though.
Have you tried the Vista drivers for your Via chipset (from Asrock)?

ASRock > Products > Motherboard > 4CoreDual-SATA2 > Download R2.0&o=Vista64

I'm not sure that they're necessary, but they may be worth a go.

If I read the release notes right, these drivers should support the 6200:

NVIDIA DRIVERS 266.58 WHQL

including AGP versions.

What BIOS version is installed? The latest is 2.20, from 9/29/2009.
My System SpecsSystem Spec
27 Feb 2011   #8
woolswell

Server 2008 R2 SP1, Win7 x64 Pro SP1
 
 

Quote   Quote: Originally Posted by Lotus289 View Post
I just upgraded to Windows 7 Home Premium 64-bit and cannot get my graphics card drivers to load properly.
.......
Graphics Card - XFX Nvidia Geforce 6200 512Mb 64-Bit
......

....... since I upgraded to Win7 64-Bit I can't get the graphics card to work for the life of me. Can someone please point me in the right direction to correct this?
Just now I replaced a Nvidia 6600GT PCI-E card (from my friend) to my PC, and installed the
ForceWare 185.42 W 7 x64 to test it worked or not, and found it ran well.

If you got time, you are welcome to visit my SkyDrive to download and try it :

ForceWare 185.42 W 7 x64.part1

ForceWare 185.42 W 7 x64.part2
My System SpecsSystem Spec
Reply

 XFX Geforce 6200 - no drivers working on Win7-64




Thread Tools




Similar help and support threads
Thread Forum
Win 7 & GeForce Go 6200
Hey all! I'm new to the forum and lookin for a bit of help. Here's the deal: I'm running Windows 7 on a notebook with a GeForce Go 6200. No aero, and under the Device Manager, the video card shows up as "Standard VGA Graphics Adapter". I tried going through the Nvidia drivers online but they...
Graphic Cards
Areo stopped working, Geforce 6200
Hi all just noticed on my pc when i rebooted that areo was gone! it had been getting lots of driver crashes and i thought that was the prob, so i updated to 285 and it is still not working, i checked in theme and it aint there plz help thx discript
Graphic Cards
Issues with NVIDIA GeForce 6200
I have a Gateway FX6840. It has an ATI Radeon HD 5700. I had two monitors going just fine. I can run WoW with most of the graphics options turned all the way up and I still get 60 fps. I had a third monitor so I decided to put it to use. I went out and grabbed my NVIDIA GeForce 6200 and tossed it...
Graphic Cards
GeForce 6200 Code 43
Hello there, just got done installing the Win7 Beta and updating all of my drivers. There's one that's still giving me troubles though; my graphics card. I've got an XFX GeForce 6200 512MB AGP 8x. This is the second time I've had an issue with this card. I powered off my system, plugged the...
Graphic Cards
GeForce 6200 TurboCache not working properly
Hello; I've done some searching and experimenting, and at the moment I'm at a loss. I've recently (a few hours ago) installed Windows 7 on my computer, at the same time as installing a new master HD. Most of the system came back up fine, with the exception of my second monitor/nVidia GeForce...
Graphic Cards
7 Just doesn't Like GeForce 6200?
Ok so if you own a Nvidia GeForce 6200 and your in 7, you probably know that there are many problems. But why? I thought Windows 7 was suppose to be the Sucesser to Vista. Everyone complains about how vista sucks but when i installed the very first time The drivers were installed correctly, and i...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:05.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App