Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI 5850 11.2 drivers


28 Mar 2011   #1

Windows 7 Home premium 64bit.
 
 
ATI 5850 11.2 drivers

So i have fully updated drivers from ATI for my ATI HiS HD5850 gpu drivers are 11.2(newest for windows 7) and it seems when i start/stop videos, or while watching live broadcasting on JTV, xfire, ustream, ngametv you name it there will be a flicker across my two monitors, one running 1920x1080(native) and the other running 1680x1050, sometimes it goes as far as my display driver stops working and then recovers, either causing adobe flash player to crash or where ever there was a video and or AD(i have them turned off) just a bright green while i can still hear the sound, now iam on a fresh install of windows 7 and have the correct drivers

Is there something wrong with the newest ATI 5850 drivers?
Should I be using an older version of the ATI 5850 drivers?
I just reinstalled my OS after replacing an unstable mobo and made sure to update my drivers so i just grabbed the latest ATI 5850 drivers.

My System SpecsSystem Spec
.

28 Mar 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

I just plugged a second monitor into mine for a few (I usually just run the one monitor) and streamed netflix and hulu without any issues.
Same card same drivers.

Have you tried a complete driver wipe and re-installation?
Guru3D - Driver Sweeper (Setup) download from Guru3D.com
^^that app does a much more complete job of removing the drivers than the normal uninstall process
I also suggest re-downloading the new driver before starting and using the fresh copy, just to make sure everything is fresh.
My System SpecsSystem Spec
28 Mar 2011   #3

Windows 7 Home premium 64bit.
 
 

No offence but if you read correctly you would know that I just re-installed my OS and got all knew drivers, therefore there would not be any unwanted drivers
My System SpecsSystem Spec
.


28 Mar 2011   #4

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

I was operating on the assumption something was wrong with the installation.
..we'll skip that though, does the problem still occur when you disable the hdmi audio device onboard the card?
My System SpecsSystem Spec
28 Mar 2011   #5

Windows 7 Home premium 64bit.
 
 

Too be honest i have no clue how to disable that, currently iam using a Razer Megalodon 7.1 headset(usb)
My System SpecsSystem Spec
28 Mar 2011   #6

Windows 7 Ultimate 64bit
 
 

Turn off Hardware Acceleration in Flash and let us know if that works. worked for me.
My System SpecsSystem Spec
28 Mar 2011   #7

Windows 7 Home premium 64bit.
 
 

Ok so tried it and it immediately flickered again
My System SpecsSystem Spec
28 Mar 2011   #8

Windows 7 Ultimate 64bit
 
 

Easy way is to go to a youtube video and right click on the window and click on Settings.
On the bottom tab of the settings window click the tab to the far left and that should have a box and this next to it "Enable Hardware Acceleration". Uncheck the box.


Attached Images
 
My System SpecsSystem Spec
28 Mar 2011   #9

Windows 7 Ultimate 64bit
 
 

did you shut down your browser and restart it?

I just turned it on on mine and it started to flicker all the screens again when I play a flash video and when I close that tab.
Unchecking it fixes it for me.
My System SpecsSystem Spec
28 Mar 2011   #10

Windows 7 Home premium 64bit.
 
 

OK fixed it at first look, we will see how it goes on from now, what does "hardware acceleration" exactly do?
My System SpecsSystem Spec
Reply

 ATI 5850 11.2 drivers




Thread Tools



Similar help and support threads for2: ATI 5850 11.2 drivers
Thread Forum
Solved ati 5850 vs. GTX580 Graphic Cards
Hd 6850 vs hd 5850 Hardware & Devices
Asus 5850 Graphic Cards
5850 stated DDI:10.1?! DX10.1? Graphic Cards
MSI AB 1.4, GPU-Z & 5850, Voltage to 1.6. GPU-Z causing Graphic Cards
My ATI 5850 Vantage, OK? Graphic Cards
No HD playback on 5850?!?! Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33