Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HD 5670 problem

05 May 2011   #11
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
 
 

Didn't work


My System SpecsSystem Spec
.

Reply

 HD 5670 problem




Thread Tools





Similar help and support threads
Thread Forum
Saphire HD 5670
Does anyone know of a fix for display drivers for this card? just installed and keep getting fail logs for the display drivers in the CCS ....Tried installing from the CD and latest/previous version from AMD's site....card seems to work fine otherwise but my monitor isn't recognised so can max at...
Graphic Cards
Sapphire HD 5670 problem: "no imput"
hi all, I have just installed on my HP Pavillion 7750 the Sapphire HD 5670, replacing my old Radeon X1650 SE. When i turn on my pc, in my monitor appears a "no imput" message, but all cables are connected and GPU's fan starts working. I tried to remove and re-install the card, but nothing...
Graphic Cards
ATI 5670, AVIVO, Catalyst
Just got a new HTPC system with a Sapphire HD Radeon 5670 graphics card. Everything seems to work very well and I can even play Blu-ray 1080P DVD rips downloaded from the internet, although I have to use the Windows port of MPlayer since MP doesn't seem to have the ability. After having...
Graphic Cards
Win 7 x64 not detecting 5670.
Hey guys, not sure if I've got the right section so I thought I'd give this a go here. Trying to install a 5670 my parents' computer, their motherboard's a Gigabyte GA-MA785GT-UD3H. They're currently using the on-board video of the motherboard so I disabled that, installed the card and booted...
Graphic Cards
ATI Radeon HD 5670 Problem
I recently downloaded Windows 7 Ultimate 64x, and I've been experiencing problems with either my Graphics card, or my Monitor. At first when I restarted my computer as soon as the computer was about to load in the login screen for Windows 7 it went black. You could see the mouse pointer, and...
Graphic Cards
Issue with XFX 5670 1 GB
Hello everyone! i am a new member. i recently bought a xfx 5670 hd 1 gb card....it works fine when i am watching movies or any thing else. but as soon as i play any game (mind it any game AOE even) i get a black screen. i have updated BIOS, reinstalled OS, installed latest drivers, checked the...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App