Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HD 5670 problem

06 Apr 2011   #1
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
 
 
HD 5670 problem

I've got a friend who has an almost similar setup to me, except that he has 2gb ram, processor athlon II x2 245 and motherboard is Asus (budget),450 w psu , his problem is the new XFX HD 5670 [1 GB] he has purchased is making games stutter and then the screen goes blank for a few seconds ('No Signal' on LCD, blank on CRT). Sometimes the game recovers and goes on ok for few more minutes,and then again BAM!! I tested the card on my setup, updated drivers, tried different games...but, same problem. What is wrong with the card? Bottleneck, isn't that unusual for a budget card?


My System SpecsSystem Spec
.
11 Apr 2011   #2
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
 
 

All hope is lost then for the card, I guess.
My System SpecsSystem Spec
11 Apr 2011   #3
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Check your PSU recommendations for that card....I have a sneaky feeling that's the root cause. Have a look at this in the specifications tab....minimum is 650 watt.

Graphic Cards - ATI Radeon HD 5000 - ATI Radeon
My System SpecsSystem Spec
.

11 Apr 2011   #4
linux731

Windows 7 Home Premium x64 SP1
 
 

What bassfish said might be the problem. Otherwise, you might be looking at a damaged card. Also a 450W power supply is very weak... Consider upgrading.
My System SpecsSystem Spec
11 Apr 2011   #5
sandman

Window's 7 Ultimate 64bit
 
 

I have a 550 watt power supply with the Sapphire version of the HD 5670 and have no issues with power. The card may be bad does that one use an extra power connector. Mine calls for a 400 watt or greater single or 500+ dual cards.
My System SpecsSystem Spec
12 Apr 2011   #6
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
 
 

Quote   Quote: Originally Posted by sandman View Post
...The card may be bad does that one use an extra power connector. Mine calls for a 400 watt or greater single or 500+ dual cards.
No the card doesn't have a power connector.

I have now tested it in a pc which has a 500W psu (although cheap), identical affliction! Even then, I'll talk to my friend about the issue...he has changed the mobo to Gigabyte/w ATI chipset (he had an ASUS one with nvidia chipset, as previously stated) after the problem 1st appeared he doesn't have much of a budget left, although the problem remains the same! I think I will suggest RMA, what do you guys think?
My System SpecsSystem Spec
12 Apr 2011   #7
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Yes...if you put that card in another machine and it's doing the same thing, chances are it's the card, Yes, replace it.
My System SpecsSystem Spec
13 Apr 2011   #8
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
 
 

Will let you guys knw of any updates.
My System SpecsSystem Spec
13 Apr 2011   #9
Fantail

7 x64 | 7 x64
 
 

This thread is interesting, kind of. I recently bought the xfx 5670 1 gig card (see specs). Basically I run 3 screens, 2 opticals, one hd with a 485w and no problems at all. Maybe you do have a defective card but have you tried disconnecting juice to all your opticals and rebooting with just the main drive?
My System SpecsSystem Spec
15 Apr 2011   #10
dorian hawkmoon

Windows 7 Ultimate (x64) SP1
 
 

Meaning with just the HDD, LCD connected, without the burner? I didn't , but I can try and let you guys know.
My System SpecsSystem Spec
Reply

 HD 5670 problem




Thread Tools




Similar help and support threads
Thread Forum
Saphire HD 5670
Does anyone know of a fix for display drivers for this card? just installed and keep getting fail logs for the display drivers in the CCS ....Tried installing from the CD and latest/previous version from AMD's site....card seems to work fine otherwise but my monitor isn't recognised so can max at...
Graphic Cards
Sapphire HD 5670 problem: "no imput"
hi all, I have just installed on my HP Pavillion 7750 the Sapphire HD 5670, replacing my old Radeon X1650 SE. When i turn on my pc, in my monitor appears a "no imput" message, but all cables are connected and GPU's fan starts working. I tried to remove and re-install the card, but nothing...
Graphic Cards
ATI 5670, AVIVO, Catalyst
Just got a new HTPC system with a Sapphire HD Radeon 5670 graphics card. Everything seems to work very well and I can even play Blu-ray 1080P DVD rips downloaded from the internet, although I have to use the Windows port of MPlayer since MP doesn't seem to have the ability. After having...
Graphic Cards
Win 7 x64 not detecting 5670.
Hey guys, not sure if I've got the right section so I thought I'd give this a go here. Trying to install a 5670 my parents' computer, their motherboard's a Gigabyte GA-MA785GT-UD3H. They're currently using the on-board video of the motherboard so I disabled that, installed the card and booted...
Graphic Cards
ATI Radeon HD 5670 Problem
I recently downloaded Windows 7 Ultimate 64x, and I've been experiencing problems with either my Graphics card, or my Monitor. At first when I restarted my computer as soon as the computer was about to load in the login screen for Windows 7 it went black. You could see the mouse pointer, and...
Graphic Cards
Issue with XFX 5670 1 GB
Hello everyone! i am a new member. i recently bought a xfx 5670 hd 1 gb card....it works fine when i am watching movies or any thing else. but as soon as i play any game (mind it any game AOE even) i get a black screen. i have updated BIOS, reinstalled OS, installed latest drivers, checked the...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App