Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MSI ATI Radeon x1650 Pro + Windows 7

08 Jul 2009   #1
dushanle

Win Xp
 
 
MSI ATI Radeon x1650 Pro + Windows 7

ok, here is the problem... when i try to install win7 on my comp the installation automatically install drivers for my MSI ATI Radeon x1650 Pro... when system tries to start for the first time i get a black screen with lines of different colors and it just stays like that for like 5sec and than comp restart... these lines show after bootscreen... i tried to enter safe mod but i just can't enter it because windows didn't start for first time i know it's a video card because when i installed drivers from ATI official site i got the same problem with win vista... but when i installed drivers from MSI site everything was good...
i tried upgrading from vista sp1 (with installed and working drivers for my card from MSI site) to win 7 RC and other newer builds but win 7 just install it's own drivers and there are lines after bootscreen again upgrade from vista to build 7000 (beta) worked but, i can't upgrade from 7000 to 7100 because of the drivers.. clean install of RC doesn't work as well...

so my question is... is there a way to stop win7 from automatically installation of video card drivers, and if there is, how to do that? to delete some file from win7 disc?
or is there a way to install my video card drivers automatically with win7 installation?


My System SpecsSystem Spec
.

09 Jul 2009   #2
r2l

Windows 7 Ultimate 32-bit
 
 

so your saying you only have tried to use a clean install of windows 7 build 7000?
My System SpecsSystem Spec
09 Jul 2009   #3
rook

Windows 7 X64 RTM
 
 

Assuming you have onboard video, try removing you MSI X1650 and do a fresh install of Windows 7. That way you have it running first. Then try installing the card and see what happens. If it gives you the same problem you should be able to boot up in safe mode.
My System SpecsSystem Spec
.


09 Jul 2009   #4
dushanle

Win Xp
 
 

tried clean install of build 7000, 7100, 7057 (or something like that), 7201... didn't work
tried upgrade from vista sp1 > 7000, worked don't know how but it worked, suppose that build 7000 don't update vista drivers
tried upgrade from vista sp1 > 7100, 7057, 7201 didn't work
tried upgrade from working build 7000 to 7057, 7100 didn't work

my motherboard is MSI K9A2 Neo and it don't have it's video
My System SpecsSystem Spec
09 Jul 2009   #5
noir7559

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by dushanle View Post
tried clean install of build 7000, 7100, 7057 (or something like that), 7201... didn't work
tried upgrade from vista sp1 > 7000, worked don't know how but it worked, suppose that build 7000 don't update vista drivers
tried upgrade from vista sp1 > 7100, 7057, 7201 didn't work
tried upgrade from working build 7000 to 7057, 7100 didn't work

my motherboard is MSI K9A2 Neo and it don't have it's video
if u have an extra Gcard u can swap with the X1650 temporarily and try to do clean installation with the subtitute Gcard. If everything working fine then maybe ur x1650 have some probs. Cheers
My System SpecsSystem Spec
10 Jul 2009   #6
manosdoc

Windows 7 / W2k8 R2
 
 

There is an official driver @ Windows Update Catalog.
My System SpecsSystem Spec
Reply

 MSI ATI Radeon x1650 Pro + Windows 7




Thread Tools





Similar help and support threads
Thread Forum
Ati Radeon X1650 ---> upgrade to Radeon HD 5670
Hi all, (sorry for bad english): I bought a new graphics card (PCI-Express) to replace the old one that came with my computer: the old one is the ATI Radeon X1650, with 512 MB DDR2 memory; the new one is the ATI Radeon HD 5670, with 1 GB GDDR5 memory. I run Windows 7 Professional on an...
Graphic Cards
ATI Radeon x1600 (x1650) series
so i just wanted to know is it x1600 or x1650... and what kind of cooling is it? bad quality pics i know, but should be clear enough to tell whats on the pic. EDIT: gonna put better pics when i get my cam back (these ones are made with SE G502)
Graphic Cards
Help Needed with Radeon X1650 drivers
Hello all I have upgraded to Win 7 and the graphics will not install properly. Its an AGP Radeon X1650 card. I can't find a driver for it from ATI and was wondering if the fix some have done for other graphics cards (3850) will work on this? Any ideas please? Also how do i do it please? ...
Graphic Cards
Radeon X1650 Pro (512MB) PCI-e (Help needed)
A couple days ago I finally decided to try out Windows 7. To my surprise if found myself liking the experience (I was one to downgrade back to XP from Vista). So far I haven't run into any problems except my video card. In the setup I am using I also have my computer hooked up to my Tv so I...
Graphic Cards
Radeon X1650 problem. please help!
Hello. i have an problem with AGP ati sapphire radeon x1650 pro 256mb. when i try to install drivers, it only installs the install manager and visual studio.same on windows vista setup. and the biggest problem is,if i play games,the screen will blink every time i do a click. please help me!
Graphic Cards
Drivers for ATI Radeon X1650 Series
Ok so unfortunately the only OS i have is Windows 7 as my XP disk do not work. Yes I know that sucks. I'm usually good with this sort of problem however this time im uncertain Of what i need to do. I kind of understand whats been said in other topics but I would like someone to make it clear on...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App