Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7 not detecting my 9800gtx+


18 Jul 2009   #1

Windows 7
 
 
W7 not detecting my 9800gtx+

Windows 7 won't detect my 9800gtx

I recently bought nvidia's setup for 3d gaming, and didn't realize xp wasn't supported.

So I've grabbed two spare HD's and installed Windows 7 on them in RAID 0.

So i've got an xps 600, and i've installed Windows 7 fine on it. At first I put in a 7800 in and used f8 to boot in 680 res. I then installed the 7800's drivers which are supposed to work for the 9800 also. I shut it down and put the 9800 in, and it boots fine.

However, it doesn't detect the 9800 card. Windows kept auto-installing nvidia drivers when I would boot up with the 9800, and they would give me a black screen after windows started. So I deleted the drivers in driverstore/filerepository and that stopped it from installing the bad drivers.

But now i'm stuck with it saying in device manager that I have a VGA compatible video controller, but it won't list it as my 9800. I've tried uninstalling and reinstalling the drivers with the 9800 plugged in, and despite the install and reboot going smoothly, it still won't see the 9800.

It did recognize my 9800 gtx before I rebooted when windows auto installed drivers, but I would get the black screen and it wouldn't boot. I can't install my 3d stereo drivers because they say I don't have a new enough version of geforce display drivers.

I've tried using both 186.18 and the new beta 190.38. I also downloaded some nvidia driver from april from microsoft update, and it gave me the black screen as well.

My 9800 is obviously using the nvidia drivers, since I couldn't even boot up with itb efore I installed the drivers using the 7800.

Anyone know why it won't see my 9800? Or why the older drivers give me the black screen after bootup? Thanks for your help.

edit :: the same nvidia driver for Windows 7 is supposed to work with 7,8, and 9 series cards.


My System SpecsSystem Spec
.

18 Jul 2009   #2

Windows® 8 Pro (64-bit)
 
 

Seems purely a driver issue. Uninstall all the video drivers that you have tried so far from safe mode and then restart the computer in normal mode and then simply do a windows update. You should find a generic video driver for the card and that should do the job of gaming.
My System SpecsSystem Spec
18 Jul 2009   #3

Windows 7
 
 

The card runs windows without the drivers working correctly. I'm typing this from the Windows 7 rig. The problem is that I am only installing windows 7 to use the nvidia 3d vision kit, and all this is pointless if I can't use it.

I've found that the problem lies with my specific card by gigabyte.

Gigabyte 9800GTX+ 1GB | GV-N98XPZL-1GH - NVIDIA Forums

The root of the problem is a bad bios in my card that gives the black screen to any driver above 1.78. I'm only 9 pages into the 18 page thread, but it looks like gigabyte released a new bios to fix the problem.

The new bios seems to allow for people to install the 1.81 drivers in xp back in 2008. I hope that bios will also work fine for windows 7.

Thanks for your quick response tho. I'll post when I get this resolved.
My System SpecsSystem Spec
.


18 Jul 2009   #4

Windows® 8 Pro (64-bit)
 
 

If this card id under warranty, seek for a replacement.
My System SpecsSystem Spec
18 Jul 2009   #5

Windows 7
 
 
Problem resolved

The won't go for that, they'd just give me a link to fix the bios. I'm wayyy too impatient to wait for that after I just ordered my 3d vision.

The problem was my cards bios. IT'S NOW FIXED. Takes 2 seconds to fix. If anyone has a gigabyte card and goes through this, go to giga-byte.com or w/e and download the @bios utility, and the f12 bios for your card. Takes less than a minute to download, install and run. Rebooted, and the new drivers are working flawlessly.

So sad I've wasted like 20+ hours of my life for this one little problem lol.
My System SpecsSystem Spec
18 Jul 2009   #6

Windows® 8 Pro (64-bit)
 
 

Quote   Quote: Originally Posted by noobish View Post
The won't go for that, they'd just give me a link to fix the bios. I'm wayyy too impatient to wait for that after I just ordered my 3d vision.

The problem was my cards bios. IT'S NOW FIXED. Takes 2 seconds to fix. If anyone has a gigabyte card and goes through this, go to giga-byte.com or w/e and download the @bios utility, and the f12 bios for your card. Takes less than a minute to download, install and run. Rebooted, and the new drivers are working flawlessly.

So sad I've wasted like 20+ hours of my life for this one little problem lol.
glad to hear that its working now.
My System SpecsSystem Spec
Reply

 W7 not detecting my 9800gtx+




Thread Tools



Similar help and support threads for2: W7 not detecting my 9800gtx+
Thread Forum
9800GTX + Windows 7 clean install = fail Installation & Setup
Can't select 2x 9800GTX+ SLI as vid source, VGASAVE =\ Graphic Cards
Windows 7 9800gtx+ Graphic Cards
W7 64 bit only detecting 3GB out of 4GB General Discussion
9800GTX+ driver update problem Graphic Cards
Nvidia 9800GTX and Polaroid (proview) 26" LCD = crash Graphic Cards
BFG 9800GTX 512 or BFG 9800GT 1024 Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:05 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33