Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GPU killed my PSU?


23 Jun 2011   #11

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Irishman View Post
Thanks guys.
How about something like this?

Quad Rail 850W Gaming Power Supply Unit For PC 850W PSU | eBay UK
If you can stretch it a bit more I would go for this.

Corsair Builder Series CX 500W ATX Power Supply (CMPSU-500CXUK) [CMPSU-500CXUK]

As others have said, don NOT take a chance on a cheap power supply, they just can't handle it. I paid £229.99 for mine and its money well spent.


My System SpecsSystem Spec
.

23 Jun 2011   #12

Windows 7 Home Premium x64 SP1
 
 

Quote   Quote: Originally Posted by stormy13 View Post

Would 650w be enough considering I have a phenom ii x4 processor?
My System SpecsSystem Spec
23 Jun 2011   #13

Windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by Irishman View Post
Quote   Quote: Originally Posted by stormy13 View Post

Would 650w be enough considering I have a phenom ii x4 processor?
Assuming you buy a quality PSU, that's certified it MIGHT be enough. Honestly I would get a minimal of 700ws, but that's just me.

With that video card and I assume you are going to play some games I wouldn't settle for less than a certified 700w psu.
My System SpecsSystem Spec
.


23 Jun 2011   #14

W7 Professional x64
 
 

Unless you have a bunch of stuff, like six or seven hard drives, a good 650W power supply should be fine. I second the recommendation of corsair
My System SpecsSystem Spec
23 Jun 2011   #15

Windows 7 Home Premium x64 SP1
 
 

Again, thank you guys you've been a great help. I ended up ordering the Corsair TX 650W V2, should be here by Monday!
My System SpecsSystem Spec
23 Jun 2011   #16

W7 Professional x64
 
 

That should do you just fine
My System SpecsSystem Spec
26 Jun 2011   #17

Windows 7 Ultimate x64 SP1
 
 

GTX 480 was running on a 380W????
My System SpecsSystem Spec
26 Jun 2011   #18

Windows 7 Home Premium x64 SP1
 
 

Quote   Quote: Originally Posted by boogieboy View Post
GTX 480 was running on a 380W????
lol No, my old GPU was using the 380w PSU and when I bought my new GPU I also replaced my PSU (with a cheap one that died ).
My System SpecsSystem Spec
Reply

 GPU killed my PSU?




Thread Tools



Similar help and support threads for2: GPU killed my PSU?
Thread Forum
Solved Have I killed my laptop? Hardware & Devices
Have I killed my laptop? BSOD Help and Support
Solved linux killed my win 7 Installation & Setup
7 killed my net Network & Sharing
Sp1 Killed Homegroup Network & Sharing
have i killed my HDD? Hardware & Devices
Avira just killed everything! System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:07 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33