Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Latest AMD Catalyst Video Driver for Windows 7

25 May 2011   #1441

Windows 10 Pro

LOL I just updated from 11.4 to 11.5a not less than 3 hours ago

My System SpecsSystem Spec
27 May 2011   #1442

Windows 10 Home Premium 64bit sp1

I been running 11.5 since is came out straight from AMD site no problems here
My System SpecsSystem Spec
27 May 2011   #1443
Microsoft MVP

Win 7 Ultimate x64

New Catalyst Application Profile 11.5 CAP3 out today,


  • New profiles added with this release:
  • Duke Nukem Forever Forced on Anti-Aliasing through the Catalyst Control Center has been disabled
  • Force Unleashed CrossFire Anti-Aliasing support
  • Transformers War for Cybertron CrossFire Anti-Aliasing support
  • Garshasp The Monster Slayer resolves negative CrossFire scaling
My System SpecsSystem Spec

28 May 2011   #1444

Main - Windows 7 Pro SP1 64-Bit; 2nd - Windows Server 2008 R2

Did the 11.5b hotfix just now. It was the first time I can remember in ages where I didn't have to mess with anything to get it to work.

Now to find out if they were right about the mouse lag issue. I've just about beat my poor old Logitech MX Revolution to pieces in frustration at times. Never thought to blame the video driver...
My System SpecsSystem Spec
28 May 2011   #1445

64-bit Windows 10 Pro

Hello Steve,

I haven't had any lag with my Logitech MX Revolution using the 11.5b hotfix with SetPoint 6.22.24.
My System SpecsSystem Spec
28 May 2011   #1446

Main - Windows 7 Pro SP1 64-Bit; 2nd - Windows Server 2008 R2

I abandoned SetPoint/Mouseware years ago after having numerous other issues. That's probably why I was so quick to blame Logitech. The current lag problem seemed to come and go and also happened with a Microsoft mouse I installed in desperation. I then began to suspect a bug with Win 7 and/or my motherboard USB drivers. I came close to dragging out an old PS/2 mouse at one point.

It rarely happened except during AOEII (yes, I still play a ten year old game...) When I saw the item in the installation notes for the ATI driver which mentioned fixing a mouse lag issue in some RTS games the light in my head clicked on. That was kind of nice. I could cock my head to one side and make shadow puppets on the wall using the beam of light coming out of my ear.

There's a bright side to everything if you look for it.
My System SpecsSystem Spec
29 May 2011   #1447

Windows 10 Pro

Quote   Quote: Originally Posted by Brink View Post
Hello Steve,

I haven't had any lag with my Logitech MX Revolution using the 11.5b hotfix with SetPoint 6.22.24.
Same here, though I'm using the 11.5a right now. In fact I haven't had/noticed the mouse lag with any of the previous cat drivers.

I do however note that the issue exists, even one of the beta testers over at rage3d had it.

Anyway I'm either lucky or just never noticed it, but the issue does exist for others.
My System SpecsSystem Spec
04 Jun 2011   #1448
Microsoft MVP

Win 7 Ultimate x64

For those with the mouse lag issue and don't mind beta/leaked drivers, asder over at Guru3D has posted this one up,

AMD Catalyst 8.86 (Win 7/Vista x86/x64) - Forums

Build Info:
DriverVer=05/12/2011, 8.860.0.0000

and it looks like the mouse lag is fixed in this one. Also a couple of reports of BSOD's with them, but nothing definitive one way or the other whether it is the driver or something else.
My System SpecsSystem Spec
05 Jun 2011   #1449

Main - Windows 7 Pro SP1 64-Bit; 2nd - Windows Server 2008 R2

Thanks, stormy13. Working fine here.
My System SpecsSystem Spec
07 Jun 2011   #1450

Win7 Pro x64

Does anyone how to how manually delete unwanted 11.5 driver folders and files?

HP dv7-3057nr

Win7 Home Premium x64 (preinstalled and later installed SP1)

Turion II M500 2.2 GHz

Mobility Radeon 4200 M880G

I also have the DirectX runtime without the SDK installed. A couple of older programs require older DirectX "components".

I have since uninstalled it, and rolled back to the original preinstalled driver and older CCC. I really liked the new sleeker looking CCC. But had no choice except to rollback. The constant Visual C runtime errors causing only IE9 x64 to crash/hang, got on my nerves fast. I would already have Task Manager or Resource Monitor open and watch the Physical Memory swell up to around 98%. I would eventually just to do forced restarts in the end. The annoying Errror Reporter getting in the way and wanting to restart IE didn't make things any easier. The Java panel got corrupted. Hard to explain. But anything contained in the border or padding would turn black.

At least the dll hell is over. I'm very surprised there wasn't a BSOD. I might become a possible victim of a BSOD in the future. I found some Event Viewer logs that have some info that the Boot time is taking longer that what it used to be. It does take while to show the login screen.

There's remnants of 11.5 and possibly 11.3 and 11.4 as well. The installations obviously failed at some step of the way when unpacking or extracting and replacing/overwriting different system and dll files. (took a peek at the installation logs and found quite a few instances of the words error a and failed in them).

I think it was the 11.4 installer that may be this that was attempting to uninstall the NET Frameworks and Visual C++ redists and replacing them "it's" own.

I bet I ran the SFC command using both the SCANNOW and VERIFYONLY options a several times, but never found any problems.

But some Event Viewer logs say otherwise:

CPLIB :: General - Invalid Parameter

Log Name: System

Source: atikmdag

I'm thinking this one might to do with color profiles.

There had been some background service trying to "phone home" to this AMD/ATI website in the DNS Client logs:

That website maybe why there's a credential listed in the Credential Manager with virtualapp/didlogical in it's name.

I can't recall consenting to anything related to development, since I'm not a developer by any stretch.

What are some these extras that come with these newer driver packages good for anyway? OpenCL, Fuel Service, and some SDK.

I'm glad I don't use any programs that hog a lot of graphics memory, since the base WEI score is only 4.4. For the year I've owned this owned this dv7, I've only watched one DVD in it's entirety. I don't even watch any flash content.

I'll just be honest about the GPU updates. It's only because of IE9 and Firefox 4 being able to take advantage GPU acceleration.

FWIW...I got myself in for more than I bargained for. The old rule of thumb, applies to me. That being... Don't upgrade a driver unless there's a reason to.

This machine is borked enough the way it is anyway.

Mostly because of the violent power outage that ocuured one day when that blizzard/snowstorm dumped about 8 inches of snow and ice around late January to early February this year in my neck of Illinois. It It's more than likely scewed up my wireless card/driver. I can get a decent connection to surf the web. But still numerous Homegroup error logs starting around Groundhog's Day. But I'll leave that up to my brother that lives with me that acts as the "Network Adminstrator". I'm not all that savvy with playing with network settings.

Windows 7 doesen't seem to like my TonePort UX2. I tried all the driver's that are supposed to be compatible with Win7. They would lead to alot of Shell32 errors. Doing factory resets, which have been 5 so far was the only resort. I didn't do a factory reset the last time, uninstalled. That was some time back in January or Decemeber. I got tired of having to uninstall all the bloatware and trial software. Good thing my old XP Pro box is holding up.

That power outage may also be to blame, or some more recent one during some of these thunderstorms that fried my brother's laptop. It's the same one as mine with the same OS. He's thinking the mobo or BIOS destroyed. Wether HP can help him out at all is something to be decided. I'll beleive he'll just buy another.

I'm not sure if SP1 caused my loss of restore points. I saw where write caching is already enabled by default. Power outages or voltage sags and spikes can present a danger of data loss and corruption if write caching is enabled.

Since SFC has proved uselesss. I would like to see if Check Disk can't find anything wrong. But can't run it because it's set it's scheduled to run at boot up.

The BIOS on these dv7s anyway lead to another question. Why is the BIOS info wrapped in so much red tape? CPU-Z is only thing that gives much info, but not the real manufacturer. Does HP actually manufacture their own BIOS?.
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Latest AMD Catalyst Video Driver for Windows 7
Latest AMD Radeon Crimson Video Driver Released How to Install AMD Graphics Drivers Without Installing Catalyst Install Manager
Graphic Cards
I need help with installing the latest AMD Catalyst Video Driver
When I install it my resolution goes to like 640x720 or something like that and I can't change it unless I rollback the driver and I need the driver to play minecraft.
Graphic Cards
BSOD after installing Latest AMD Catalyst Video Driver for Windows 7
I have a His Radeon 4850 and it seems like every time I go to install the latest updates, I get a BSOD after restarting. Am I not installing correctly or something? is there a link to the proper procedure I usually just download and install over the old. Thanks for all assistance. :)
Graphic Cards
Crush with the latest Catalyst driver.
Hello Sapphire ‏‏HD 5870 Vapor-X OC 1GB GDDR5 DX11 - my card When I install the latest 10.10 catalyst driver and running FunMark stability check my screen goes black and pc crashes. On 10.9 this never happens but then I got scaling problem with my screen samsung xl2370. Please help!
Graphic Cards
Latest ATI Catalyst Driver for Radeon X1550 on Se7en?
Hi, i'm using a Radeon X1550 on Windows 7 build 7137. What are the latest drivers avaiable for this card? Now i'm using the Catalyst 8.1 for Vista, and I can't install the Catalyst 9.3 for Vista.
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:12.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App