Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7


01 Apr 2013   #1991

Windows 7 Home Premium 64bit sp1
 
 

Hey Shawn remember that clean install ?

Anyway I got everything smooth as silk installed the 13.3 beta drivers gave it a chance also if you don't have it I can mail it to you the Bios to turn a 7970 reference card into a Ghz ed just did it early took a risk because they have two bios so far so good I have it at 1145/1555 let's hope all my test are stable ran 3d advantage I did get a score boost and it ran through


My System SpecsSystem Spec
.

01 Apr 2013   #1992
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Glad to hear it's running great now Tommy.

I only have a HD5870 though.
My System SpecsSystem Spec
01 Apr 2013   #1993

Windows 7 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by Brink View Post
Glad to hear it's running great now Tommy.

I only have a HD5870 though.
Well I will save it in case someone in the future decide they want to do the same
My System SpecsSystem Spec
.


12 Apr 2013   #1994

Windows 7 Ultimate 32bit
 
 

Downloading 13.3 beta now!
My System SpecsSystem Spec
18 Apr 2013   #1995

Windows 7 Ultimate x64
 
 

hi, after installing the AMD Catalyst Software Suite 13.1 for AMD Radeon HD 4000, AMD Radeon HD 3000, and AMD Radeon HD 2000 Series, i got this problem of green screen for videos only on firefox. I know there's a solution that is to disable hardware acceleration for Adobe Flash player, but I am curious about why it is only happening on firefox but not on chrome and internet explorer. When I play videos on Chrome and Internet Explorer, they play fine without me having to disable hardware acceleration. Also, after installing the graphic drivers, some of the AVI videos show a green screen when i use Media Player Classic Home Cinema and the original Media Player from windows. WMV format videos are even worse, they don't even play on Windows Media Player, it freezes with a black screen. I don't have this problem when using the 12.6 drivers previously. Can anyone confirm that it's a problem for 13.1 drivers? Any way for me to download 12.6 drivers?
My System SpecsSystem Spec
18 Apr 2013   #1996
Microsoft MVP

Win 7 Ultimate x64
 
 

It isn't a problem with 13.1 per se, more of a bug in either the driver or Flash itself. There is also no rhyme or reason as to when or where it will occur, and has (and still does) affected both AMD and Nvidia. If you want to go back to the 12.6 you can find it here,

Previous AMD Catalyst
My System SpecsSystem Spec
18 Apr 2013   #1997

64-Bit W7 Ult_sp1
 
 

Hey, guys..
..if anyone fancies doing some test driving, there's a neat update here:
AMD Catalyst 13.x (12.101.2.1 April 16) - Guru3D.com Forums

- it seems to have cured FC3's occasional lock-ups, and the game now runs at Ultra specs
- could be worth trying, if you've experienced similar problems with recent 13.3BETA's
My System SpecsSystem Spec
18 Apr 2013   #1998

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by stormy13 View Post
It isn't a problem with 13.1 per se, more of a bug in either the driver or Flash itself. There is also no rhyme or reason as to when or where it will occur, and has (and still does) affected both AMD and Nvidia. If you want to go back to the 12.6 you can find it here,

Previous AMD Catalyst

it's not with flash itself, because i can view youtube videos etc. in chrome and internet explorer without disabling the hardware acceleration. and it's not only happening with youtube videos, it also happens with the original Windows Media Player and Media Player Classic Home Cinema. I didn't have the same problem when i'm using 12.6, it only happened after i installed 13.1. There's problem only when playing videos, when playing games, everything is fine.

The link you gave is not for the legacy driver version, i.e. the supported device list doesn't include AMD Radeon HD 4870.
My System SpecsSystem Spec
23 Apr 2013   #1999

64-Bit W7 Ult_sp1
 
 

My System SpecsSystem Spec
24 Apr 2013   #2000

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

just received a tweet @CatalystCreator: AMD Catalyst 13.4 WHQL and AMD Catalyst 13.5 Beta are now live link
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33