Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Latest AMD Catalyst Video Driver for Windows 7


27 Jul 2009   #441

Windows 7 x64 RC Build 7100
 
 
Note for X1xxx "legacy" ATI users...

Hi all,

Just a note for other older ATI hardware users/enthusiasts who want the latest version of the ATI driver suite for use under Windows 7... (er, that was meant to mean users of older ATI hardware, not old users of ATI hardware )

ATI support sent me to the 9.1.3 build of their 64-bit Catalyst drivers for Windows 7 x64 a bit over 2 weeks ago, and unfortunately, that driver set hasn't been updated since then.

And since the PCIe X1600XT (and similar X-series and 9xxx series cards) are now in "legacy support" mode, ATI won't be providing support (or, presumably, driver updates) until after their "build 7600 compatible" drivers are finalised. If they do provide updates sooner, it will only be on a "best effort" basis. That could work either way, I suppose...

I guess that's the way the cookie crumbles (drivers compile?) these days. But hopefully, this might help to minimise disappointment for others like me with perfectly acceptable but superseded hardware...

If anyone does get info about the Windows 7 drivers for the older cards, please let us know! I'll do the same.


My System SpecsSystem Spec
.

27 Jul 2009   #442

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

Are you looking in the device manager? Once the ATI drivers are removed Windows will use it's own generic standard vga drivers and that will be indicated in the display adapter section in the device manager there.
My System SpecsSystem Spec
27 Jul 2009   #443

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by Airbot View Post
try and see if you can install the new driver this way in Smarteyeballs post here, but for the 9.7 drivers.






http://www.sevenforums.com/graphic-c...html#post64410
Holy cow! Thanks so much! This brute force method worked perfectly!
My System SpecsSystem Spec
.


27 Jul 2009   #444

Windows 7 Ultimate x64 SP1
 
 

LOL, the infamous 9.4 fiasco fix. Glad it worked for you, because it was the last thing I could suggest.
My System SpecsSystem Spec
28 Jul 2009   #445

windows 7
 
 
cant start up catalyst control center

hey could any1 giv me some help..i am using hpdv5-1106ax with 3400 ati graphics card..i was previously using vista 32bit and now recently i installed win 7..downloaded all the drivers and is workin superb..my only prob is i insatlled 9.7 catalyst suite and drivers but in my device manager it is showin ati 3400 installed. but i am not able to open my catalyst center... wen i click right button in desktop its showin ATI CATALYST CENTER but not able to open it..when i clik nothing happens..
wen i checked in my task manager i found that it is running..

any 1 had such kind of prob...
it would be gr8 help if some could tell how 2 correct this...
My System SpecsSystem Spec
28 Jul 2009   #446

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

Quote   Quote: Originally Posted by Airbot View Post
LOL, the infamous 9.4 fiasco fix. Glad it worked for you, because it was the last thing I could suggest.
It only took a trip into the device manager!

Meanwhile the 9.7 finally went on here without fuss. It simply took a new "beta fish" wallpaper to solve that little problem!
I also seeing a problem where one program refused to work on the host RC64 while it works perfectly on the second? Time for another clean install again!

Quote   Quote: Originally Posted by mail2parun View Post
hey could any1 giv me some help..i am using hpdv5-1106ax with 3400 ati graphics card..i was previously using vista 32bit and now recently i installed win 7..downloaded all the drivers and is workin superb..my only prob is i insatlled 9.7 catalyst suite and drivers but in my device manager it is showin ati 3400 installed. but i am not able to open my catalyst center... wen i click right button in desktop its showin ATI CATALYST CENTER but not able to open it..when i clik nothing happens..
wen i checked in my task manager i found that it is running..

any 1 had such kind of prob...
it would be gr8 help if some could tell how 2 correct this...
You have to be a little patient and a welcome anyways to the Se7enforums here! mail2parun

Did you restart the system inbetween all updated and the 9.7? Often you have to left everything finish installing in order to get one thing hanging to work when the rest are finished.


Attached Thumbnails
Latest AMD Catalyst Video Driver for Windows 7-latest-beta-fish.jpg  
My System SpecsSystem Spec
28 Jul 2009   #447

windows 7
 
 

hi everybody
I have a little problem, I'm running windows 7 rtm 7600 (64bit) on my hp pavilion with an ati hd4500.
The driver is installed but I can't seem to get the catalyst center to work. I've installed the 9.7 driver and everything seems to go well with the installation, it even says, installation completed, but the catalyst center isn't enywhere to be found. When I go to the folder ..programfiles/ati technologies the folder is just empty. my laptop says the ati install manager is installed but the catalyst control center not. I had the same problem when I was running the windows 7 rc.
I've tried to install the ccc from the extraction folder on c:/ati but still same problem.
Can anybody tell me what's wrong?
Thx
Dani
My System SpecsSystem Spec
28 Jul 2009   #448

Windows 7 Home Premium 64-bit
 
 

Hey guys, I'm back.

There's a problem that I'm having. Ever since I was able to install the driver for my radeon 3850 properly, the fonts tend to get messed up. When I maximize/minmize, that's when it happens. I have attached a picture of it in this post and tell me what you guys think. Thank you.

EDIT: Also, it's only happening in the Aero theme.

EDIT 2: Another thing I notice. When I play games, its very laggy. Should I go back to the old drivers?

EDIT 3: Okay, I don't think I gave you every information about my card. I forgot to say, it's an AGP and not a PCIE! Maybe this is why its not working properly.


Attached Thumbnails
Latest AMD Catalyst Video Driver for Windows 7-fongmessedup.jpg  
My System SpecsSystem Spec
29 Jul 2009   #449

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ShaolinMilk View Post
Hey guys, I'm back.

There's a problem that I'm having. Ever since I was able to install the driver for my radeon 3850 properly, the fonts tend to get messed up. When I maximize/minmize, that's when it happens. I have attached a picture of it in this post and tell me what you guys think. Thank you.

EDIT: Also, it's only happening in the Aero theme.

EDIT 2: Another thing I notice. When I play games, its very laggy. Should I go back to the old drivers?

EDIT 3: Okay, I think I don't think I gave you every information about my card. I forgot to say, it's an AGP and not a PCIE! Maybe this is why its not working properly.
hmm tricky problem,
i suggest fisrt reinstalling the drivers, if that dosent work try installing an older version of the drivers,
if that dosent work download the vista drviers and run in compatibilty mode
My System SpecsSystem Spec
29 Jul 2009   #450

windows 7
 
 

Quote   Quote: Originally Posted by Night Hawk View Post





You have to be a little patient and a welcome anyways to the Se7enforums here! mail2parun

Did you restart the system inbetween all updated and the 9.7? Often you have to left everything finish installing in order to get one thing hanging to work when the rest are finished.
danks nighthawk yup i had restarted system after install but still its not comin...
My System SpecsSystem Spec
Closed Thread

 Latest AMD Catalyst Video Driver for Windows 7




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:45 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33