Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: blue screen with GeForce 7900 GT

31 Oct 2009   #31

win7 64

Hi all, joining the ranks of the 7900GT + win7 problem owners. Have been reading a lot of forums and posts and it seems that the only work around is modding your gpu bios (increasing the speed by 5 mhz).
Software recommended to do this is Nibitor or Evga precision. However I am not able to launch these programs in win7 (64 bit).

My question:
- is there a flashable bios out there that i can just download and install while in win7
- if there is no easy fix: how do I manually edit my bios (e.g. how can i create a bootable disk from where to change the bios, im new to this, so pointing to a step by step guide would be appreciated)

Thx for any replies

My System SpecsSystem Spec
01 Nov 2009   #32

windows 7

From another thread, here is a link to the step by step instructions i used to flash my card:

.:: BenchZone ::. Get in the Zone, stay in the Zone! - nVIDIA GeForce 8 Series Detailed Overclocking Guide

I couldnt get those programs to work under windows 7 either, so booted into xp to do this, im afraid this may be your only course of action.

It was fairly straight forward, still scary though! but all went well.

My System SpecsSystem Spec
01 Nov 2009   #33

win7 64

Hi Johnym,

great idea. but aint got any other windows versions anymore (just win7)

any recommendations?
My System SpecsSystem Spec

02 Nov 2009   #34

win 7 32 bit

Rivatuner works fine for me both in 32bit and 64bit.
My System SpecsSystem Spec
03 Nov 2009   #35

Windows 7 Ultimate

rivatuner is the software solution and is not permanent like the bios flashing...

if you only have windows7 (64bit) then try to use XP Mode... not tested though...

Windows 7 32bit has no problem with the flashing software.
My System SpecsSystem Spec
09 Mar 2010   #36

XP - Right now
Think of upgrading to Windows 7

Great thread and thanks to everyone for all the information.
I have a quick question; I would like to upgrade to windows 7 and use my two (SLId) 7900 GT cards. Judging by the comments this may be a problem
I have two that have different GPU speeds, both overclocked by the manufacture, one is at 500 mhz (overclocked) and the other is at 550 mhz (super -overclocked).
Would I have to overclock both of them by 5 mhz to get them to work in Windows 7?
Any thoughts on this?
My System SpecsSystem Spec
11 Mar 2010   #37

win 7
Bios Mod using Windows 7

Hey all,

Been having the same problem with my GeForce 7900 GT with Windows 7.

I didn't want to run RivaTuner all the time and wanted to do the bios mod but NiBiTor wouldn't recognize my card at all.

After much searching I found a workaround.

You'll need the following:

UltraIso Me

You'll also need this file: nV_Flash_v5_50_Disc_Image.ima
which I got from .:: BenchZone ::. Get in the Zone, stay in the Zone! - nVIDIA GeForce 8 Series Detailed Overclocking Guide

Open GPU-Z
Save Bios as original
Rename to original.rom

Open NiBiTor
read saved bios
tweak bios (I changed all values by +10 and it seems to be working)
save bios as newbios

Open UltraIso ME
open nV_Flash_v5_50_Disc_Image.ima
go to Actions>add files
add original bios and new bios
select files and extract to a folder
then File>Save as>something.ima file

Open Nero Burning rom
select make bootable CD or DVD
browse for ima file you created and burn === didn't work for me so I manually added extracted files from folder created.

Boot with CD or DVD in drive
Enter over date and time
Type dir to verify that original and newbios are there
Type nvflash -5 -6 newbios.rom
verify bios info's match
press y and wait for it to finish

*** if not successful, try to restore original bios *****


Hope this helps someone else.

My System SpecsSystem Spec
12 Mar 2010   #38

Windows 7 Pro x64

Thanks for detailed instructions Tushy! Worked perfectly! After getting the run-around from EVGA this was a life saver!
My System SpecsSystem Spec
15 Sep 2010   #39

Windows 7 Professional x86

Thanks alot guys, these instructions worked just like a charm!

Only thing i needed to change was Nero Burning Rom. Wasn`t able to get a bootable CD out of this, maybe its because i only have Nero Express. Used the free tool cdburnerxp instead, which did the job just fine.

Geez, this problem bugged me so much, so glad that i found a fine fix. Thanks alot!
My System SpecsSystem Spec
23 Jan 2012   #40

win 7 32 bit

Just an update. I ran into this problem again after getting a virus. I removed the virus and upon rebooting, got a blank screen. I thought the virus was still there. What happened was the malware changed my user account settings to cause riva tuner to not load without peqrmission. Problem was my monitor was going to sleep before i could see what was going in. After the splash screen i would get the zig zagss and then a few moments later the screen would go black and windows would continue to load and i would here a few dings from something failing but i didnt think to check video card as this was fixed so long ago.

In the search to find what service was causing the screen to black we used msconfig to turn everything off. With all shut down, windows booted up fine no zig zags. What we found was that desktop windows management is the culprit causing this card to bomb. With everything else on and DWM off, and rivatuner off, windows boots up fine no sync issues. If anyone can dig further, maybe its just a setting causing this that is part of dwm

My System SpecsSystem Spec

 blue screen with GeForce 7900 GT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Blue screen after install geforce driver
Hello! I have Asus N56JN-CN047. If i install nvidia driver and i restart laptop i have blue screen with nvlddmkm.sys error. Could you help me? Thanks
BSOD Help and Support
Geforce 7300 LE - Blue screen of death - Multiple lines down screen.
Today I booted my computer up to be promoted with a black screen, I gave it a good half an hour before forcing it to shutdown, to which when I booted it back up. Was then promoted with a blue screen about the video card not being able to lead, that happened twice. I then booted it into safe...
Graphic Cards
Standard VGA/GeForce Go 7900 GS
I recently got my hands on a Toshiba Satellite P105-S9339. As it was second hand I totally wiped the hard-drive and then installed Windows XP and upgraded to Win 7 Enterprise 32bit from there. Everything has been working peachy... except for my graphics card. I assume I have the default GeForce Go...
Graphic Cards
Huge Problem with geforce 7900 GT --- horizontal lines
Hi, I've been searching for a solution all day I try here..! Today I tried to install Windows 7 64 bit RTM, aswell as 32 bit RTM on my desktop PC, with the same Problem. All Drivers were automatically installed by Win 7, BUT somehow the graphic driver for my XFX geforce 7900 GT is not...
Graphic Cards
Nvidia GeForce Go 7900 GS
Ive been running xp for ages now and seeing that windows 7 was going on sale I decided it was time to upgrade. I have a Dell xps m1710 laptop with an nvidia geforce go 7900 gs graphics card. Before installing windows 7 I thought it best to check that it would run on my machine so I downloaded...
Graphic Cards
Nvidia GeForce 6200 Causing Blue Screen
I've been getting the BSOD when trying to open pictures or videos. I thought it was due to installing DirectX 9.0, but I've since reinstalled Windows 7 RC and started fresh again. Now get this. Everything worked fine. I used the 'generic' video driver that gets installed with Win7 RC and just...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:41.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App