Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Flicker after installing latest NVIDIA 8600M GT driver

16 Oct 2011   #1
end0ftime

Windows 7 Ultimate x32
 
 
Flicker after installing latest NVIDIA 8600M GT driver

So I just recently upgraded to Windows 7. After installing all the necessary drivers provided by Windows Update, It was time to install the one provided for the Graphics Card. Ever since I've got the driver set, there seems to be this flicker on the screen that tends to show up every few seconds.

It's really annoying.. can anybody help?


My System SpecsSystem Spec
.
16 Oct 2011   #2
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Welcome to Windows Seven Forums.

Having the latest driver is not always the best solution.

Have you tried rolling back to the previous driver from within Device Manager or downloading one from the manufacturer's driver page?
My System SpecsSystem Spec
16 Oct 2011   #3
end0ftime

Windows 7 Ultimate x32
 
 

Yes and every time I do that it goes back to Standard VGA. -__-
My System SpecsSystem Spec
.

16 Oct 2011   #4
vspeck23

Windows 8 Pro Media Centre Edition 64Bit, Windows 8 Home Premium 64bit
 
 

try changing tto 50 Hz 60 Hz 75 Hz it may get rid of the flicker , you will find it , right mouse desktop Screen resolution / advanced settings and under the monitor tab
My System SpecsSystem Spec
16 Oct 2011   #5
end0ftime

Windows 7 Ultimate x32
 
 

The only option available is 60. Would I be able to install an older version of the driver?
My System SpecsSystem Spec
16 Oct 2011   #6
end0ftime

Windows 7 Ultimate x32
 
 

The screen flickers even with the driver provided through Windows Update.. =/
My System SpecsSystem Spec
17 Oct 2011   #7
vspeck23

Windows 8 Pro Media Centre Edition 64Bit, Windows 8 Home Premium 64bit
 
 

maybe you have a lose connection with the cable try wiggling it and see if it makes it worse or better or maybe your gpu may be damaged
My System SpecsSystem Spec
Reply

 Flicker after installing latest NVIDIA 8600M GT driver




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD randomly after installing latest Nvidia Driver.
Little background, bought an GS60-003 Ghost from MSI a few weeks ago and it game with windows 8 OEM. I really don't like windows 8 so I figured I would give Ubuntu a try and I found a didn't like that either. Ultimately I decided to purchase Windows 7 Home Premium x64 and have that installed as my...
BSOD Help and Support
Non 7z archive error when installing latest NVidia update 337.88 - WHQ
Whenever I try to install it I get this window popping up saying ''Non 7z archive. Anyone know why this isn't working? Drivers | GeForce
Graphic Cards
Windows 7 Refusing to post after installing Latest Nvidia Drivers
Okay. This combination of drivers works fine in windows vista 32 bit.. boots up fine and everything. Today I finally got my SSDD for my OS and a copy of Windows 7 64 bit. I installed it fine without error. Then installed my chipset drivers that I downloaded off of Nvidia's website (64 bit, worked...
Drivers
nvidia isn't installing latest driver
Hai friends, I am using HP Pavilion dv6-7012tx with 2gb nvidia geforce gt630m graphics card.My driver version is 295.55.Recently when I checked for driver update in nvidia control panel it showed that version 301.42 is available & the nvidia website also showed that update is available for my...
Graphic Cards
Driver Issues|nVidia 8600m GT|Win7Ult 64|VAIO
Hello. This forum has so far given me the most hope for solving my driver issues... Here's my story, I hope you can help! Computer: VAIO VGN-AR870 Former OS: Windows Vista Home Premium 32-bit Current OS: Windows 7 Ultimate 64-bit GPU: nVidia 8600m GT I've tried installing the drivers from...
Drivers
Latest nVidia Driver not working in Win 7:
Hi I have just installed Win 7 onto a partition on my machine: MoBo: ASUS P5N32-e SLi Bios Revision 1203 Processor: Intel E6750 2.66 MHz Video Card: nVidia GeForce 8600GT Memory: 2 x 2048 Mb DDR2 PC2-5300 (333Mhz) Dual Monitors: 1680 x 1050 and 1280 x 1024 My system is...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App