Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Upgraded gfx card but getting fps lag - please help


17 Oct 2011   #1

Windows 7 home premium 64bit
 
 
Upgraded gfx card but getting fps lag - please help

Hi,

I recently upgraded my graphics from the 550 ti to the gtx 570 and for some reason I get fps lag. This originally happened when i upgraded my motherboard thinking it was just a graphics problem and now it's happening with the new graphics card for some reason. I'm not complaining about buying a new card and it being the same because i needed an upgrade anyway..

Specs-

Asus m5a78L motherboard
AMD phenom II x 4 3.4Ghz
8Gb Corsair RAM
Xentra 800w PSU
Asus gtx 570 Direct CU II

Please help, all will be appreciated!


My System SpecsSystem Spec
.

17 Oct 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64 Windows 8.1 x64
 
 

Hi Ccloyd,

A couple of things to check :

1. Is your GFX card compatible with your motherboard?
2. Do you have the latest drivers installed?

Is it only certain games that lag, or several?

Regards,
Golden
My System SpecsSystem Spec
17 Oct 2011   #3

Windows 7 Home Premium 64-bit
 
 

What is the driver version that you currently have?
What are the games with which the issue is happening?

Driver versions that you have tried apart from the current one?
My System SpecsSystem Spec
.


18 Oct 2011   #4

Windows 7 Ultimate 64 Bit
 
 

In one week time you upgrade your gpu from a 9800 to a 550ti to a GTX570 while you thought the problem was in your new motherboard since the problems started happening after you got the new mobo.You must have money too much or something.Anyway,i dont think its necessary to keep making so many threads about the same problem,and in all threads you are kinda vague..Try to provide a video,while your playing a game or some screenshots with fraps running to show us your fps and to show the problem you have,because this is going nowhere.

PS: I still think you should get a bios update for that mobo,maybe it has some incompatabilities with your cpu,gpu,or memory.

Also,your motherboard has 1 x PCIe 2.0 x16,make sure your gpu is installed in that slot.To see where it's located look it up in your mobo manual.
My System SpecsSystem Spec
18 Oct 2011   #5
Microsoft MVP

Win 7 Ultimate x64
 
 

I would start with looking at that power supply you have. The best I can find about that make and model is to avoid it at all costs,

My GTX 260 has two power connectors - Guru3D.com Forums

AMD Game Forums - HD 6870 Crossfire crashing PC whilst loading games.

and no the reviews on ebuyer are the last thing to go on as they can and will delete anything that isn't positive.
My System SpecsSystem Spec
18 Oct 2011   #6

Windows 7 64bit
 
 

Quote   Quote: Originally Posted by clloyd21 View Post
Hi,

I recently upgraded my graphics from the 550 ti to the gtx 570 and for some reason I get fps lag. This originally happened when i upgraded my motherboard thinking it was just a graphics problem and now it's happening with the new graphics card for some reason. I'm not complaining about buying a new card and it being the same because i needed an upgrade anyway..

Specs-

Asus m5a78L motherboard
AMD phenom II x 4 3.4Ghz
8Gb Corsair RAM
Xentra 800w PSU
Asus gtx 570 Direct CU II


Please help, all will be appreciated!

I am not totally familiar with the Bios layout for your MOBO, but go into the bios and check these settings; Initial display first (PCIE), PCI/VGA Palette Snoop (Disabled), and Maximum Payload Size (4096).

If your MOBO has onboard video insure it is disabled. You should also insure that your motherboard has the most current bios.

Download, "but do not install at this time," the most current video drivers for the 570. Google for a program called driver sweeper. Uninstall the video drivers, after reboot run driver sweeper to insure that all related materials for the video drivers were unistalled. Driver Sweeper will also remove entries in the registry. Install the new drivers for the 570. This should cure your problems. Link for driver sweeper, Phyxion.net - Driver Sweeper

Your PSU should be more than adequate.

If you are still having issues then I suggest a program called GameBooster 3.0. This program will shutdown unnecessary programs that are running in the background and will assist in your game performance. Here is the link for GameBooster, Game Booster 3.0 Free Download, Speed Up PC for Top Gaming Performance
My System SpecsSystem Spec
21 Oct 2011   #7

Windows 7 home premium 64bit
 
 

Okay, solved it quite easily. My cpu was overheating as the the fan wasn't put on perfectly flat... Thanks anyway!
My System SpecsSystem Spec
Reply

 Upgraded gfx card but getting fps lag - please help




Thread Tools



Similar help and support threads for2: Upgraded gfx card but getting fps lag - please help
Thread Forum
Bought a video card (and upgraded the PSU) Graphic Cards
What kind of graphic card be upgraded on this computer? Graphic Cards
I need an upgraded card for my HP Slimline s5200. Graphic Cards
Solved Just upgraded RAM/Graphics Card Hardware & Devices
Has anyone upgraded their PC w USB3.0 card?? Hardware & Devices
Just upgraded to 7, no Graphics Card appearing Graphic Cards
Upgraded to W7. No sound. Creative Xfi card. Help! Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33