Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Monitor problem! Can't figure out the cause...


22 Oct 2011   #1

 
 
Monitor problem! Can't figure out the cause...

Hi guys! Faced really strange problem. Got a PC with Nvidia GeForce 6150 graphics card with no overclocking. Sometimes the monitor loses signal and does not work. Sometimes it works just fine.

I've tried different VGA cable and different monitor, situation didn't change.

I've got 4 different connectors. 1 VGA and DVI on Nvidia + 1 VGA and DVI built in into motherboard. Sometimes, when the Nvidia doesn't work, I connect to built-in card and monitor starts working. Next time when it's out, I connect back to Nvidia. There have been situations when only one of the four connectors is working. This means that on one graphics card there may be only one connector which is functioning.

I don't get this. Problem isn't in the display nor the cable. It also doesn't seem to be in the graphics card as the built-in connectors aren't fully functional neither.

Please help me out guys!


My System SpecsSystem Spec
.

23 Oct 2011   #2

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

first of all make sure all the drivers are up to date, and get back to us
My System SpecsSystem Spec
23 Oct 2011   #3

 
 

Which drivers are you talking about? The PC was working just fine before. I don't see why the drivers might be causing the problem.

BTW, when I click "check for updates" in the device manager, it states that drivers are up to date.
My System SpecsSystem Spec
.


23 Oct 2011   #4

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

your Nvidia drivers. last update was about 4 weeks ago.

just because it was fine a while ago, another windows update or such could cause an issue with the current drivers. Last AMD drivers caused my rig to Blue screen randomly.

if its a hardware issue theres nothing anyone on the forum can do, other than say "yep its fudged"
My System SpecsSystem Spec
23 Oct 2011   #5

 
 

If it's the driver, why aren't the motherboard built-in connections working neither?

Installing the Nvidia driver ATM from Nvidia's website.
My System SpecsSystem Spec
28 Oct 2011   #6

 
 

Same problem still present after the driver install... What should I try next?
My System SpecsSystem Spec
Reply

 Monitor problem! Can't figure out the cause...




Thread Tools



Similar help and support threads for2: Monitor problem! Can't figure out the cause...
Thread Forum
Computer is performing poorly, trying to figure out the problem. Performance & Maintenance
Solved How do i figure out display issues problem? Graphic Cards
I think this is a driver problem, can't figure out which BSOD Help and Support
Need Help to figure out my BSOD problem. BSOD Help and Support
Dual Monitor Problem - Only 1 monitor working Graphic Cards
Can't Figure Out A Problem Hardware & Devices
dual monitor problem (primary monitor disappears) Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:34 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33