Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After installing ATI Driver, restart but shows nothing

06 Aug 2009   #1

Windows 7
 
 
After installing ATI Driver, restart but shows nothing

Hi, I'm still 3 days old to Windows 7 and i had this problem.
I installed the latest driver for Windows 7 for my display card ATI HD3870 and downloaded the driver from the official website.
My problem is, after installing the driver.
The installer didn't prompt me to restart the computer.
But since my notification area didn't appear any of ATI icon so i restart it.
But yet after restarting my pc i still don't see any icon and i went to check program files and i saw ati technologies but inside it i don't see a single item.
It's an empty folder.
So did i went to device manager and right click on my display driver and press update driver but it says I'm on the latest driver already.
This is so confusing! Anyone help me please??!


My System SpecsSystem Spec
.

06 Aug 2009   #2

Windows 7
 
 

i think i know why, maybe because i only downloaded the "Display Driver" but not the catalyst software suite, downloading now, hope it works !
My System SpecsSystem Spec
07 Aug 2009   #3

Windows 7
 
 

You can't get the control panel to show up if you don't install it, so your current download should fix the problem. btw I have found the new ATI drivers do not require a restart usually after the installation.
My System SpecsSystem Spec
.


07 Aug 2009   #4

 
 

Quote   Quote: Originally Posted by Stranger View Post
You can't get the control panel to show up if you don't install it, so your current download should fix the problem. btw I have found the new ATI drivers do not require a restart usually after the installation.
+1

However the drivers do require a restart in Vista
My System SpecsSystem Spec
08 Aug 2009   #5

Windows 7
 
 

That is probably true for Vista, which is why we are discussing Windows 7.

I have just finished installing Windows 7 RTM including all my drivers, and the radeon driver definitely did not require a restart.

As a side note....it is nice to have Windows 7 fully activated
My System SpecsSystem Spec
11 Aug 2009   #6

Windows 7
 
 

yes guys, i found my problem.
I was dumb enough to download the display driver only but not the CCC Catalyst.
So even the display driver is installed, the icon in notification bar did not show.
So i went to download another CCC Catalyst software and boom it shows.
My System SpecsSystem Spec
12 Aug 2009   #7

Windows 7
 
 

Quote   Quote: Originally Posted by iLachva View Post
yes guys, i found my problem.
I was dumb enough to download the display driver only but not the CCC Catalyst.
So even the display driver is installed, the icon in notification bar did not show.
So i went to download another CCC Catalyst software and boom it shows.
Quote   Quote: Originally Posted by Stranger View Post
You can't get the control panel to show up if you don't install it
My System SpecsSystem Spec
18 Aug 2009   #8

WINDOWS 7 !
 
 

nah i have the catalist and it installs, but the version in the controller is still with out update... :S:S:S

any help??
My System SpecsSystem Spec
Reply

 After installing ATI Driver, restart but shows nothing




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:41 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33