Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HD 6850 startup problems


12 Dec 2011   #1

Windows 7 Home Premium 64bit
 
 
HD 6850 startup problems

Hey there! Before I start, thanks for looking at my thread, any feedback is appreciated.

I have built a new system (the other day) with a new MSI HD 6850 graphics card. When I installed windows 7 everything is fine. The graphics card, however, is showing up in the device manager as 'Standard VGA device". So, I go to install the latest drivers through device manager, that results in the changing of this to "HD 6800 series...". I am then prompted to restart the pc, which is when the problem arises. After the windows flag, I am left with a blank screen, although something is happening because the backlights are still there. Tried numerous reinstalls after formatting disk etc. Tried updating BIOS. Computer runs fine in safe mode. When I boot to the last successful load up, the computer works fine again, until of course the driver installs once again.

Cheers, Triopas.

My System SpecsSystem Spec
.

12 Dec 2011   #2

Windows 7 Home Premium 64bit sp1
 
 

does your motherboard has onboard graphics ?

If so try disabling onboard graphics and see what happens
My System SpecsSystem Spec
12 Dec 2011   #3

Windows 7 Home Premium 64bit
 
 

There are no onboard graphics, no. The thing is, when the card is shown as "Standard VGA device", the clock speed/memory etc. are all as they should be. It seems that as soon as the system recognises it's a HD6800 series, the problems arise.

Cheers, Triopas.
My System SpecsSystem Spec
.


12 Dec 2011   #4

Windows 7 Home Premium 64bit sp1
 
 

card might be faulty

does it message you driver stoped responding and has recovered ?
My System SpecsSystem Spec
12 Dec 2011   #5

Windows 8.1 Pro
 
 

Quote   Quote: Originally Posted by Triopas View Post
So, I go to install the latest drivers through device manager, that results in the changing of this to "HD 6800 series...".
Try installing the drivers the standard way, not through Device Manager - GPU-33: How to install AMD Catalyst. Let's try installing the drivers the correct way before delaring the card bad.

Let us know.
My System SpecsSystem Spec
12 Dec 2011   #6

Windows 7 Home Premium 64bit
 
 

Doesn't say anything about drivers not responding, just a black/blue'ish screen after windows flag.

I have tried both installing the drivers on the CD provided and through that recommended by the card manufacturers website.

Cheers, Triopas.
My System SpecsSystem Spec
12 Dec 2011   #7

Windows 8.1 Pro
 
 

Check that all the power connectors are connected, including the one to the vide card itself. You might also try reseating the video card.

And are you getting the drivers here - ATI Video Card Drivers

BTW please complete the System Specs section of your CP

Thanks
My System SpecsSystem Spec
12 Dec 2011   #8

Windows 7 Home Premium 64bit
 
 

That is the site i've been getting the drivers from yeah.

Completed system specs.

Checked all power connectors, tried with drivers again, still wont work.

Cheers, Triopas.
My System SpecsSystem Spec
12 Dec 2011   #9

Windows 8.1 Pro
 
 

Are you getting a video signal? If so can you post a screen shot of your Device Manager? How to upload screen shots - http://www.sevenforums.com/general-d...tml#post852738

If you're not getting a video signal, than yeah, the card may be bad.
My System SpecsSystem Spec
12 Dec 2011   #10

Windows 7 Home Premium 64bit
 
 

What do you mean by video signal?

Cheers, Triopas.

EDIT: Just realised what you meant, I'll post them when I'm home.
My System SpecsSystem Spec
Reply

 HD 6850 startup problems




Thread Tools



Similar help and support threads for2: HD 6850 startup problems
Thread Forum
Upgrade from 4870 to 6850 BSOD problems Drivers
Problems with startup. Performance & Maintenance
Radeon 6850 - freezing on startup Graphic Cards
Solved Radeon HD 6850 Problems Graphic Cards
GTX 460 1 GB or HD 6850? Graphic Cards
Problems on Startup Performance & Maintenance
still having problems with startup General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:10 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33