Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with ATI Radeon HD 4300, White Screen

22 Dec 2011   #1

Windows 7 Ultimate x64
 
 
Problem with ATI Radeon HD 4300, White Screen

Hi all,
I have a Dell Inspiron 1564, with ATI Radeon HD 4300 Card Graphic and Windows 7 64 bit.
Some days ago, when I power laptop on, after about 5 mins,The screen shows a white page. I restarted system, but problem didn't solve.
I thought that might battery has problem, but today, problem occurred again, with out battery.
The action center alert me that:
"Address a problem with ATI Graphics Driver. ATI Graphics Driver has stopped working properly."


Can any one help me please to solve this problem.

Best regards,
Nima


My System SpecsSystem Spec
.

22 Dec 2011   #2

window 7 64b SP1
 
 

I am not 100% sure this will fix it.But run this to reinstall the driver.
ATI Catalyst
Do you got any software to shows temps?If not,try core temp.When app opens be careful when you click next.Will ask if you want to install other stuff.Uncheck what you don't want.
Core Temp
I believe either your GPU driver may be corrupted or your GPU may have heat damage.
My System SpecsSystem Spec
01 Jan 2012   #3

Windows 7 Ultimate x64
 
 

Thanks for your help and sorry for late reply.
I installed last version of ATI Catalyst, but problem didn't solve.
It feel this problem occurs when the screen must change, for example I had this problem when slides of PowerPoint changed or I saw a film, or if power on my laptop badly (meaning power on by holding down power button low (not by powerful press)

After this problem occurs, If system goes to Sleep and power on again, the screen is correct and isn't white.
My System SpecsSystem Spec
.


03 Jan 2012   #4

window 7 64b SP1
 
 

You're welcome.What temps are you getting?
Try this driver
http://www.dell.com/support/drivers/...iverId=R265297
My System SpecsSystem Spec
04 Jan 2012   #5

Windows 7 Ultimate x64
 
 

Thank you greenwizard for your reply.
This laptop is not mine but my friend asked me to find the problem! I told him to take measures temps, but he didn't yet.
This link of dell is for 4330, but this laptop has 4300. If is installed, might cause problems?
My System SpecsSystem Spec
04 Jan 2012   #6

window 7 64b SP1
 
 

I am not sure.I put up a couple pics off the dell site.From what I could find their is 2 different 1564.One has i3 & other has i5.5450 & 4330 is only two they list.I read on another site one with a Core i5 - 430M-ATI Mobility Radeon HD5430.You can try the driver I gave.If it fails still,go to the amd site,select notebook,& try auto detect & install.I don't think
I can help any further.I believe it is a driver issue,the laptop needs cleaned & needs new thermal applied,or it has heat damage.I'm leaning more towards driver because you say it will tell you "Address a problem with ATI Graphics Driver. ATI Graphics Driver has stopped working properly."If it was a heat issue,it would probably just freeze.Some computers need a older driver to work with everything else it has & using a up to date driver can cause it to malfunction.But not always the case,some work fine with newer drivers.Maybe the chipset Needs updated before you can update the GPU if the chipset is intel.Which I think it has for chipset.Just a thought


Attached Thumbnails
Problem with ATI Radeon HD 4300, White Screen-45.jpg   Problem with ATI Radeon HD 4300, White Screen-dwm-2012-01-04-07-35-27-05.jpg  
Attached Images
 
My System SpecsSystem Spec
04 Jan 2012   #7

Windows 7 Ultimate x64
 
 

Thank you dear greenwizard,
I installed Graphic Driver from ATI website. I will try update chipset also.

Pictures of temps is attached.
First picture is when system start. Second picture was taken after 30 minutes.


Attached Images
  
My System SpecsSystem Spec
29 Mar 2012   #8

Windows 7 Ultimate x64
 
 

Hi,

Unfortunately this problem didn't solve yet.
I installed a fresh windows from backup (When the backup was taken, there was any problem). Therefore, the problem is not software.
Also, when problem occurred and the screen was white, I connected laptop to another monitor, and there was any problem in image display of second monitor. Therefore, the problem isn't the graphics card.

Now, how solve the problem? Can any body help me please?

Thanks,
Nima
My System SpecsSystem Spec
29 Mar 2012   #9
Microsoft MVP

Win 7 Ultimate x64
 
 

If it is a hardware problem then there isn't much we can do to help. If that is what it is and there is any warranty left on it, time to contact Dell and see what they have to say.
My System SpecsSystem Spec
29 Mar 2012   #10

Windows 7 Ultimate x64
 
 

Thanks you stormy13 for your kind reply.
Unfortunately its warranty expired.
Can you guess that the problem of what can be? Meaning, maybe a piece of burnt?
My System SpecsSystem Spec
Reply

 Problem with ATI Radeon HD 4300, White Screen




Thread Tools



Similar help and support threads for2: Problem with ATI Radeon HD 4300, White Screen
Thread Forum
ATI Radeon HD 4300/4500 HDMI Detection Graphic Cards
Why am I having white screen? Graphic Cards
ATI Radeon HD 4300/4500 Detection Issues Graphic Cards
Dual Video Card ATI Radeon 4300/4500 Graphic Cards
White Screen.... Browsers & Mail
White screen General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:05 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33