Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Anyone having trouble with the new AMD drivers

29 Dec 2011   #1
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 
Anyone having trouble with the new AMD drivers

I have a Gigabyte 6950 which ran exceptionally well with the 11.11 drivers. After installing the 11.12 drivers I have some problems with the graphics not showing right in places and the screen jerking in certain games. Battlefield 3 when in the helicopter the screen was like showing every 3rd frame. So, I installed the 12.1 drivers and it was worse. I'm considering going back to 11.11. I am just curious if anyone else was having a similar problem. And, yes I used driver sweeper in safe mode before installing new drivers.


My System SpecsSystem Spec
.
29 Dec 2011   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

No problems here with the 12.1 Preview on my 6850. Had the 11.11b on before that and no problems with it either. Can't say about the 11.12 as I never installed them.

Quick question, have you been installing the CAP's as well? If so the old should be uninstalled before installing the new CAP or driver.
My System SpecsSystem Spec
29 Dec 2011   #3
Sardonicus

Windows 7 Home Premium 64 bit
 
 

I had some problems, booted into the Safe Mode, re-booted and they all went away.
My System SpecsSystem Spec
.

29 Dec 2011   #4
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Well, I guess I'll show my ignorance. I don't know what caps are, so I guess I didn't install them, just the catalyst package, the first one listed. I also noticed my card ran about 4 warmer than usual. I ran driver sweeper in safe mode, then ran the ccleaner registry cleaner and uninstalled everything AMD or display.
My System SpecsSystem Spec
29 Dec 2011   #5
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Quote   Quote: Originally Posted by Sardonicus View Post
I had some problems, booted into the Safe Mode, re-booted and they all went away.

Did you do anything when yoy booted into safe mode? I did the same but the issues remain. 99% of the time it is fine, just occasionally, the problems appear, always in games though one old game COD4 and one new, BF3. Even then it is only certain scenes.
My System SpecsSystem Spec
29 Dec 2011   #6
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by essenbe View Post
Quote   Quote: Originally Posted by Sardonicus View Post
I had some problems, booted into the Safe Mode, re-booted and they all went away.

Did you do anything when yoy booted into safe mode? I did the same but the issues remain. 99% of the time it is fine, just occasionally, the problems appear, always in games though one old game COD4 and one new, BF3. Even then it is only certain scenes.
No.
It was a 1080p vs 1080i issue and lag in my video playback and mouse movement.
I booted into the Safe Mode as a last resort. Somehow I lucked out.
I hope you get yours sorted.
My System SpecsSystem Spec
Reply

 Anyone having trouble with the new AMD drivers




Thread Tools




Similar help and support threads
Thread Forum
Having trouble with certain drivers
My laptop is an Asus X55U. Just recently did a fresh installation of Windows 7 Home Premium 64 bit. Installed most drivers, ie. The video, sound, wireless, lan. but there is a couple I couldn't find.
Drivers
Having trouble updating drivers
Hi, I have a custom built desktop PC and I have been trying to find drivers online to see wether I have the up-to-date drivers. So far it has been a nightmare! I have a few questions that I can't seem to figure out the answer to. Any assistance would be greatly appreciated! Here are my PC...
Drivers
Trouble installing ATI drivers
Hi everyone, I'm running Windows 7 Ultimate 64bit, and I'm having trouble installing ATI video drivers. I currently have version 9.9 installed and figured it was time to go to a newer version. I tried installing 10.9, 10.10 and even the latest 10.11 (of course 64bit version). I even tried...
Drivers
Trouble deleting drivers
I have 5 usb drivers for a samsung cell phone that I cant delete, was trying to get pc studio to install not knowning that its nit compatable with 7. HELP Thanks Marshall
Drivers
trouble installing drivers
I'm trying to install a drive so that i can use an FTDI made cable that converts a TTL data port to a RS232 data. But i've run into trouble. when i install it it comes up in my hardware manager as a Com3 which is good but I'm lacking a com1 and an LPT1 which i assume i need. The FTDI guys say i...
Drivers
trouble installing drivers
I recently bought an Nvidia 7200 GS graphics card for my computer, but it is causing problems. I plugged in the card and booted up, and it somehow found a driver for it (maybe on the driver cd I had inserted). I then enjoyed 20 minutes of dual monitors, but then I had to restart the computer. Ever...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App