Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Action Centre advising Driver download but it's already installed

16 Feb 2012   #1
sweetiepie82

Windows 7 Home Premium 64 bit
 
 
Action Centre advising Driver download but it's already installed

Well, as the title really.

After a new build (my first build), I'm getting a whole host of problems. Ran okay for a few days & this is just one problem of many.

I have the action centre enabled in my task bar & it just popped up to tell me that I need to install my video card driver. Not sure what the problem is, my gpu is showing up on Speccy & mypcdrivers so not sure if it just needs ignoring or whether it's *another* issue with this build

Firstly, I'm not overly technical minded, I know a bit & I learn fast but I'm still starting out, so any help is appreciated

I have a feeling that you will see a lot more of me on these forums

TIA


My System SpecsSystem Spec
.
16 Feb 2012   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Have you installed all drivers from the Asus P8Z68-V LX Driver DVD?
and updated from the Asus website?
My System SpecsSystem Spec
16 Feb 2012   #3
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Hi sweetiepie82, welcome to 7F!

It could be that the driver was not signed properly.

Instead of using mypcdrivers you could use the built-in verifier, see: Driver Verifier - Enable and Disable

How did you obtain the driver, have you been to the Asus site to double check?

I see I wasn't fast enough, theog beat me.
My System SpecsSystem Spec
.

16 Feb 2012   #4
sweetiepie82

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by theog View Post
Have you installed all drivers from the Asus P8Z68-V LX Driver DVD?
and updated from the Asus website?
Yes, it was one of the first things I have done

Quote   Quote: Originally Posted by Anak View Post
Hi sweetiepie82, welcome to 7F!

It could be that the driver was not signed properly.

Instead of using mypcdrivers you could use the built-in verifier, see: Driver Verifier - Enable and Disable

How did you obtain the driver, have you been to the Asus site to double check?

I see I wasn't fast enough, theog beat me.
Thank you

I have just enabled the Verifier, I remember having to turn it off to resolve a problem, so thanks for that, will see what happens after a reboot.

The video card driver was directly from AMD's website for the HD 5850.
My System SpecsSystem Spec
16 Feb 2012   #5
sweetiepie82

Windows 7 Home Premium 64 bit
 
 

Still saying the same. I've just had 4 BSOD & removed a stick of RAM I suspected as bad.

Tbh, I'm all over the place now. I just don't know where to start, I fix one problem & it causes 2 others.

It says this:

Quote:
Download and install the driver for your video card

Your video card is missing a driver.
The model name of your video card is Radeon HD 5700 Series.
Then tells me to get the latest driver from their site, which I have, the newest one out.

I seem to be having times where my screen freezes a little & I can't move the mouse for a second (or less). This only happened since I restarted.

Thanks x
My System SpecsSystem Spec
16 Feb 2012   #6
sweetiepie82

Windows 7 Home Premium 64 bit
 
 

Just noticed, it's saying my card is a 5700 series, but it's a 5850?

What could be causing this?

Thanks again
My System SpecsSystem Spec
16 Feb 2012   #7
derekimo

Microsoft Community Contributor Award Recipient

 
 

Quote   Quote: Originally Posted by sweetiepie82 View Post
Still saying the same. I've just had 4 BSOD & removed a stick of RAM I suspected as bad.

Tbh, I'm all over the place now. I just don't know where to start, I fix one problem & it causes 2 others.

It says this:

Quote:
Download and install the driver for your video card

Your video card is missing a driver.
The model name of your video card is Radeon HD 5700 Series.
Then tells me to get the latest driver from their site, which I have, the newest one out.

I seem to be having times where my screen freezes a little & I can't move the mouse for a second (or less). This only happened since I restarted.

Thanks x
Not sure about your other problems but it sounds like Action Center is telling you to update your driver based on a previous problem report.

Problem Reports and Solutions - View History Details

If that is the case and you have already solved that you can remove that problem from the history, #5 here,

Problem Reports and Solutions - Clear History

Since you are getting BSOD's, you should follow these instructions to upload your .dmp files and have the experts help you sort that out first.

http://www.sevenforums.com/crashes-d...tructions.html
My System SpecsSystem Spec
Reply

 Action Centre advising Driver download but it's already installed




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
(Action center) Install your USB control driver but it is installed.
Hi everyone, I keep getting a message (see screenshot) about a control driver but I have the latest and device manager says I have the latest as well . It's a Asmedia control driver , I even downloaded a program called "Hardware Identify " one of Tweaking.coms new programs and it says all...
Drivers
Windows 7 Action Centre
Hi, I have windows 7 ultimate. A message came up on the action centre saying that windows could not find a anti virus??.....I am using kaspersky internet security, and I have had no problem until about 1 hr ago?,now the action says to check online for a anti virus?,why is this happening??..can...
System Security
action centre message
Hi all, I am always getting a message from the Action centre...."Windows security centre is turned off". I turn it on but at next boot, same message. I have "User access control" and "Network access protection" turned off. Is this the reason I am getting this annoying popup and is there any way...
BSOD Help and Support
NIS2009 and Action Centre
http://i49.tinypic.com/28s670j.png As You can see action centre reports it as off why?
System Security
Action Centre Notification help
Could someone please help me? I installed Windows 7 Home Premium x64 yesterday and i have put some software on it since them. I notice that my action centre flag in the system tray (set for show icon and notifications) is now taking between 3-5 mins to load after my anti-virus and network status...
General Discussion
Action Centre Changes
Upcoming Action Center Changes for Security Vendor Software By nwhite on 06 May 2009 We have been working in partnership with our independent software vendor (ISV) community to move the ecosystem to a set of new application programming interfaces (APIs) that many ISVs use to report status...
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App