Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New GTX 560 Ti doesn't display

28 Feb 2012   #1
CommandoBob

Windows 8 Professional x64
 
 
New GTX 560 Ti doesn't display

Whenever I boot up my computer with my new GTX 560 Ti it says no display on my monitor, I've attached the external PCI powerfeed to the GPU and also connected it to my mobo. Everything's running expect my GPU. Using my new Corsair CX600 PSU. Any help please?


My System SpecsSystem Spec
.
28 Feb 2012   #2
CommandoBob

Windows 8 Professional x64
 
 

Update: mouse & keyboard aren't starting either
My System SpecsSystem Spec
28 Feb 2012   #3
CommandoBob

Windows 8 Professional x64
 
 

Hdd neither
Sorry can't edit no mobile
My System SpecsSystem Spec
.

28 Feb 2012   #4
CommandoBob

Windows 8 Professional x64
 
 

Hdd running again
My System SpecsSystem Spec
28 Feb 2012   #5
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I recommend checking all hook ups/connection with your new power supply.
My System SpecsSystem Spec
28 Feb 2012   #6
CommandoBob

Windows 8 Professional x64
 
 

Everything's connected according to me.
My System SpecsSystem Spec
28 Feb 2012   #7
CommandoBob

Windows 8 Professional x64
 
 

Update: attached an external HDD which turned itself off after a
few seconds
My System SpecsSystem Spec
28 Feb 2012   #8
1Bowtie

Windows 7 Home Premium 64 bit
 
 

No signal says the problem is between the monitor and the video card, i'd check the pins to make sure they aren't bent, good conection to monitor and vid card.
My System SpecsSystem Spec
28 Feb 2012   #9
CommandoBob

Windows 8 Professional x64
 
 

I have a VGA monitor attached to a DVI adapter to the GPU. It's connected but doesn't work.
My System SpecsSystem Spec
28 Feb 2012   #10
1Bowtie

Windows 7 Home Premium 64 bit
 
 

One more thing, did you charge your monitor to VGA since you are useing a DVI to VGA adapter.
My System SpecsSystem Spec
Reply

 New GTX 560 Ti doesn't display




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
wmp doesn't display subtitles
I am trying to see a movie (mkv file) with srt subtitles on windows media player - Windows 7 32 bit Home but I cannot. I have searched all the internet and tried different solutions but still no result. I have also installed and uninstalled various codecs and programs. Now I have installed...
Music, Pictures & Video
PC Starts but doesn't display anything
Hello, I'm CrazyKilla By this i mean, i got a new motherboard, MSI X79A-GD45 8D, i plugged in all the fans, water cooling, the 24 or something pin power cable into the motherboard, an 8 pin cable in to the motherboard, the 2 hdds, the 2 gpus, disc reader and plugged in 8gbs of ram. I push the...
Hardware & Devices
Computer doesn't display on monitor?
My computer just stopped working, powers on but no image on the monitor. Basically my computer use to freeze up during gaming then I'd had to hold down the power button and reset the computer. Mobo Audi psq pro Gtx260 I have a backup 6600gt Q6600 4 gigs of ram
Hardware & Devices
My Computer doesn't display my other HDD!
Something's wrong. My Computer doesn't display my other HDD! Device Manager and Computer Manager detects it as Healthy and Active but it's nowhere to be found. PLS HELP I'm freaking out. :cry: I created a system Image before this happened, but IT IS IN the missing hard drive. Can I use system...
Hardware & Devices
Game Doesn't Display Properly
I just downloaded a game (Clue Accusations and Alibis) and it starts perfectly. It has a full screen mode and a windowed mode. The max screen resolution for my computer is 1024x600. The game in either windowed or full screen cuts off vital portions of the game on all sides. I have made sure...
Gaming
Power options page doesn't display a "dim the display"
Hi, I just installed windows 7 on my laptop and the power options page doesn't display a "dim the display" option, nor do the keyboard commands to dim the display do anything. Is there a way to fix this? I am running a Lenovo G530 machine and there does not seem to be driver support for windows...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App