Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sapphire HD 4650 AGP problem

08 Mar 2012   #1

Windows 7 Ultimate 32 bit
 
 
Sapphire HD 4650 AGP problem

Well, i know there a lot of posts about this graphic card but i just tried everything and i cant solve it
I installed windows 7 ultimate (32 bits) and then installed the drivers of my sapphire hd 4650 (agp) from my original CD, when i rebooted the pc was going extremly slow and the screen turned black intermittently.
I tried the hotfix, the same problem, i re-installed windows 7 without the graphic card on the pc, put it and installed the drivers again, and the same.
I tried a non-certificated driver from someone on this forum, and the same
This graphic card was working great on xp and i know there are some people that have made this card work on windows 7
I just dont know what to do, i hope you can help me

My specs:
P4M800 PRO-M7
Intel Pentium D 3.00 ghz
2 GB ram
400 gb hard disk
btw, sorry for the bad english

My System SpecsSystem Spec
.

08 Mar 2012   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

jpmena6, welcome to the Seven Forums.

The problem isn't the card or the driver for it, the problem is the chipset on the motherboard and an either unsupported or not functioning properly AGP driver, which is part of the chipset and required for the video card driver to install and work properly. Windows 7 comes with a generic AGP driver that unfortunately doesn't work with some chipsets. That said go here,

VIA Drivers Download - VIA Technologies, Inc.

and get the Vista 32 bit Hyperion Pro chipset drivers and install them, then try the video card driver again. It shouldn't but it may take using Compatibility Mode to get the chipset driver to install.
My System SpecsSystem Spec
08 Mar 2012   #3

Windows 7 Ultimate 32 bit
 
 

ok thanks but i have some questions
before installing those AGP drivers should i unistall all the ati drivers i had installed for the graphic card?
when i download the 4 in 1 package and i start the setup, it says that only 2 things will be installed: VIA Chipset inf update and the VIA PATA/SATA IDE drivers, doesn't say nothing about an AGP driver. Is it included in the inf update or is it not normal what appears? Becasue there is a folder where it says viaagp and it have some inf files on it. Should i install those drivers mannually some way or with the setup its ok?
Again, really thank you
My System SpecsSystem Spec
.


08 Mar 2012   #4
Microsoft MVP

Win 7 Ultimate x64
 
 

It should be part of the INF update, but not sure; never had a Via based board. And yes you can try installing just the AGP driver manually,

Driver Install - Device Manager

Also yes, uninstall the ATI driver first.
My System SpecsSystem Spec
08 Mar 2012   #5

Windows 7 Ultimate 32 bit
 
 

I just tried that and it keeps exactly the same problem, do you think it might be possible that my mainboard agp drivers simply dont support windows 7? In XP the graphic card worked perfectly and when i bought my pc it brought windows vista so i think that would be weird. But it keeps exactly the same problem.
The package I downloaded was the last hyperion 4 in 1 package for windows vista 32 bits. It didn't work, so i tried with the package just before the last one and there are no advances...
I dont know what else to try....
My System SpecsSystem Spec
09 Mar 2012   #6

WIN7 Ultimate 64bit
 
 

Wipe your drive and reload Win 7

Let Win 7 download all the drivers it needs from the internet > updates

Where the white flag is on taskbar for Action centre>update windows

Do NOT use your old CD drivers under any circumstances (exception is SATA/SCSI drivers)

If you are missing any via chipset drivers go to via for latest 32bit win 7 updates

Download 32bit Win 7 12.1 "Hotfix AGP" driver from AMD site

After install it probably wont install the driver
GoTo
>'puta management
> display adapters
> right click on ATi 4xxx adapter > update driver software
> "Browse my computer"
> point search to C: drive > AMD folder and let it search/install correct driver

reboot

Now run the Windows indexing for your computer
White flag >Action centre > view performance information > run the W.E.Indexing

Now Look on microsoft website for latest "Direct X" updates esp 9.0c even if your card supports 10.? and download/install
https://www.microsoft.com/download/e...ils.aspx?id=35

Should keep you busy this weekend

Sorry cant help much further cos all my Socket A boards use Nvidia chipset not via
My System SpecsSystem Spec
10 Mar 2012   #7

Windows 7 Ultimate 32 bit
 
 

thanks but that doesn't work either... exactly the same problem. Maybe it can be something with the bios, updating the bios can be an option? Or changing some value?
My System SpecsSystem Spec
10 Mar 2012   #8

vista home premium 32 bit
 
 

try this, worked for me on a couple of ATIs, go to administrative tools, and services and turn on smart card adapter on auto, and start the service, reboot and install hotfix drivers, seems the pci to agp adapter needs this service to see it on some mo bords, give it a try.
My System SpecsSystem Spec
11 Mar 2012   #9

Windows 7 Ultimate 32 bit
 
 

thanks, but didn't work either.
I think i'll have no choice but to go back to windows xp, may i need a bios update or can be something with the psu? this ati with xp worked perfectly
My System SpecsSystem Spec
Reply

 Sapphire HD 4650 AGP problem




Thread Tools



Similar help and support threads for2: Sapphire HD 4650 AGP problem
Thread Forum
Gigabyte Radeon HD 4650 AGP Problem Graphic Cards
Sapphire HD 4650 AGP driver problem Graphic Cards
Sapphire HD5770 problem. Graphic Cards
ATI Radeon HD 4650 Windows 7 Problem Graphic Cards
Sapphire Wonder TV USB problem!! Software
sapphire AGP 4650 aero glitches and slow games Graphic Cards
ATI HD 4650 problem Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:56 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33