Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: After installing new Radeon GPU and drivers, Windows stuck at starting

29 Mar 2012   #1

Windows 7 Professional 64bit
 
 
After installing new Radeon GPU and drivers, Windows stuck at starting

I just received my new ASUS HD7850-DC-2GD5 video card. I installed it, booted up Windows, and installed the drivers from the included CD. Then I rebooted Windows. However, my system hangs at the 'Starting Windows' screen. Actually, it seems that only the video hangs--because if I type in my password and hit enter, as if I could see the welcome screen, I hear the 'correct' sound that normally plays when I log in. I just can't *see* what's going on.

I reset the system and booted into safe mode, where I entered Device Manager and uninstalled the HD7850 display adapter. Then I rebooted Windows, and again I'm able to operate normally -- but without the AMD Radeon drivers. I've tried downloading the latest drivers from the AMD website, but installing those leads to the same problem. I get stuck at the 'Starting Windows' screen.

This has me totally perplexed... I bought an ASUS-branded card specifically to try and avoid drama, as I also have an ASUS mobo (the P8Z68-VPRO/GEN3). My CPU is an i7 2700k, not currently overclocked at all. My PSU is an XFX PRO850W XXX Edition Semi-Modular 88Plus 850 Watt PSU, which should be up to the task, right?

Anyone have any clue why this is happening?

My System SpecsSystem Spec
.

29 Mar 2012   #2

Windows 7 Home Premium 64bit sp1
 
 

go to amd.com get the drivers from there the disc drivers offers alot of issues which you will see the 12.3 will fix all that
My System SpecsSystem Spec
29 Mar 2012   #3

Windows 7 Professional 64bit
 
 

Quote   Quote: Originally Posted by Solarstarshines View Post
go to amd.com get the drivers from there the disc drivers offers alot of issues which you will see the 12.3 will fix all that
Hi, thanks for replying. I've already tried the latest drivers, but have the same problem.
My System SpecsSystem Spec
.


30 Mar 2012   #4

Windows 7 Ultimate x64
 
 

If you have updated drivers and still the problem exists, then perform the following tasks::

Install and run antispyware software
Free up wasted space with Disk Cleanup tool
Defragment your hard disk drive


Click Start - Run, type in %temp% and then click OK.

Once that temp folder is open and you can view its contents, select and delete EVERYTHING that's inside it.

It's all junk and is a good place for "nasties" to hide.

If a few files resist being deleted, that's normal. Leave them alone and delete EVERYTHING else.

Repeat the steps with c:\windows\temp

After you're done with both temp folders, restart the computer.
My System SpecsSystem Spec
30 Mar 2012   #5

Windows 7 Professional 64bit
 
 

OK, I tried these tasks. Still no change. I'm back in safe mode atm so I can disable the Radeon drivers again.
My System SpecsSystem Spec
30 Mar 2012   #6

Windows 7 Professional 64bit
 
 

Does anyone know a way I can test the video card itself? I don't have a second desktop to swap it into, unfortunately.
My System SpecsSystem Spec
30 Mar 2012   #7

Windows 7 Home Premium 64bit sp1
 
 

i would RMA or Exchange for a new one and see if that was the reason won't be the first time a bad card has ben sold out of the box

Might just be a debunked card
My System SpecsSystem Spec
30 Mar 2012   #8

Windows 7 Professional 64bit
 
 

Well, I'm getting video output from the card as long as I don't enable the Radeon drivers. My monitors are plugged into the video card, not the onboard graphics. And the fans are spinning. Does that count for something? I'd rather avoid the hassle and expense of sending this thing back if there are other troubleshooting steps to take first.
My System SpecsSystem Spec
30 Mar 2012   #9

Windows 7 Professional 64bit
 
 

Alright I'm sending it back. $13 and another week wasted... if the replacement doesn't work, I'm going with NVidia :P
My System SpecsSystem Spec
30 Mar 2012   #10

Windows 7 Home Premium 64bit sp1
 
 

Reason i said this ih ave the same issue with a diamond hd 6870 it would run but when it came to use-ing the drivers it failed too man times to count you might have this issue


Timeout Detection and Recovery of GPUs through WDDM

which in my case none of the fixes worked had to RMA my card and Diamond themselves said my card was shot just right at the 2 year mark warrenty kicked in and i was saved
My System SpecsSystem Spec
Reply

 After installing new Radeon GPU and drivers, Windows stuck at starting





Thread Tools



Similar help and support threads for2: After installing new Radeon GPU and drivers, Windows stuck at starting
Thread Forum
Stuck on Starting Windows screen General Discussion
Solved Stuck on Classic theme after installing NVIDIA drivers Themes and Styles
Solved Issue Installing Win 7 Ult x64 on New PC; Stuck @ "Starting Windows" Installation & Setup
Solved Error installing drivers for ATI Mobility Radeon HD 4650 Drivers
stuck at windows is starting Installation & Setup
Stuck on starting windows screen Graphic Cards
Windows 7 stuck on "starting windows" after drivers Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:44 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33