Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Sapphire x1550 problem

17 Apr 2012   #1

windows 7 home premium 32 bit
 
 
Sapphire x1550 problem

Hello everyone, I have a problem that is driving me crazy.

My computer is as follows:
Motherboard Asus P4S8X-x
Intel CPU 2800 Ghz
2 Gb Ram
Video Card Sapphire Radeon X1550 512 MB AGP

It 'a bit' old-fashioned but so far it has always done his duty.

I installed Windows 7 Ultimate 32 for about 2 years without any problems: Windows has tried the drivers and everything worked perfectly with Aero enabled.
Last week I've noticed that I no longer have any hardware acceleration and Aero, Windows uses the driver VgaSafe giving me Error 43 in Device Manager "the device has been discontinued because it has a problem"
I decided to format but after installation I have the same problem.
I tried to manually install the driver Legacy 10.2 (the latest for my video card) without solving.
Since I was in the process of formatting I tried to install Windows XP and the card works, then I realized that is not broken. I reformatted installing Windows 7 Home Premium 32 but still have the same problem.
I think that 2 years ago, Windows has installed the right drivers but now goes to get the drivers that are not good for my video card. What can I do? I do not know where to turn!
I hope someone can help me out. greetings

My System SpecsSystem Spec
.

17 Apr 2012   #2

Windows 7 Home Premium x64
 
 

Have you tried running the driver in compatibility mode?

1. Place the driver installation file on the Desktop.

2. Right Click the driver installation file and select Properties/Compatibility Tab. Select the appropriate options from the list(Usually the last OS that the driver was supported on, in your case, you know it worked in XP).

3. Click Apply/OK.

4. Right Click the file and select the Run As Administrator option to install.
My System SpecsSystem Spec
19 Apr 2012   #3

windows 7 home premium 32 bit
 
 

Ok, it works and install the driver, now I have anymore the error 43, but when I try to install the Vista driver I have the same problem.
With XP driver I haven't Aero activated because this driver isn't WDDM.
My System SpecsSystem Spec
.


19 Apr 2012   #4

Windows 7 Home Premium x64
 
 

Yes, and you'll probably have problems with some DirectX items as well. The only choice you have is to upgrade your Video Card to something a little newer. Any of these should get you there. Newegg.com - Computer Hardware, Video Cards & Video Devices, Desktop Graphics Cards, AGP 4X/8X, DirectX 10.1
My System SpecsSystem Spec
20 Apr 2012   #5

windows 7 home premium 32 bit
 
 

But why for 2 years and until a week ago all was ok, Aero and games, and now after a format and a new install I can't use my video card?
This is what I don't understand.
My System SpecsSystem Spec
20 Apr 2012   #6

Windows 7 Home Premium x64
 
 

Do you remember which driver version you were previously using? Do you have all of the correct drivers for your card? ATI Catalyst
My System SpecsSystem Spec
20 Apr 2012   #7

 
 

What exactly happened when you tried to install the 10.2 drivers for your card?

Did the installation fail? Did you receive some sort of error code?
My System SpecsSystem Spec
21 Apr 2012   #8

windows 7 home premium 32 bit
 
 

No I don't remeber which driver I previously use and yes I have downloaded the driver from Ati site and Sapphire site.
When I install the 10.2 drivers, the installation don't fail and I have any error, but when I restart the pc I have Vgasafe driver and a yellow mark on the video card in Device Manager (error 43 the device has a problem).
My System SpecsSystem Spec
21 Apr 2012   #9

Win 7
 
 

Try using the 8.10 driver> ATI Catalyst
My System SpecsSystem Spec
21 Apr 2012   #10

Windows 7 Home Premium x64
 
 

That you are still getting this error, it is likely that your gpu is dead. There are a few things you can try. Remove the gpu and thoroughly clean it with a can of compressed air. Before reinstalling the gpu clean out the slot with the compressed air also.
My System SpecsSystem Spec
Reply

 Sapphire x1550 problem





Thread Tools



Similar help and support threads for2: Sapphire x1550 problem
Thread Forum
Sapphire HD 4650 AGP problem Graphic Cards
Sapphire HD5770 problem. Graphic Cards
sapphire 5450 hd problem Graphic Cards
Sapphire Wonder TV USB problem!! Software
Sapphire HD3650 64-bit problem Graphic Cards
sapphire 4670 problem Graphic Cards
ATI X1550 OpenGL Problem Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:27 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33