Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New monitor and graphics card, POST screen not displaying during boot

05 Jun 2012   #1
Rhirtix

Windows 7 x64
 
 
New monitor and graphics card, POST screen not displaying during boot

Hi All,

So, I upgraded from an Apple 20" HD Cinema display with an EVGA GTX 470 SC graphics card to a 27" Apple LED Cinema display with an EVGA GTX 680 SC graphics card.

My issue is that with the previous setup, I'd see the POST information during boot before the Windows 7 splash screen prior to desktop loading. With the new configuration, the screen remains black until it hits the Windows 7 splash screen.

The new display turns on automatically via its connection to the computer. It has no on/off button, unlike the 20" Apple Cinema display.

Also, with connections, the 20" used a direct DVI connection. The 27" display has a Mini DisplayPort connector, which is plugged into an MDP to DVI adapter, which is then plugged into my graphics card.

Any ideas?

Thanks!


My System SpecsSystem Spec
.
06 Jun 2012   #2
Rhirtix

Windows 7 x64
 
 

Wow. 250 views and no ideas? Anyone?
My System SpecsSystem Spec
06 Jun 2012   #3
paulpicks21

Windows 7 Professional 64 bit
 
 

I am pretty sure its down to the connection type.

I had a similar issue a couple of years back with a screen I was using, it would show all the post info if it was connected by dvi but with hdmi the screen would not work until windows loaded. (I know this is different to yours)

Are there any other ways you can connect it other than the way you have already described?
My System SpecsSystem Spec
.

06 Jun 2012   #4
Rhirtix

Windows 7 x64
 
 

Thx for the reply.

I purchased a mini displayport to displayport adapter. I hoping this will resolve the issue. UPS hasn't yet delivered it.
My System SpecsSystem Spec
06 Jun 2012   #5
Rhirtix

Windows 7 x64
 
 

Solved.

The DisplayPort male to Mini DisplayPort female adapter solved it.

6in DisplayPort® to Mini DisplayPort Video Cable Adapter - M/F | StarTech.com
My System SpecsSystem Spec
06 Jun 2012   #6
paulpicks21

Windows 7 Professional 64 bit
 
 

Great, glad you got it sorted.
My System SpecsSystem Spec
Reply

 New monitor and graphics card, POST screen not displaying during boot




Thread Tools




Similar help and support threads
Thread Forum
Can I upgrade my monitor with the graphics card I have?
Due to a shoulder injury I need to type and edit photos standing up. I thought I'd upgrade to a large high resolution monitor but wonder if my present system could handle it. The 19" monitor I'm using has a 1440 x 900 native resolution but I want a bigger monitor, maybe 30"and the resolutions are...
Graphic Cards
Monitor & Graphics Card Issue
Hello! I've been having a whole bunch of problems with my AMD Radeon HD 6670 graphics card and my Dell monitor which I don't know the model of. To start off my PC started to overheat and shut down every so often so I opened it up and cleaned everything out, to my surprise it actually worked. While...
Graphic Cards
Graphics card and monitor resolution ?
Hi I have a Nvidia GTX 580 GPU I have just bought a Dell UltraSharp U2713HM - running a resolution at 2560*1440.I know it's not a gaming screen, but I still manage to run games pretty well. But I'm thinking. If I get a better GPU will that make the games run even better at 2560*1440 ? ...
Hardware & Devices
Windows 7 logo stuck at boot loading screen graphics card SLI ?
Hi guys. iv just encountered a weird problem with my graphics card. im currently running 2x 9800GT in sli mode. now the issue im getting is when i boot my computer and when the windows 7 logo appears, it will load for abit then freeze or go black screen. now funny thing is my actually...
Graphic Cards
Why is my graphics card only displaying 742 MB
Hello, I have a ATI Radeon HD 5770 Graphics Card and have noticed in both the dxdiag utility and on systemrequirementslab.com that I have 742 MB graphics. I know I have a 1 GB graphics card and GPU-Z also shows that I have 1024 MB video memory available. I have attached a screenshot below....
Graphic Cards
Dual Monitor Graphics Card
Hey all, I've got a bunch of HP Compaq dc5800 and dc6000 small form factors in the office I do IT support for. A couple of the employees have requested the use of multiple monitors, but I quickly discovered that the standard video card in these models does no support this function. I have looked...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App