Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Resolution not set properly, unable to play games


04 Jul 2012   #1
JaidynM

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04
 
 
Resolution not set properly, unable to play games

I recently had a problem with my games (found in the thread here) that involved the games lagging badly. It turned out to be an image settings preference that I hadn't set properly. In my attempt to fix the problem however I did a clean install of drivers and updated to v301.42.

Since I installed the new driver none of my games would start (NBA 2K12, Assassin's Creed, Skyrim etc.) and simply go to a black windowed screen. Skyrim tells me that 'Your display doesn't support the selected resolution'. However, I am using the native resolution (1680x1050) for my monitor.

Has anyone got any ideas as to why this might be happening and/or how I could go about fixing it?


My System SpecsSystem Spec
04 Jul 2012   #2
solarmystic

Windows 7 x64 Professional SP1
 
 

Hello once again JaidynM,

Can you try lowering the resolution of your monitor to non-native temporarily to test out a hypothesis i have?

Try setting the resolution to 1280x800 or 1280x720 (next 16:10/16:9 resolution on your list i presume), and running the affected games again?

Also for Skyrim, If you do not have any custom Skyrim.ini or custom SkyrimPrefs.ini files (ones you've modified personally, line by line and do not wish to delete), could you try to back them up and then delete them from your Documents/My Games/Skyrim folder to allow the game to generate fresh ones for your newly minted drivers?

After doing so, run the launcher again, let the game auto-detect your hardware and and run the game again..

Give it a shot and holler back...

EDIT:- How about other 3D based software like benchmarks (Unigine Heaven) or Furmark? Do they run with the same errors?

http://www.ozone3d.net/benchmarks/fur/

http://unigine.com/products/heaven/

Also with Skyrim, try running it in windowed mode as an experiment?
My System SpecsSystem Spec
04 Jul 2012   #3
JaidynM

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04
 
 

The problem still occurs with the resolution changed.

Deleting the .ini file does not work either.

Windowed mode (settings the mode to Minimized) does not work.

I'm installing Furmark, will post back when I'm done.

EDIT: Furmark doesn't say anything.
My System SpecsSystem Spec
04 Jul 2012   #4
solarmystic

Windows 7 x64 Professional SP1
 
 

Okay.. let's try another method...

You say that the problems occur after installing the new drivers (301.42 WHQL), what was the previous version of drivers on your system that worked? (If you can remember them?)

You also mentioned performing a clean install. Did your clean install involve using Driver Sweeper in safe mode in between the driver installs?

Would you be willing to install the latest betas for your GTX 560 from Guru3D to ascertain whether or not the problem is driver specific? (The newest betas include improvements for your GTX 560 in particular so your games performance may increase and have good comments from those who've tested them on the Guru3D forums)

GeForce 304.79 Beta 64-bit download from Guru3D.com

(Guru3D is a legitimate site for 3D related applications and drivers, don't worry)
My System SpecsSystem Spec
04 Jul 2012   #5
JaidynM

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04
 
 

I tried using Driver Sweeper but the Guru 3D version is no longer available and the Phyxion version crashes.

And sure, I'll install the beta drivers and have another shot.
My System SpecsSystem Spec
04 Jul 2012   #6
solarmystic

Windows 7 x64 Professional SP1
 
 

The latest version of Driver Sweeper (3.20) crashes? That's odd...

I await the results of your new driver installation...
My System SpecsSystem Spec
04 Jul 2012   #7
JaidynM

Windows 7 Ultimate x64/Windows 8 Consumer Preview x64/Ubuntu 11.04
 
 

The beta driver works! All games are working fine now.

Thanks again for your help, I don't know what I'd do without you.
My System SpecsSystem Spec
04 Jul 2012   #8
solarmystic

Windows 7 x64 Professional SP1
 
 

I'm glad it was just a simple driver malfunction JaidynM! Enjoy your games mate!
My System SpecsSystem Spec
Reply

 Resolution not set properly, unable to play games




Thread Tools



Similar help and support threads for2: Resolution not set properly, unable to play games
Thread Forum
Resolution stopped working properly Graphic Cards
Games Explorer - Last Play Time of Games - Enable or Disable Tutorials
Unable to play my old dos games on new laptop? General Discussion
certain videos do not play properly Music, Pictures & Video
Midis sometimes don't play properly Sound & Audio
unable to play numerous online flash games Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:30 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App