Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Monitor has no signal when plugged in to graphic card slot(dvi)

10 Jul 2012   #11
solarmystic

Windows 7 x64 Professional SP1
 
 

The monitor supports DVI cables?

In that case before you do anything drastic and buy another monitor, buy some new DVI cables and try to use them with the 6670 graphics card and see whether it works. Also, try buying another VGA --> DVI adapter and testing that out too.

It is a lot cheaper to buy new DVI cables then to consider a new monitor/graphics card replacement.

We can continue this session later after you've tried out the new DVI cables/adapter.


My System SpecsSystem Spec
.
10 Jul 2012   #12
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

Are you using just one monitor? Are you connecting the monitor to the mobo connection slot or the GPU connection slot?
My System SpecsSystem Spec
10 Jul 2012   #13
solarmystic

Windows 7 x64 Professional SP1
 
 

Quote   Quote: Originally Posted by bassfisher6522 View Post
Are you using just one monitor? Are you connecting the monitor to the mobo connection slot or the GPU connection slot?
He mentioned that his monitor (single setup) works just fine with his onboard card, but doesn't show an input signal when plugged into his new AMD 6670 using a VGA cable via a DVI to VGA adapter..

He's going to try using/purchasing a DVI cable as the next step in the troubleshooting process, as the monitor supports both DVI and VGA cables, but he only has a VGA cable right now, which is why the adapter was used in the 1st place with the card...
My System SpecsSystem Spec
.

10 Jul 2012   #14
antonice22

windows 7 64 bit
 
 

So my monitor is HP w1907 Wide LCD Monitor. Im really concerned that i need to plug both dvi slots in my monitor to my graphic card.. is that true? what do you think?
My System SpecsSystem Spec
10 Jul 2012   #15
solarmystic

Windows 7 x64 Professional SP1
 
 

Sorry for the late response.

After checking out your monitor's specs from the HP website:-

Product Specifications HP w1907 19 inch LCD Monitor - HP Customer Care (United States - English)

It seems like the next step for you is to get just one of those DVI-D cables and try plugging one end to your 6670 graphics card and one end to the monitor for further testing.

Something like this:-

For only $5.19 each when QTY 50+ purchased - 6ft 28AWG CL2 Dual Link DVI-D Cable - Black | 28AWG DVI-D Cables
My System SpecsSystem Spec
12 Jul 2012   #16
antonice22

windows 7 64 bit
 
 

Yes! thats what i exactly did and it worked. thank you very much!
My System SpecsSystem Spec
12 Jul 2012   #17
solarmystic

Windows 7 x64 Professional SP1
 
 

You're most welcome, thanks for reporting back that it worked!
My System SpecsSystem Spec
Reply

 Monitor has no signal when plugged in to graphic card slot(dvi)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Graphics Card spinning but no signal to the monitor
Earlier today I replaced my RAM and GCU, everything was working fine before I tried installing these new things. Like I said the Graphics Card fans spin but there is no signal, idk what to do? no DGI
Graphic Cards
DVI No Signal with graphics card plugged in (on board work)
Hello all! I turned on my computer today and everything loaded normally. I opened up google chrome, and the screen froze for a second and the dvi went offline (computer kept running). I turned the computer back on and the dvi kept going to no signal. I took out the graphics card and I am currently...
Graphic Cards
New GFX Card w/ DVI-I - VGA Adapter -> No Monitor Signal
I honestly have no clue what to do, I been googling forever and none of them seem to be for me, so I decided to post here. Ok so I bought a new GFX Card : EVGA GTX 560 Amazon.com: EVGA GeForce GTX 560 1024 MB GDDR5 PCI Express 2.0 2DVI/Mini-HDMI SLI Ready Graphics Card, 01G-P3-1460-KR:...
Graphic Cards
Installed graphics card, monitor error (check signal cable)?
I just installed my ATI Radeon X1950 XT sapphire graphics card to my computer. I inserted it into the slot and plugged it in. Now when I turn on my computer the monitor keeps getting the Check Signal Cable error. I have it plugged in properly and everything not sure what is going on. My computer...
Graphic Cards
Dual monitor graphic card suggestions
Currently have FireGL V3350 which there are no ATI-provided W7 drivers. It does seem to work OK though with the automatically installed drivers. Thinking to upgrade to something a bit more up to date, what would the team suggest? This is for basic office/development work with 2 19" viewsonics...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App