Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Monitor receives no signal after a while of functioning

23 Aug 2012   #1

Winows 7 64 bit
Windows 7 Monitor receives no signal after a while of functioning

Hi all.

I encountered a new issue with my PC and I sincerely don't know what to do. In fact, after a while, the monitor is showing no signal. I changed the video card with a brand new one and still my PC will do the same. Is there a worm or software issue or the motherboard miss-fires?

Thanks a lot!

My System SpecsSystem Spec

23 Aug 2012   #2
Chalky Emultion



first, check if the monitor works with other PCs.
My System SpecsSystem Spec
23 Aug 2012   #3

Winows 7 64 bit

sorry, i should have pointed the following actions:
- i changed the cooler paste from the processor
- i added a new fan
- i cleaned and dusted everything
- i tested the monitor on another computer
- i changed the video card (upgrade it)

So i really don't know what to do next. I just want to know if this can be a software issue as well as a hardware one. I suppose that I'll change the power supply and/or the motherboard, but after being sure that it isn't a software /worm/malware issue.

My System SpecsSystem Spec

23 Aug 2012   #4
Chalky Emultion


if the monitor doesn't display nothing after doing what you did, 90% is an hardware problem.

If you have it, try using your integrated graphics card without any other graphics device in PCI/AGP/PCIe slot.
My System SpecsSystem Spec

 Windows 7 Monitor receives no signal after a while of functioning

Thread Tools

Similar help and support threads
Thread Forum
no signal to monitor until windows welcome screen
Hi guys, New to the forum and am really hoping you guys can help me out. Just put an HTPC together with this motherboard ASUS F2A85-M PRO Micro ATX My problem is that if I connect the computer via DVI to a display it functions normally, but when I hook it up via HDMI to my Flat screen, it...
Graphic Cards
ERROR_CODE: (NTSTATUS) 0xc0000094 - Screen no longer receives signal
Hello! I got a reoccurring problem. Every now and then i get a black screen and the signal is cut off. I restart my machine and all works fine. I tried to learn from here abit of what to do but it's way over my head. I got the crash dump here, ill upload it here 101812-15631-01.dmp - Speedy...
BSOD Help and Support
Monitor Loses Signal When Windows Boots Up
When I start my computer with drivers installed my monitor loses the signal when I should be receiving a log in screen. I can boot up fine in safemode and/or if I'm using Standard VGA Graphics Adapter. To my knowledge I do not have an onboard graphics card as there is nothing to plug an avi or vga...
Graphic Cards
Projector and TV receives VGA-signal but doesn't realize it
Hey I'm having the above mentioned problem with my fatherís laptop. He's a teacher so we bought the laptop so he could show powerpoint-presentations on projector, but the laptop doesn't work with all projectors. :-( The output is received by the external screen/projector but the projector...
Graphic Cards
Windows 7 Home Premium No signal to Monitor after Hibernation
Kind of a strange random problem I got here. I woke up the other day and tried to turn my computer on after it had been hibernating for the night, to my shock the monitor wasnt getting a signal of any kind. So i messed with the cords, tried a few restarts, turn the monitor on and off. Nothing...
General Discussion
Monitor receives no signal all of the sudden
Even though I have been missing for ages, I hope that my fellow seven forum friends could help me out here :o Have been successfully using my graphics card for months with one little quirk. Whenever I shut down my computer and restart, in order for the monitor to detect a signal, I would have...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:28.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App