Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No video playback only audio (black screen)

16 Sep 2012   #11
Hikeman

Windows 7 SP1 Ultimate x64
 
 

Just tried the SFC /SCANNOW to, but didn't resolve the problem .
Thanks anyway )


My System SpecsSystem Spec
.
13 Oct 2012   #12
Hikeman

Windows 7 SP1 Ultimate x64
 
 

Hey guys. I just reinstalled my OS (clean install ) and guess what ? I still have the problem with the video playback !! I even installed the last version of AMD video driver 12.8, no help.
The thing is that, when there is no video driver is installed I have the playback on all video players !!! sa soon as I install the AMD driver i am loosing my video playback !
what should I do??
pleas help
My System SpecsSystem Spec
14 Oct 2012   #13
razy60

windows 7 64 bit and dual boot Pinguyos
 
 

go back to the original install and dont use the latest amd driver.
or
uninstall the 12.8 driver and find an older version that works, list of downloadable old drivers:
Downloads | techPowerUp
or
I am assuming you have used the sony site to get the original driver package if not here is the link.
Sony eSupport - Electronics - Select Your Model
Find and install the correct drivers then update if necessary.
My System SpecsSystem Spec
.

16 Oct 2012   #14
Hikeman

Windows 7 SP1 Ultimate x64
 
 

Thanks a lot fro response razy60.
As soon as I uninstall the driver I have now installed, it is asking me to reboot the system, after restart i will automatically install AMD driver from Microsoft (which doesn't include OpenGL adn I can not run certain games! but oddly the video playback will work with all video players!). And if I try to install the older version of AMD driver over the Microsfot provided one, it will "refuse" to install ! and by "refuse" I mean in the Custom option of AMD installer it wan't show up the "Display driver", it shows only AMD Control Center and some other soft from AMD installer.
Can you pleas tell me what could I do now?
Thank you very much again
My System SpecsSystem Spec
18 Oct 2012   #15
razy60

windows 7 64 bit and dual boot Pinguyos
 
 

If you have the older driver remember where it is saved then uninstalll the current driver, when it asks you to restart, restart then before the system restarts press the relevent F key(f8 or 12 maybe) so that you can restart in safemode then install the driver you want, you may have to try it a few times until you find one that works. Also try a driver cleaner there is one on this forum that has been recommended but I can't remember It's name at the moment.
My System SpecsSystem Spec
Reply

 No video playback only audio (black screen)




Thread Tools




Similar help and support threads
Thread Forum
Black screen while video playback on any player, but VLC (audio works)
Hey guys. I discovered that besides VLC player on my laptop all the other video player are not able to work properly (meaning,, Windows Media Player 12, Cyberlink PowerDVD12 and WMPC are able to play only the audio, but not the video, it's just just black screen),, BUT with VLC is no problem...
Drivers
WMC plays TV audio, but no video display (black screen)
Hello, I hope this is not a repeat question as I have checked and searched the forum thoroughly. I have a problem playing live TV using Windows Media Player. I can select different TV channels without a problem. I can hear the audio clearly. However, i can not watch anything as it displays a...
Media Center
No video playback only audio (only black screen)
Hey guys,, I have a little problem,, hope I can get my answer here. Hey guys. I recently desc covered that besides VLC on my laptop all the other video player are not able to work properly (meaning,, Windows Media Player 12, Cyberlink PowerDVD12 and WMPC are able to play only the audio, but not...
Music, Pictures & Video
Audio and video playback choppy
I have a Dell Inspiron 1545 laptop with windows 7 home premium 64 bit installed. The problem is that whenever I play a video through a browser or from the hard drive, the audio and video will stutter for a second or two every 30 seconds. I've updated windows, installed a codec pack, installed...
Music, Pictures & Video
video playback and audio optimization
lve noticed that allot of my resource issues seem to relate to audiodg.exe process and playback of video.. l tend to see pretty much constant cpu access when running winamp etc tho l have gotten it down from what it was by disabling effects and changing the sound quality to DVD quality l still...
Music, Pictures & Video
Choppy Audio/Video Playback
I have been struggling with choppy audio/video playback through WMP on Win7 for some time and, to save a lot of time, have narrowed it down to this: I cannot have Flash Player or AnyDVD installed if clarity in playback is to be achieved. With either program installed the audio/video will buzz...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App