Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit

16 Sep 2012   #1
charpotro

Windows 7 Ultimate 32bit
 
 
Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit

I have recently repaired my motherboard (Intel D945GCNL). After a formatting of my HDD, I installed windows 7 ultimate 32 bit and all my drivers. Downloaded 12-8_vista_win7_win8_32_dd_ccc and installed it. The problem is at startup, it shows the windows 7 logo as starting windows and then the display vanishes as if there is no input. I can access the display when in safe mode or when I uninstall the driver. Then it loads normally and shows generic driver and I cannot utilize my graphics card. The card does not seem to be faulty and relatively newly purchased.

Need your help, am not that tech savvy and at a loss. What should I try to fix?


My System SpecsSystem Spec
.

16 Sep 2012   #2
oxymoron02

Windows 7 Ultimate 64-bit
 
 

The output resolution is set to something your monitor cannot support. If you have another monitor, or a TV with a PC input, you could use this to reset the resolution to something more friendly, like 800 x 600 (generally universally supported).
My System SpecsSystem Spec
16 Sep 2012   #3
oxymoron02

Windows 7 Ultimate 64-bit
 
 

Oh, although safe mode won't load the AMD drivers to run the graphics card, you might be able to run the program itself. Navigate to its installation location and run it, then see if you can change the resolution that way. When you reboot, hopefully Catalyst will have remembered the resolution you set it to, and apply this resolution (again, I recommend 800 x 600).
My System SpecsSystem Spec
.


16 Sep 2012   #4
charpotro

Windows 7 Ultimate 32bit
 
 

thanks for the suggestion. Problem is I do not have a spare monitor to work on. But am logging on to safe mode to try to run the program. Let's see how that turns out.
My System SpecsSystem Spec
16 Sep 2012   #5
oxymoron02

Windows 7 Ultimate 64-bit
 
 

Also in safe mode before did you change the resolution up or down? You'll want to change it down. What make and model is your monitor? It'll be written on the back.
My System SpecsSystem Spec
16 Sep 2012   #6
charpotro

Windows 7 Ultimate 32bit
 
 

I could not change through CCC in safe mode, it could not load the device; probably because of the safe mode cause it is showing my device in the device manager. Set the resolution to 800X600 but did not help. My monitor is Samsung Syncmaster 794MG (CRT). Any suggestion??
My System SpecsSystem Spec
16 Sep 2012   #7
oxymoron02

Windows 7 Ultimate 64-bit
 
 

Your monitor can support 1280 x 1024 which means it is a 4:3 ratio, so 800 x 600 should have been fine. Clearly the problem is more deeply rooted. If you change the settings and then reboot into safe mode a second time, does Catalyst stay on the resolution you changed it to?


The only other thing we can try is an older version of Catalyst. Try to find 12.4 online, but of course be wary of where you download from. If at all in doubt, post any links you find here, and I will check them out (and get a virus lol ).
My System SpecsSystem Spec
16 Sep 2012   #8
latecomer

win7 home premium 32bit OEM System Builder Pack
 
 

try uninstalling the 12.8 driver for graphic card. i had issues with it. im using the 12.6 driver and works great now.
My System SpecsSystem Spec
16 Sep 2012   #9
charpotro

Windows 7 Ultimate 32bit
 
 

Catalyst does not run as I could not reboot in the normal mode after the software installation and safe mode also does not load catalyst. The screen resolution stays the same once i change it and reboot. downloading 12.4 from cnet, do i require to uninstall the current driver in a special way, or a simple uninstall through catalyst installer will be fine?? Let's see if this helps.
My System SpecsSystem Spec
16 Sep 2012   #10
oxymoron02

Windows 7 Ultimate 64-bit
 
 

Uninstall fully first. If you can run something like driver sweeper in safe mode, do this too. It will remove all traces of AMD/ATI drivers but make sure it doesn't select anything else.
My System SpecsSystem Spec
Reply

 Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit




Thread Tools





Similar help and support threads
Thread Forum
BSOD trying to install Sapphire HD5450 Graphics Card
Someone gave me a machine which is a dell 755 sff, I decided to upgrade my graphics with a low profile sapphire HD5450. I installed the drivers on the copy of windows 7 which worked fine, I later found out that the copy of windows was not geniune, so I purchased a geniune copy, when I installed...
Drivers
Installed Windows 7 ultimate 32bit driver problem
ok, so i upgraded my computer from windows xp pro 32bit to windows 7 ultimate 32bit i downloaded all of the needed drivers like wireless internet driver and vga driver, then i downloaded the sound driver and i have a big problem:( took a screenshot:http://i.imgur.com/Bci9v.png and it says...
Hardware & Devices
Strange boot up behaviour after Sapphire HD6770 installed
Hi, I have just upgraded from a Nvidia 8800GT512Mb to a Sapphire radeon HD 6770 Vapour-X GFX card. The PC has always booted fine, even right before the upgrade so I could unistall the Nvidia drivers. Since I added the new card I get several seconds of quiet clicking, then the system...
Graphic Cards
Upgrading from Windows ultimate 32bit to Ultimate 64bit
Can I upgrade from Windows ultimate 32bit ver 6.1 ( build 7600) to windows 7 ultimate 64bit edition and keep all of my installed programs and files ? :huh:
Installation & Setup
Crash as soon as Sapphire HD 5750 drivers installed
Everything seems okay. Installed OS (Win7 Professional 64-bit) Installed Chipset drivers. Ran Windows Update Installed Graphics Card drivers - newest from website Reboot - CRASH - have to boot in Safe Mode & restore to earlier version as system will no longer start properly. Why? What did I...
Graphic Cards
Installed 32bit - would like to try 64 bit
Good morning - I successfully installed Win 7 from the Family Upgrade as 32 bit. Now, after a bit of research, I wish I had used the 64 bit instead. This begs 2 questions - first, will it "cost" me another license to change? Second, is it possible to complete without losing my...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App