Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit


16 Sep 2012   #1

Windows 7 Ultimate 32bit
 
 
Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit

I have recently repaired my motherboard (Intel D945GCNL). After a formatting of my HDD, I installed windows 7 ultimate 32 bit and all my drivers. Downloaded 12-8_vista_win7_win8_32_dd_ccc and installed it. The problem is at startup, it shows the windows 7 logo as starting windows and then the display vanishes as if there is no input. I can access the display when in safe mode or when I uninstall the driver. Then it loads normally and shows generic driver and I cannot utilize my graphics card. The card does not seem to be faulty and relatively newly purchased.

Need your help, am not that tech savvy and at a loss. What should I try to fix?

My System SpecsSystem Spec
.

16 Sep 2012   #2

Windows 7 Ultimate 64-bit
 
 

The output resolution is set to something your monitor cannot support. If you have another monitor, or a TV with a PC input, you could use this to reset the resolution to something more friendly, like 800 x 600 (generally universally supported).
My System SpecsSystem Spec
16 Sep 2012   #3

Windows 7 Ultimate 64-bit
 
 

Oh, although safe mode won't load the AMD drivers to run the graphics card, you might be able to run the program itself. Navigate to its installation location and run it, then see if you can change the resolution that way. When you reboot, hopefully Catalyst will have remembered the resolution you set it to, and apply this resolution (again, I recommend 800 x 600).
My System SpecsSystem Spec
.


16 Sep 2012   #4

Windows 7 Ultimate 32bit
 
 

thanks for the suggestion. Problem is I do not have a spare monitor to work on. But am logging on to safe mode to try to run the program. Let's see how that turns out.
My System SpecsSystem Spec
16 Sep 2012   #5

Windows 7 Ultimate 64-bit
 
 

Also in safe mode before did you change the resolution up or down? You'll want to change it down. What make and model is your monitor? It'll be written on the back.
My System SpecsSystem Spec
16 Sep 2012   #6

Windows 7 Ultimate 32bit
 
 

I could not change through CCC in safe mode, it could not load the device; probably because of the safe mode cause it is showing my device in the device manager. Set the resolution to 800X600 but did not help. My monitor is Samsung Syncmaster 794MG (CRT). Any suggestion??
My System SpecsSystem Spec
16 Sep 2012   #7

Windows 7 Ultimate 64-bit
 
 

Your monitor can support 1280 x 1024 which means it is a 4:3 ratio, so 800 x 600 should have been fine. Clearly the problem is more deeply rooted. If you change the settings and then reboot into safe mode a second time, does Catalyst stay on the resolution you changed it to?


The only other thing we can try is an older version of Catalyst. Try to find 12.4 online, but of course be wary of where you download from. If at all in doubt, post any links you find here, and I will check them out (and get a virus lol ).
My System SpecsSystem Spec
16 Sep 2012   #8

win7 home premium 32bit OEM System Builder Pack
 
 

try uninstalling the 12.8 driver for graphic card. i had issues with it. im using the 12.6 driver and works great now.
My System SpecsSystem Spec
16 Sep 2012   #9

Windows 7 Ultimate 32bit
 
 

Catalyst does not run as I could not reboot in the normal mode after the software installation and safe mode also does not load catalyst. The screen resolution stays the same once i change it and reboot. downloading 12.4 from cnet, do i require to uninstall the current driver in a special way, or a simple uninstall through catalyst installer will be fine?? Let's see if this helps.
My System SpecsSystem Spec
16 Sep 2012   #10

Windows 7 Ultimate 64-bit
 
 

Uninstall fully first. If you can run something like driver sweeper in safe mode, do this too. It will remove all traces of AMD/ATI drivers but make sure it doesn't select anything else.
My System SpecsSystem Spec
Reply

 Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit




Thread Tools



Similar help and support threads for2: Need help to get Sapphire HD5450 1 GB installed in 7 ultimate 32bit
Thread Forum
Solved Installed Windows 7 ultimate 32bit driver problem Hardware & Devices
Strange boot up behaviour after Sapphire HD6770 installed Graphic Cards
SAPPHIRE 3650 AGP problems (W7 ultimate 64bit) Graphic Cards
Upgrading from Windows ultimate 32bit to Ultimate 64bit Installation & Setup
Crash as soon as Sapphire HD 5750 drivers installed Graphic Cards
Installed 32bit - would like to try 64 bit Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:33 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33