Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sapphire 4670 problem

19 Sep 2009   #1
ATTILA04

WINDOWS7
 
 
sapphire 4670 problem

hey i just signed in this forum.and i need some serious help.i bought a sapphire 4670 graphics card few days ago.then when i tried to rate it using windows7 experience index my display goes off and then never comes again.i restart the pc but in vain.my pc dont get my card anymore.i went to the retailer and took a new card.the new card also showed same problem.the second card was also gone when i tried to rate.and the cards dont work anymore in any other pc.how windows7 rating possibly can damage a card permanently.by the way i ran the rating without installing the ati drivers.by using the driver windows installs automatically .i am really screwed up with all this.i used a nvidia 8500 gt before.it was running fine in my system.pls pls some1 help me.


My System SpecsSystem Spec
.

19 Sep 2009   #2
Tews

64-bit Windows 8.1 Pro
 
 

Please fill in your system specs so we know what we're dealing with...Help us help you!
My System SpecsSystem Spec
19 Sep 2009   #3
zigzag3143

Win 8 Release candidate 8400
 
 

cant run wei index rating without drivers and expect normal results. If you can boot into safe mode, you can install the video driver there.

Ken
My System SpecsSystem Spec
.


19 Sep 2009   #4
ATTILA04

WINDOWS7
 
 

thanks zigzag for the reply.but my graphics card is totally gone.my pc dont get that even in the safe mode even.so how can i install drivers.i took the third new card from the retailer and running it in windows xp now.its doing fine.absolutely fine in xp.
My System SpecsSystem Spec
19 Sep 2009   #5
zigzag3143

Win 8 Release candidate 8400
 
 

attila

so you are saying that the card works in xp but not in win 7? As long as you are not over clocking, and have enough power the cahnces are the problem is a driver and not hardware.

Can you tell us more about the problem

Ken
My System SpecsSystem Spec
19 Sep 2009   #6
ATTILA04

WINDOWS7
 
 

zigzag,just try to understand me brother.
1.i bought a card then damaged it,while rating with windows7.then took another new 4670 card from the retailer cause i had warrenty.

2.i did the same thing with the 2nd card.and also damaged that card.again i went to the retailer and got another 4670 from him.(its the 3rd card i took).cause still i have warrenty.
3.i took the third card and now using it with xp.i didn't tried windows 7 rating with 3rd card.cause the rating permanently damaged previous two cards.and the only solution for that is replacing it.

i think you got me now.can you help me?i am too much helpless in this matter.and thanks for listening.
My System SpecsSystem Spec
19 Sep 2009   #7
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by ATTILA04 View Post
zigzag,just try to understand me brother.
1.i bought a card then damaged it,while rating with windows7.then took another new 4670 card from the retailer cause i had warrenty.

2.i did the same thing with the 2nd card.and also damaged that card.again i went to the retailer and got another 4670 from him.(its the 3rd card i took).cause still i have warrenty.
3.i took the third card and now using it with xp.i didn't tried windows 7 rating with 3rd card.cause the rating permanently damaged previous two cards.and the only solution for that is replacing it.

i think you got me now.can you help me?i am too much helpless in this matter.and thanks for listening.

Got you now what do you want help with?

Ken
My System SpecsSystem Spec
19 Sep 2009   #8
ATTILA04

WINDOWS7
 
 

now i wanna know what i should do to use my card in windows7.i am afraid if i try to rate again my 3rd card will also damage.can you give me any way how can i use this card without damaging it in windows7.
thanks again for the support.
My System SpecsSystem Spec
19 Sep 2009   #9
johngalt

 

I think it is going to be a power issue more than anything - your specifications are incomplete - in particular, I went searching for an Intel dual core processor clocked at 2.5 GHz and did not find one - you need *accurate* specifications (see my System specs for answers) and then use eXtreme Power Supply Calculator Lite v2.5 to calculate what you really need in terms of a PSU.

For example, under load, according to ATI Radeon HD 4670 review you'll need 207 W of power just for the video card - and you only have 420 to begin with....
My System SpecsSystem Spec
19 Sep 2009   #10
jfar

Vista Ult64, Win7600
 
 

Hi, Attila04, did you download the latest drivers for your card from the Asus site.
I hope this helps you.

http://www.asus.com/
My System SpecsSystem Spec
Reply

 sapphire 4670 problem




Thread Tools





Similar help and support threads
Thread Forum
Sapphire R7 240 multimonitor problem
I am using a Dell Optiplex 780. I have added a R7 240 GC to the pc so that I can use multimonitor setup. My setup are: 1x 19" monitor -VGA (1024x768p) 1x 23" monitor -DVI (1920x1080p) However, while I can connect both monitors to the card. I get a duplicated display which is annoying. The...
Graphic Cards
Sapphire radeon hd 4670 - Need Help!!!!!!!!!!
I am facing a lot of problem with my Sapphire radeon hd 46701gb ddr3 card. This is my second thread to help me for solving this problem. Aero doesn't run even with the latest driver or the old drivers i have tried all the things like enable force to run aero that doesn't work. And also use services...
Graphic Cards
ATI Radeon 4670 Display Port Problem
I have an ATI Mobility Radeon HD 4670 (on my Dell Studio XPS 1640 notebook) and I just tried to use my external monitor (Dell P2210) through a DisplayPort cable, but it did not work in Windows 7 (x64). It did display the BIOS and the Windows startup screen, but after the startup the (external)...
Graphic Cards
Sapphire Radeon HD 4670 and second VGA card problem
Had a frustrating afternoon trying to get my triple-monitor setup going again; I had WinXP for years with two video cards: a single, simple VGA / PCI card, and a recent Radeon HD 4670 card with two outputs. Under XP everything was recognized without incident, first repeating all three monitors and...
Graphic Cards
His HD 4670 ATI Vga Problem !
Hello, I have a "HIS HD 4670 IceQ Native HDMI 1GB (128bit) 850 MHz DDR3 PCIe" VGA.in windows xp i can play games need for speed - SHIFT, Resident evil 5 with maximum graphic details.No problems at all But in windows 7 above games are really slow even if i choose medium graphic details. I...
Drivers
help ATI 4670 driver problem
Everytime I try and install catalyst 9.6/driver, my screen will display only the background picture, nothing else. Ctrl-alt-del turns the screen black, esc out and back to background picture. Had to go safe mode and system restore everytime. Driver shows up in microsoft updates and same result....
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App