Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Black screen after installing graphics drivers

24 Sep 2009   #11
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Muscar View Post
Quote   Quote: Originally Posted by torrentg View Post
As I mentioned, it's probably installing and then setting an incorrect refresh rate. Follow what I said to set it right.
Changing the resolution to a low one doesn't help, the screen is still black.
You mean you set a low resolution in safe mode, then rebooted, and it's still black then? There's also a vga mode to boot into that could possibly be of some use if uninstalling the driver method doesn't help. Maybe you could boot into that and have access to settings. I dunno, never tried it myself.


My System SpecsSystem Spec
.
24 Sep 2009   #12
Muscar

OS X SL, Windows 7
 
 

Quote   Quote: Originally Posted by jfar View Post
Go to Device Manager, and uninstall your driver from there.
The one in the the "Display adapters" right?

Sorry for the inconvenience.
My System SpecsSystem Spec
24 Sep 2009   #13
torrentg

7600.20510 x86
 
 

yep
My System SpecsSystem Spec
.

24 Sep 2009   #14
Muscar

OS X SL, Windows 7
 
 

Hmm, so I went into the device manager, uninstalled what I should and rebooted into normal mode, it then downloaded the graphics drivers and said: Nvidia blabla something was successfully installed and it wanted me to reboot, so I did and now the screen is black again.
My System SpecsSystem Spec
24 Sep 2009   #15
Muscar

OS X SL, Windows 7
 
 

Windows failed to start now, so I did repaired it. Works fine at the moment.

So I should not download and install any graphics drivers?
My System SpecsSystem Spec
24 Sep 2009   #16
jfar

Vista Ult64, Win7600
 
 

I wouldn't do anything for a while, and see how it gets on, it is working now isn't it.
My System SpecsSystem Spec
24 Sep 2009   #17
zigzag3143

Win 8 Release candidate 8400
 
 

Nope If display is correct leave it.
My System SpecsSystem Spec
24 Sep 2009   #18
Muscar

OS X SL, Windows 7
 
 

Windows does feel very slow and laggy. I'll have to try and play a game and see if it's the same there.
My System SpecsSystem Spec
24 Sep 2009   #19
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Quote   Quote: Originally Posted by Muscar View Post
Windows does feel very slow and laggy. I'll have to try and play a game and see if it's the same there.
Also please go into your user CP and flll in your entire system specs this will help everyone who is trying to help to know what all your hardware is. Thanks and welcome to sevenforums. Glad it is working. Fabe
My System SpecsSystem Spec
24 Sep 2009   #20
Muscar

OS X SL, Windows 7
 
 

Quote   Quote: Originally Posted by thefabe View Post
Quote   Quote: Originally Posted by Muscar View Post
Windows does feel very slow and laggy. I'll have to try and play a game and see if it's the same there.
Also please go into your user CP and flll in your entire system specs this will help everyone who is trying to help to know what all your hardware is. Thanks and welcome to sevenforums. Glad it is working. Fabe
I will, thank you!
My System SpecsSystem Spec
Reply

 Black screen after installing graphics drivers




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Big black bar on side of screen after installing geforce drivers
I just started up my new computer and everything was fine. The monitor i'm using that's getting this problem is a Wacom Cintiq 21ux drawing tablet, and the video card i'm using is Asus GeForce GTX 780 Ti. Everything was fine until I installed the latest Asus drivers, and after I restarted my...
Graphic Cards
Graphics Card Drivers Not Installing. Please HELP!
Hi I went to NVIDIA and downloaded the graphics driver for my graphics card and they aren't installing. I get the error message: Please help. I have a Geforce 440 GT.
Graphic Cards
BSOD after installing Graphics Drivers
Hi, The problem I'm having right now is the fact that last night my computer decided to just shut itself down randomly after me starting up World of Warcraft. Afterwards it would only give me BSOD's with BCCode 116. As it had been some time since a fresh install (over a year probably) I figured...
BSOD Help and Support
BSOD After installing graphics drivers
After installing the drivers for my ATI Radeon HD 6450,I am asked to restart my computer. Every time I just get a blue screen on startup and have to restore from backup. I've attached a zip file of the logs from the BSOD.
BSOD Help and Support
Black Screen after installing ATI Catalyst Drivers
Hi, the first time I installed Windows 7 Professional (clean install, not upgrade) and installed the catalyst drivers for my HD5750 video card (http://game.amd.com/us-en/drivers_catalyst.aspx?p=win7/windows-7-64bit), everything worked fine. I ended up formatting my hard drive and doing a...
Graphic Cards
Installing Nvidia graphics drivers
Hi, I am looking to sort out my graphics drivers for my new computer and just want to make sure I get it right and so avoid any kind of nightmare, I am sure some of you will be able to point me in the right direction.... I have a GTS250 card installed on my PC running windows 7 64 bit. It is...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App