Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI driver bug?

24 Sep 2009   #1

Windows 7 x64
ATI driver bug?

I've been using Windows 7 since the RTM was released, since the new fall tv line up started I began to view full episodes on network's website as always. I realized that either the ATI driver or Windows 7 have a problem with flash videos (or flash?). I never experienced something wrong before with Windows XP , the playback was smooth (considering all 24p movies with 75hz refresh) but now in 720p is annoying jerky, cbs 1080p is literally unwatchable, Youtube's 720p files are really jerky. I also tried BBC player (with a proxy), same results.
I'm sure it's a software problem (maybe they added a new useless feature in windows 7 drivers that does that) since this only happens when I'm in fullscreen and the cpu usage is always below 30% with HD streaming. Again, this only happens in flash, no problem with videos played with local players, even 1080p Blu-Rays are flawless with both software and hardware decoding.

I tried to reinstall Windows XP to see if maybe I was mistaken but the problem doesn''t present there, everything's fine. Plus I tried another PC with Windows 7 with a "crappy" NVIDIA integrated video card, no jerkiness, even with CBS 1080p streaming.

I have an ATI HD 2600 PRO, I tried to reinstall 9.7 and 9.8 drivers with no change, does anybody have the same problems and maybe a solution?


My System SpecsSystem Spec
26 Sep 2009   #2

Windows 7 ultimate 64 bit / XP Home sp3

Do you have adobe reader and the flash player 10 pugin installed maybe it would play better with a flash player. Welcome to sevenforums. Also would you please go to your user CP and fill in al your systems specs unfortunately some people won't even tyr and help without all this information avalaible to them. Fabe
My System SpecsSystem Spec
26 Sep 2009   #3

Windows 7 Professional x86 RTM

Do right click on the flash video->Settings->disable hardware acceleration

There is a problem with Windows 7+flash and old Ati cards.
My System SpecsSystem Spec


 ATI driver bug?

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Multiple BSOD. Driver Verifier Driver caught a driver corrupting
I have had BSOD for a while and being super busy I did not have time to look at it and get it fixed. Well Being a computer guy I assumed I could fix it myself. But with tons of research and trying to use every guide I can find I decided to try here(probably should have came here first). Today I...
BSOD Help and Support
BSOD Windows 7 update mp3 player driver conflict, graphics driver
Hi, and thanks in advance... Much of this is a repeat to other threads, until the graphic driver problem at the end... (I also have an Ubuntu partition.) I'd left my mp3 player plugged in overnight + an Asus Xonar DAC in a usb hub, when Windows wanted to do an update and conflict over...
BSOD Help and Support
BSOD driver power state / Nvidia graphics driver problems
Hello, After many many hours of searching forums for solutions I have been unable to find a solution to my problem - so I decided to open a topic of my own and hope someone can help me with my problem specifically. My problem is similar to this topic, although the solutions posted there...
BSOD Help and Support
No drivers found. click load driver to provide a mass storage driver f
Okay so, my laptop's system is unable to boot, so I just tried to format it since I have to do that for a very long time, and when it asked me in which partition I want to install windows there was nothing, although when I clicked "Load Driver" I could access the hard disk's files, the hard disk IS...
Hardware & Devices
Display driver Intel Graphics Accelerator Driver for Windows XP Stop
I am not sure if this is where it belongs, or if it is a Graphics Card issue. I have an Acer Aspire 7741z-4433 with an Intel(R) Pentium(R) p6200 (2.13 GHz, 3MB 1.3 cache). This only happens to me while I am playing The Sims 3. I have the game set on the lowest quality settings, even though my...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:26.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App