Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ATI Radeon HD 5450 Driver problem!


04 Nov 2012   #11

Win7 Home Premium 64 bit
 
 

When you installed the new video drivers did you uninstall the previous version first or did you just install the newer version over the old one.


My System SpecsSystem Spec
.

04 Nov 2012   #12

Windows 7 Home Premium 64 bit
 
 

It seems like your having a driver problem. Remove the driver using device manager, reboot your computer and download the latest driver from amd here AMD Driver Autodetect
My System SpecsSystem Spec
04 Nov 2012   #13

Windows 7 x86 Ultimate
 
 

Quote   Quote: Originally Posted by Invader440 View Post
When you installed the new video drivers did you uninstall the previous version first or did you just install the newer version over the old one.
Before anything, I would like to thank you all guys for helping me out!
First i launched the game. Then a saw that the driver is out of date. After that i went to amd.com and downloaded AMD Catalyst 11.7, that was the minimum needed. When i installed it, nothing changed. Tried the same with AMD Catalyst 12.8, but nothing changed, same problem... Downloaded AMD Driver autodetect, the program detected AMD Catalyst 12.10 as best for my GPU. THE SAM ERROR APPEARS WITH ANY AMD CATALYST PACK!

So yes, in fact, i did install the newer version over the old one...
My System SpecsSystem Spec
.


05 Nov 2012   #14

Windows 7 Home Premium 64 bit
 
 

What I meant was to completely uninstall the driver not just over it.
My System SpecsSystem Spec
05 Nov 2012   #15

Windows 7 x86 Ultimate
 
 

Yea, i understand what you mean, but I was thinking... If I uninstall the driver, and restart the computer, then run the AMD Driver autodetect, it will start downloading the "best" driver for my card... That will take about 10min, but windows will automaticly download the same driver (that i had previously uninstalled), before the AMD Catalyst driver is installed ... Then i get to the same point, and i am installing a new driver over the old one... Am I correct??? I think it won't work... But if you say that it may work I'll try it, and see what happens
My System SpecsSystem Spec
05 Nov 2012   #16

 

Search up the Web regarding complete driver removal. Also avoid any auto detect stuff for everything. Your safest bet with this would be to go full manual from downloading to installation. I have bad this before and that fixed it for me although I didn't use auto detect but updated drivers over existing one. That was a 4850 card. Else search up nfs issues like the one you have. Probably a configuration thing. My 4850 worked nicely after a full sweep and a clean installation
My System SpecsSystem Spec
05 Nov 2012   #17

Windows 7 x86 Ultimate
 
 

I found some Nvidia drivers that windows downloaded as an update. should i uninstall them?? My mobo has 2 PCI-E slots for 2 Nvidia cards... Maybe thats messing up my ATI drivers??? What do you say?


Attached Thumbnails
ATI Radeon HD 5450 Driver problem!-capture.png  
My System SpecsSystem Spec
05 Nov 2012   #18

 

Unless you're set up for dedicated phys x then yes you should remove them. If you have an on board graphics component set your pcie as main in your bios. I may be wrong on this part since I've always been amd/ati user with one exception 2 gens ago with a dedicated phys x, and a 4850 but I think the optimized for sli or xfire is just branding and if it isn't just branding it shouldn't matter on a single card solution. Anyhow you should do a complete removal for it including registry entries and files in parts of your drive that remains after uninstalling. Do it manually instead of using a tool. Remove both drivers amd and nvidia and fresh install amd. If one of the installed nvidia progs is labelled phys x u won't have to worry about it. But best be safe and try out amd ccc without any other gpu drivers / tools to avoid conflicts
My System SpecsSystem Spec
05 Nov 2012   #19

 

Ps: using phone at the moment can't see your print screen
My System SpecsSystem Spec
05 Nov 2012   #20

Windows 7 x86 Ultimate
 
 

After uninstalling the Nvidia Drivers, all i lost was the internet connection
I uninstalled all drivers for my GPU, and then downloaded AMD Catalyst 12.10. installed it and this are the results. (1st image)
After that i ran Need For Speed and it says2nd image)
I uninstalled AMD 12.10 and installed AMD 11.7. Then, this is the result of instalation: (3rd image)...
The Aero in Windows didn't appear... And there is the lag when i drag a folder over my desktop...
The final result is the same as before. It doesn't work...
I currently don't have any driver installed for my GPU...


Attached Thumbnails
ATI Radeon HD 5450 Driver problem!-untitled1.png   ATI Radeon HD 5450 Driver problem!-error.png   ATI Radeon HD 5450 Driver problem!-untitled-radi.png  
My System SpecsSystem Spec
Reply

 ATI Radeon HD 5450 Driver problem!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:08 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33